none
SharePoint Designer "failed to load this workflow"

    Question

  • SharePoint Designer 2013 is behaving very strangely: I can create a 2013 workflow, publish it, use it just fine.... until the next day or some short time after when I try to reload it and recieve this message:

    "Failed to load this workflow. To correct this problem, restart SharePoint Designer."

    Click ok then SPD show a page titled "SharePoint Designer cannot display the item." & "hit f5 to refresh"

    Hit f5 and you are met with the rather baffling alert error: "Windows Workflow Foundation, part of .Net Framework 3.0, must be installed to use this feature."

    The SP site and WF service are using https.

    Any clues as to what might cause this behaviour??

    Tuesday, April 23, 2013 8:04 AM

Answers

  • Thanks for your replay Michael! I had tried all of that except the Troubleshooting page, which was very helpful.

    To, vaguely, answer my own question...

    The issue seems to be related to users, and more specifically to my work place using AD two domains (the tech are in the middle of transitioning). They setup a trust between the two domains and theoretically there shouldnt have been a problem but as soon as I stopped mixing domains the problem went away.

    By mixing doamins I mean I was creating workflows in designer with my desktop login user (domainA) on a sharepoint environment hosted in domainB.

    When I recreated the workflows from scratch with a user from domainB (on a computer in domainB just to be sure), the problem didnt not reoccur.


    Friday, April 26, 2013 7:21 AM

All replies

  • Hi Russel,

    I don't know what could be the cause of the issue, but there are some things you can try to fix it:

    1. Clear the cache of SPD. It is located in these folders:

    %APPDATA%\Microsoft\Web Server Extensions\Cache
    %USERPROFILE%\AppData\Local\Microsoft\WebsiteCache

    2. Try to re-register Workflow Service using the following PowerShell cmdlet:

    Register-SPWorkflowService -SPSite ‘https://myhost/mysite’ -WorkflowHostUri ‘https://workflowhost’ -AllowOAuthHttp -Force

    3. If it doesn't help, try to read this article about Troubleshooting Workflow Manager 1.0 Management and Execution.

    4. Take a look at the logs, probably there is some clues (WF Manager, Events, ULS). Here is an article how to enable debug logs for Workflow Manager.

    Hope some of it helps. Please, let us know whether it helps (and what was solution if it does).

    ______________________________________________

    Regards, Michael (http://sp2013-blog.com)

    Tuesday, April 23, 2013 8:22 AM
  • Thanks for your replay Michael! I had tried all of that except the Troubleshooting page, which was very helpful.

    To, vaguely, answer my own question...

    The issue seems to be related to users, and more specifically to my work place using AD two domains (the tech are in the middle of transitioning). They setup a trust between the two domains and theoretically there shouldnt have been a problem but as soon as I stopped mixing domains the problem went away.

    By mixing doamins I mean I was creating workflows in designer with my desktop login user (domainA) on a sharepoint environment hosted in domainB.

    When I recreated the workflows from scratch with a user from domainB (on a computer in domainB just to be sure), the problem didnt not reoccur.


    Friday, April 26, 2013 7:21 AM
  • I have the same issue occuring repeatedly

    >edit an existing Moss 2013 workflow or create a new one 

    >error message asks to restart Sharepoint Designer 

    >F5 displays error message Windows Workflow Foundation, part of .Net Framework 3.0, must be installed to use this feature."

    >restart doesn't help

    it seems this is caused by the cache of Sharepoint Designer 

    the solution that works is to empty the matching folders

    %APPDATA%\Microsoft\Web Server Extensions\Cache

    %APPDATA%\Microsoft\SharePoint Designer\ProxyAssemblyCache

    C:\Users\<username>\AppData\Local\Microsoft\WebsiteCache



    • Edited by CDH2009 Friday, July 05, 2013 12:37 PM missing step
    Friday, July 05, 2013 12:36 PM
  • I', having this extac issue. Did you guys managed to solve this? Thanks in advance.

    Tuesday, November 05, 2013 4:16 PM
  • Tiago or anyone,

    Did you ever get this problem resolved?

    Saturday, July 19, 2014 4:51 AM
  • In my case I had to install this to make it work... even though I'm not using VS 2005
    Visual Studio 2005 extensions for .NET Framework 3.0 (Windows Workflow Foundation)
    http://www.microsoft.com/en-us/download/details.aspx?id=23072

    You need to restart SPD after installing the extensions

    • Proposed as answer by Adam Toth Monday, August 15, 2016 8:52 PM
    Monday, April 20, 2015 10:22 PM
  • Installing those extensions made it work for me, thanks Jean!
    Monday, August 15, 2016 8:53 PM