none
The Application Data folder for Visual Studio could not be created RRS feed

  • Question

  • Hey,

    I've seen many posts on these forums with this problem and I've tried all the suggested things in those forums, but the problem still persists. 
    The version of VS I've installed is Visual Studio 2010 professional and my operating system is Windows 7 Ultimate with system pack 1.

    Just to clerify what my problem is, when I try to launch devenv it gives me the error "The Application Data folder for Visual Studio could not be created.".

    Here is what I've tried so far
    -Uninstalling/re-installing/repairing visual studio.
    -Made sure that the appdata and application data folders all have admin privlages.
    -I've tried using Microsoft's fixit
    -I've checked regedit to make sure that AppData's path was %USERPROFILE%\AppData\Roaming

    Is there anything else that I've missed?

    Thanks

    Monday, February 13, 2012 3:11 AM

Answers

  • Hi quadef,

    Welcome to the MSDN forum.
    After my search, many of our customers solved this issue by this step:
    Please refer to this article:
    http://technetlk.blogspot.com/2010/08/application-data-folder-for-visual.html
    Note: before you edit the registry, you’d better export the keys in the registry that you plan to edit, or back up the whole registry.
    If this workaround didn’t work, please try running devenv.exe /log <log path> in Command Prompt. The log files will be generated in the <log path>. Then you can check and analyze the log file to see if there is anything incorrect. After that, you can also post your log file to a public site, like SkyDrive, and post the link here so that I can help you. (This log is easier to read than Process Monitor, so we can collect this log first).
    If you have any updates, please feel free to let me know.

    Best regards,


    Barry Wang [MSFT]
    MSDN Community Support | Feedback to us


    Tuesday, February 14, 2012 5:05 AM
    Moderator

All replies

  • Hi quadef, have you tried creating a new adminstrator user account on your computer and from there try to launch VS and see if you still get the error?
    Monday, February 13, 2012 3:29 AM
  • Ah, yes I have done that. Forgot to mention that.

    Anything else that I could try?

    Monday, February 13, 2012 3:49 AM
  • Hi quadef, do you happen to be using Windows 7 Ultimate 64bit? If you are, please have a look at this thread and see if it helps you.

    If the above does not help, please download the Process Monitor Tool to capture the activity of devenv.exe while it is being launched. Once you have downloaded it, launch the Process Monitor Tool first, and then click "Filter" from the menu bar. After that, click "Filter" again, and a new window will popup.

    You will see a drop down list showing "Architecture". Change that to "Process Name". After that, in the textbox on the right, enter "devenv.exe", and press the "Add" button below, then press the "Ok" button. Once done, launch VS 2010.

    After the error appears, click "Ok", and go back to the Process Monitor Tool. Click "File" from the menu bar, and then click "Save". After that, take note of where you are saving the file (LogFile.PML), and click the "Ok" button.

    Once done, please upload LogFile.PML to SkyDrive or any online file hosting service and then post the link back here again so that readers can have a look at the logs for further analysis, thanks!


    • Edited by systemx Monday, February 13, 2012 6:13 PM
    Monday, February 13, 2012 6:13 PM
  • Hi quadef,

    Welcome to the MSDN forum.
    After my search, many of our customers solved this issue by this step:
    Please refer to this article:
    http://technetlk.blogspot.com/2010/08/application-data-folder-for-visual.html
    Note: before you edit the registry, you’d better export the keys in the registry that you plan to edit, or back up the whole registry.
    If this workaround didn’t work, please try running devenv.exe /log <log path> in Command Prompt. The log files will be generated in the <log path>. Then you can check and analyze the log file to see if there is anything incorrect. After that, you can also post your log file to a public site, like SkyDrive, and post the link here so that I can help you. (This log is easier to read than Process Monitor, so we can collect this log first).
    If you have any updates, please feel free to let me know.

    Best regards,


    Barry Wang [MSFT]
    MSDN Community Support | Feedback to us


    Tuesday, February 14, 2012 5:05 AM
    Moderator
  • I have the same problem, here is the log file 

    https://skydrive.live.com/redir.aspx?cid=ff517829747ea8ee&resid=FF517829747EA8EE!125&parid=FF517829747EA8EE!123&authkey=!ACgplMjK_R8KUiQ

    thx for your help

    • Proposed as answer by HASANAHN Friday, May 31, 2013 10:25 AM
    Tuesday, February 14, 2012 8:24 AM
  • I had the same Issue too but finally i found the solution :

    it was that i had no permission on the following folder "C:\ProgramData\Microsoft\VisualStudio\10.0"

    • Proposed as answer by Ian Homonnai Monday, August 6, 2012 10:48 AM
    Monday, April 2, 2012 2:32 PM
  • I had the same Issue too but finally i found the solution :

    it was that i had no permission on the following folder "C:\ProgramData\Microsoft\VisualStudio\10.0"

    It works! Thanks.

    • Edited by E u g e n e Tuesday, September 18, 2012 10:28 AM
    Tuesday, September 18, 2012 10:27 AM
  • To,

     Sir

    Below error

    The Application Data folder for Visual Studio could not be created

    your ans - it was that i had no permission on the following folder

    pl. send me details

    thanking you

    Sanadi M.H. 9975376688

    Friday, May 31, 2013 10:42 AM
  • Changing the following envionment variable(s) resolved this for me [ Windows 10 Visual Studio 10.0 ]

    USERNAME=Administrator
    USERPROFILE=c:\Users\Administrator

    Replaced 'Administrator' with another 'User' [ possibly the User name used when loading Visual Studio 10 ]

    Hope this helps


    • Edited by PatPog Friday, October 4, 2019 1:50 PM Poor Spelling ;-)
    Friday, October 4, 2019 1:49 PM