none
"Insert as List Form Field" not available on Data Source Details panel when editing EditForm.aspx

    Question

  • I used Designer 2010 to create a new EditForm.aspx for a list and called it CustomEditForm.aspx. I did a fair amount of work to customise the form.

    Later, I realised I wanted to add an extra column to the list so in SharePoint 2010, I added the extra column to the list.

    I went back to Designer to try to add that new column to my CustomEditForm.aspx but am not able to get the column/field into my form using the documented method.

    In the "Data Source Details" panel, the new field is there, but when I try to drag it onto the form, nothing useful happens. When I right click the field in the "Data Source Details" panel, I know there should be an option to  Insert as List Form Field. I do not get that option. See screenshot below.

    I've seen this exact problem reported elsewhere but have not found an answer as to how to make that option available.

    Yes, there are cumbersome workarounds involving creating another new form from scratch, etc, but I want to understand how to get Designer working the way it should and can. Anyone known what's up?

    Thanks.

    Thursday, July 4, 2013 11:40 AM

Answers

  • In case this helps anyone, I'll point out that I did seem to solve my problem of adding a new column to my customised form using a workaround. I created another new form for the list, which automatically contains the new column (CallRef) because I'd already added it in SharePoint. I then copied the HTML for that column from the new form and pasted it into my custom form. I then changing the ff codes in the pasted HTML to be 1 more than the last ff code already in the custom form.

    ie. the code below is the HTML for the new column, and I looked at the ff value of the last row in my custom form that has a form field on it (it had an ff value of 14), and so changed the ff values for my new column to be 1 more than that (15).

    <tr>

    <td width="190px" valign="top">

    <H3>

    <nobr>CallRef</nobr>

    </H3>

    </td>

    <td width="400px" valign="top">

    <SharePoint:FormField runat="server" id="ff15{$Pos}" ControlMode="New" FieldName="CallRef" __designer:bind="{ddwrt:DataBind('i',concat('ff15',$Pos),'Value','ValueChanged','ID',ddwrt:EscapeDelims(string(@ID)),'@CallRef')}"/>

    <SharePoint:FieldDescription runat="server" id="ff15description{$Pos}" FieldName="CallRef" ControlMode="New"/>

    </td>

    </tr>

    This seems to work.

    But I continued to play some more to try to get to the bottom of the missing Insert as List Form option and noticed that in my custom form, if click somewhere near the bottom of it and then:

    • Insert (tab in ribbon) > Edit Item Form > then choose my list

    it inserts a form beneath my existing custom form and I am able to insert columns using Insert as List Form, but only for the new form inserted at the bottom, not for area of the existing custom form. I don't have a clear idea what this signifies technically but perhaps it will trigger something in someone's mind which will help explain the original problem.


    Thursday, July 4, 2013 2:50 PM

All replies

  • I am also searching for the exact same solution.

    It's very frustrating.

    Thursday, July 4, 2013 2:25 PM
  • In case this helps anyone, I'll point out that I did seem to solve my problem of adding a new column to my customised form using a workaround. I created another new form for the list, which automatically contains the new column (CallRef) because I'd already added it in SharePoint. I then copied the HTML for that column from the new form and pasted it into my custom form. I then changing the ff codes in the pasted HTML to be 1 more than the last ff code already in the custom form.

    ie. the code below is the HTML for the new column, and I looked at the ff value of the last row in my custom form that has a form field on it (it had an ff value of 14), and so changed the ff values for my new column to be 1 more than that (15).

    <tr>

    <td width="190px" valign="top">

    <H3>

    <nobr>CallRef</nobr>

    </H3>

    </td>

    <td width="400px" valign="top">

    <SharePoint:FormField runat="server" id="ff15{$Pos}" ControlMode="New" FieldName="CallRef" __designer:bind="{ddwrt:DataBind('i',concat('ff15',$Pos),'Value','ValueChanged','ID',ddwrt:EscapeDelims(string(@ID)),'@CallRef')}"/>

    <SharePoint:FieldDescription runat="server" id="ff15description{$Pos}" FieldName="CallRef" ControlMode="New"/>

    </td>

    </tr>

    This seems to work.

    But I continued to play some more to try to get to the bottom of the missing Insert as List Form option and noticed that in my custom form, if click somewhere near the bottom of it and then:

    • Insert (tab in ribbon) > Edit Item Form > then choose my list

    it inserts a form beneath my existing custom form and I am able to insert columns using Insert as List Form, but only for the new form inserted at the bottom, not for area of the existing custom form. I don't have a clear idea what this signifies technically but perhaps it will trigger something in someone's mind which will help explain the original problem.


    Thursday, July 4, 2013 2:50 PM
  • OK, the way I have solved this problem is like this:

    1. In SharePoint designer create new form (New or edit Form)

    2. Click on the form to edit it

    3. Click at the top to highlight (WebPartPages:DataFormWebPart)

    4. Press Delete to delete web part

    5.  Click on “div” section on this form (form should be empty at this point)

    6.  Click Insert -> Edit Form (or New Form, depending what form you creating) -> Custom List Form (this is important, make sure it is custom form)

    7. Now you should be able to customize your form including inserting SharePoint:FormField from Data Sources

    DO this before you start customizing the form so the SharePoint:FormField is available.

    Wednesday, August 14, 2013 4:42 PM
  • Thanks hamish!

    I was searching for the same kind of solution. I am just applying your idea.

    Sunday, November 29, 2015 10:47 AM