none
C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\Microsoft.CppCommon.targets(151,5): error MSB6006: "cmd.exe" exited with code -1073741515. RRS feed

  • Question

  • Any idea on what is the error ?

    1>------ Rebuild All started: Project: generator, Configuration: Release Win32 ------

    ...........................

    2>Done executing task "MakeDir".
    2>Done building target "ComputeCustomBuildOutput" in project "zheader.vcxproj".
    2>Target "CustomBuild" in file "C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\Microsoft.CppCommon.targets" from project "C:\eddynet\projects\zheader\zheader\zheader.vcxproj" (target "BuildGenerateSources" depends on it):
    2>Using "CustomBuild" task from assembly "Microsoft.Build.CppTasks.Common, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a".
    2>Task "CustomBuild"
    2>  Forcing rebuild of all source files due to missing command tlog "C:\eddynet\projects\zheader\zheader\Release\custombuild.command.1.tlog".
    2>  C:\eddynet\projects\_sln_all\..\..\bin\generator.exe . acquisitiontypes.xml
    2>  C:\eddynet\projects\_sln_all\..\..\bin\generator.exe . analysistypes.xml
    2>  C:\eddynet\projects\_sln_all\..\..\bin\generator.exe . datamgmttypes.xml
    2>  C:\eddynet\projects\_sln_all\..\..\bin\generator.exe . measurements.xml
    2>  C:\eddynet\projects\_sln_all\..\..\bin\generator.exe . onewire.xml
    2>  C:\eddynet\projects\_sln_all\..\..\bin\generator.exe . systemtypes.xml
    2>  C:\eddynet\projects\_sln_all\..\..\bin\generator.exe . zloginrecordtypes.xml
    2>  Generating files from acquisitiontypes.xml...
    2>  Generating files from analysistypes.xml...
    2>  Generating files from datamgmttypes.xml...
    2>  Generating files from measurements.xml...
    2>  Generating files from onewire.xml...
    2>  Generating files from systemtypes.xml...
    2>  Generating files from zloginrecordtypes.xml...
    2>C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\Microsoft.CppCommon.targets(151,5): error MSB6006: "cmd.exe" exited with code -1073741515.
    2>Done executing task "CustomBuild" -- FAILED.
    2>Done building target "CustomBuild" in project "zheader.vcxproj" -- FAILED.
    2>
    2>Build FAILED.
    2>
    2>Time Elapsed 00:00:00.46
    ========== Rebuild All: 1 succeeded, 1 failed, 0 skipped ==========

    Tuesday, March 12, 2013 3:35 PM

Answers

  • Hi,

    From the error message we can see the error:

    C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\Microsoft.CppCommon.targets(151,5): error MSB6006: "cmd.exe" exited with code -1073741515.

    2>Done executing task "CustomBuild" -- FAILED.

    I guess that you add a wrong command in your CustomBuild task. If we run the execute command in the CMD window. Can it work well?

    Please show the content of the CustomBuild task.

    Best regards,


    Ego [MSFT]
    MSDN Community Support | Feedback to us
    Develop and promote your apps in Windows Store
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Wednesday, March 13, 2013 7:43 AM
    Moderator

All replies

  • Hi,

    From the error message we can see the error:

    C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\Microsoft.CppCommon.targets(151,5): error MSB6006: "cmd.exe" exited with code -1073741515.

    2>Done executing task "CustomBuild" -- FAILED.

    I guess that you add a wrong command in your CustomBuild task. If we run the execute command in the CMD window. Can it work well?

    Please show the content of the CustomBuild task.

    Best regards,


    Ego [MSFT]
    MSDN Community Support | Feedback to us
    Develop and promote your apps in Windows Store
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Wednesday, March 13, 2013 7:43 AM
    Moderator
  • Were you able to resolve your issue if so how? I have the same error derived from a custom build. 

    "I guess that you add a wrong command in your CustomBuild task. If we run the execute command in the CMD window. Can it work well?

    Please show the content of the CustomBuild task." -- How do you do this? I am very new to the VS IDE

    Friday, July 10, 2015 10:04 PM