none
Copy azure sql db never finishes (been 4+ hours)

    Question

  • I've tried twice to copy a db - something I do all the time - in azure sql using the portal and I see from sys.databases that the state is 7 and the state_desc is COPYING.  For one it's been more than 4 hours.  Usually takes 10 mins or less.  I don't see any issues reported in the Azure sql status page.
    Thursday, April 20, 2017 10:18 PM

All replies

  • Copying going OK for me in east region.

    Josh

    !!!

    oops spoke too soon, now I've just tried one from a web job and everything is hosed ... ???

    ... just very slow, seems to be going again now ... portal seemed confused for a time, too

    ... still won't show me my webjobs blade ...

    ... ok, back to norbal.




    • Edited by JRStern Friday, April 21, 2017 12:36 AM
    Thursday, April 20, 2017 10:56 PM
  • Hello,


    Try to cancel the copying process when is taking hours to finish, by dropping the new database as mentioned on a note of below article:

    https://docs.microsoft.com/en-us/azure/sql-database/sql-database-copy

    After that, try to copy the database again.


    Hope this helps.

    Regards,

    Alberto Morillo
    SQLCoffee.com

    Friday, April 21, 2017 3:33 AM
  • copies eventually finished and they are working OK today.

    I suspect that Azure had issues - annoying that they don't report them.  Amazon / AWS seems to be more transparent.

    Friday, April 21, 2017 7:08 PM