locked
SharePoint Farm Backup Error RRS feed

  • Question

  •         Dear Friends,

    I have installed SharePoint 2007 in one box and SQL Server 2008 in separate box running through Windows Server 2008. I have shared a folder for farm backup, that shared folder is smoothly accessible from both the boxes.

    During the backup from SharePoint Central Administration is nothing reflects to shared folder.
    But during full backup using STSADM.exe, backup hangs at 

    [1/18/2010 10:38:14 AM]: Verbose: [SharedServices1_DB] SQL command completed at: 1/18/2010 10:38:14 AM.
    [1/18/2010 10:38:14 AM]: Verbose: Starting object: UserProfileApplication.
    [1/18/2010 10:38:14 AM]: Progress: [UserProfileApplication] 50 percent complete.
    [1/18/2010 10:38:14 AM]: Verbose: Starting object: SessionStateSharedApplication.
    [1/18/2010 10:38:14 AM]: Verbose: Starting object: Shared Search Index.
    [1/18/2010 10:38:14 AM]: Progress: [Shared Search Index] 50 percent complete.
    =================================================================

    finally backup process completed without any error or warning when I had manually deleted the following links one after another from Timer Job Definitions  of SharePoint Central Administration (This is only by STSADM.exe not by SharePoint Central Admin)
     
      1.Search Backup and Restore (backup) application f099b19b-fd2c-4734-9645-d5a14c8c49fd
      2.Search Backup and Restore (pause) application e0ef7f5d-9999-4a25-ae7e-5e1d913e5aa5
      3.Search Backup and Restore (backup) application e0ef7f5d-9999-4a25-ae7e-5e1d913e5aa5
      4.Search Backup and Restore (resume) application e0ef7f5d-9999-4a25-ae7e-5e1d913e5aa5 


    Please also let you know that these all are happening after upgrading my SharePoint farm with service pack2. Along with backup, search and alert system also not working on my farm.


    Please help me to recover from this disaster

    Thanking you.
    Shofiqul

     






     

    • Moved by Daniel Trautman Monday, January 11, 2010 6:29 PM On-Premise SP 2007 backup questions (From:Microsoft Online: SharePoint Online)
    • Edited by Shofiqul Islam Monday, January 18, 2010 6:01 AM
    Monday, January 11, 2010 6:01 AM

Answers

  • More specifically, the SharePoint Farm Account needs to be able to access the share that you created for the backups.

    Jeff DeVerter, MCSE
    Rackspace
    Blog: http://www.social-point.com
    twitter: http://www.twitter.com/jdeverter
    Monday, January 11, 2010 10:22 PM
  • Hi there,

    Ensure that the account carrying out the backup has full permissions to the share and is a member of the administrators group - that may be the reason why you are getting 'Access is Denied' - also check the SQL server has write access to the share

    Cheers

    Geoff
    Monday, January 11, 2010 8:54 PM
  • I see the issue as:
    SharePoint_Config] SQL Server Command: BACKUP DATABASE [SharePoint_Config] TO DISK=@db_loc WITH NAME=@db_name, STATS=5, NOINIT, NOSKIP, NOFORMAT, NOREWIND
     @db_name=SharePoint_Config, @db_loc=\\bd-sharepoint01\SharePointBackup\spbr0001\00000013.bak
    [1/7/2010 1:21:14 PM]: Verbose: [SharePoint_Config] SQL command timeout is set to 1.00 hours.
    [1/7/2010 1:21:14 PM]: Error: Object SharePoint_Config failed in event OnBackup. For more information, see the error log located in the backup directory.

    please check if the account mentioned above has backup operator role access in SQL Server, it seems it is not able to backup the configuration database most likely due to insufficient access.

    I LOVE MS..... Warm Regards, Kshitiz Posting is provided "AS IS" with no warranties, and confers no rights.
    Tuesday, January 12, 2010 12:40 AM

All replies

  • Hi there,

    Ensure that the account carrying out the backup has full permissions to the share and is a member of the administrators group - that may be the reason why you are getting 'Access is Denied' - also check the SQL server has write access to the share

    Cheers

    Geoff
    Monday, January 11, 2010 8:54 PM
  • More specifically, the SharePoint Farm Account needs to be able to access the share that you created for the backups.

    Jeff DeVerter, MCSE
    Rackspace
    Blog: http://www.social-point.com
    twitter: http://www.twitter.com/jdeverter
    Monday, January 11, 2010 10:22 PM
  • I see the issue as:
    SharePoint_Config] SQL Server Command: BACKUP DATABASE [SharePoint_Config] TO DISK=@db_loc WITH NAME=@db_name, STATS=5, NOINIT, NOSKIP, NOFORMAT, NOREWIND
     @db_name=SharePoint_Config, @db_loc=\\bd-sharepoint01\SharePointBackup\spbr0001\00000013.bak
    [1/7/2010 1:21:14 PM]: Verbose: [SharePoint_Config] SQL command timeout is set to 1.00 hours.
    [1/7/2010 1:21:14 PM]: Error: Object SharePoint_Config failed in event OnBackup. For more information, see the error log located in the backup directory.

    please check if the account mentioned above has backup operator role access in SQL Server, it seems it is not able to backup the configuration database most likely due to insufficient access.

    I LOVE MS..... Warm Regards, Kshitiz Posting is provided "AS IS" with no warranties, and confers no rights.
    Tuesday, January 12, 2010 12:40 AM

  • Hello Geoff,


    Thanks for your reply. I have edited my question because after giving change permission to "everyone" on shared folder the question's scenario has been changed. Please look into the current problem and suggest me.

    Thanks again.

    Shofiqul



    shofiq
    Monday, January 18, 2010 6:15 AM

  • Hello Kshitizs,

    I have edited my question because after giving change permission to "everyone" on shared folder the question's scenario has been changed. Please look into the current problem and suggest me.

    Thank you.

    Shofiqul


    shofiq
    Monday, January 18, 2010 6:17 AM
  • Hi, Shofiqul Islam

    What exactly is the issue that you are facing now?

    I LOVE MS..... Warm Regards, Kshitiz Posting is provided "AS IS" with no warranties, and confers no rights.
    Sunday, January 24, 2010 5:10 PM
  • Hello Kshitizs,

    Thanks for your reply.I hav been solved the above probles whatever I had mentioned in this post. But after overcomming previous problem my sharepoint server giving one more problem in Timer Job status, the "Office SharePoint Server CEIP Data Collection"  found status : failed but progress 100% 

    In my server event viewer receiving the following two events after every one hour:

    Log Name: Application 
    Source: Office SharePoint Server
    Event ID: 7888
    Description:

    A runtime exception was detected. Details follow.

    Message: Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED))

    Techinal Details:

    System.UnauthorizedAccessException: Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED))

    at Microsoft.SharePoint.SPGlobal.HandleUnauthorizedAccessException(UnauthorizedAccessException ex)

    at Microsoft.SharePoint.Library.SPRequest.AddField(String bstrUrl, String bstrListName, String bstrSchemaXml, Int32 grfAdd)

    at Microsoft.SharePoint.SPFieldCollection.AddFieldAsXmlInternal(String schemaXml, Boolean addToDefaultView, SPAddFieldOptions op)

    at Microsoft.SharePoint.SPFieldCollection.AddFieldAsXml(String schemaXml, Boolean addToDefaultView, SPAddFieldOptions op)

    at Microsoft.SharePoint.SPFieldCollection.AddFieldAsXml(String strXml)

    at Microsoft.SharePoint.SPFieldCollection.AddInternal(String strDisplayName, SPFieldType type, Boolean bRequired, Boolean bCompactName, Guid lookupListId, Guid lookupWebId, StringCollection choices)

    at Microsoft.SharePoint.SPFieldCollection.Add(String strDisplayName, SPFieldType type, Boolean bRequired, Boolean bCompactName, StringCollection choices)

    at Microsoft.SharePoint.SPFieldCollection.Add(String strDisplayName, SPFieldType type, Boolean bRequired)

    at Microsoft.Office.Server.UserProfiles.SiteSynchronizer.UserSynchronizer.TryAddFieldToUserInfoListWithInternalName(String strWSSInternalName, SPFieldType fieldType)

    at Microsoft.Office.Server.UserProfiles.SiteSynchronizer.UserSynchronizer.AddFieldToUserInfoList(String strProfilePropName, SPFieldType fieldType)

    at Microsoft.Office.Server.UserProfiles.SiteSynchronizer.UserSynchronizer.PushSchemaToList(Boolean& bAddedColumn)

    at Microsoft.Office.Server.UserProfiles.SiteSynchronizer.UserSynchronizer.SynchFull(Boolean ignoreIsActive)

    at Microsoft.Office.Server.UserProfiles.SiteSynchronizer.Synch()

    at Microsoft.Office.Server.Diagnostics.FirstChanceHandler.ExceptionFilter(Boolean fRethrowException, TryBlock tryBlock, FilterBlock filter, CatchBlock catchBlock, FinallyBlock finallyBlock)


    Log Name: Application 
    Source: Office SharePoint Server
    Event ID: 5553

    Description:
    failure trying to synch site 0ca0b9e5-82c4-4cae-9d21-ed698c5bcae9 for ContentDB 5f047a93-01de-4953-a2af-b9e0d27c00f2 WebApp 66a1ca64-59ff-40df-9596-70867fba30a2. Exception message was Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED)).


    ----------------------------------------------
    Thanking you in advanced for you help
    shofiqul


    shofiq
    Thursday, January 28, 2010 5:47 AM
  • This seems to be an issue with Profile sync.
    Run the command:
    stsadm -o sync -listolddatabases 5
    incaseyou get results, execute,
    stsadm -o sync-deleteolddatabases 5

    This will not delete any content database or data but will clear the entris of old databases from profile sync that are not being synced.
    You may also try detaching and attaching the content database from the web application if the issue persists.
    Please refer:
    http://technet.microsoft.com/en-us/library/cc263196.aspx
    I LOVE MS..... Thanks and Regards, Kshitiz (Posting is provided "AS IS" with no warranties, and confers no rights.)
    Thursday, January 28, 2010 9:18 AM

  • hi Kshitizs,

    one database found using stsadm -o sync -listolddatabases 5

    and that has been deleted after executing  stsadm -o sync-deleteolddatabases 5


    but till I am receiving every hour the same Event 7888 and 5553 and found Office SharePoint Server CEIP Data Collection (job) failed


    Thank you.
    Shofiqul
    shofiq
    Tuesday, February 2, 2010 9:55 AM
  • Hi,

    How did you eliminate the first problem you faced i.e, trying to backup to UNC path and backup stops at following line:Progress: [Shared Search Index] 50 percent complete.

    I am facing the same issue now.

    Thanks in advance :-)

    Thursday, March 25, 2010 3:34 PM
  • Check the Everyone group "Change" rights on UNC folder.  and assign db-backupoperator rul to respective service account to related databases on database server.

    I have found information from the following posts

    http://social.technet.microsoft.com/Forums/en-US/sharepointadmin/thread/98cd0251-1f68-49ca-b7d4-338b3270d33e

     

    Thanks, Shofiqul


    shofiq
    Monday, March 29, 2010 5:45 AM