SharePoint "People and Group" user profile information is not correct.


  • Dear All,


    Our company are using MOSS 2007. After add a new AD user  into "People and Group". Observed that some information are missing such as our AD have Office value.

    Anyone can help me?







    • Moved by Mike Walsh FIN Friday, July 16, 2010 9:12 AM admin q (From:SharePoint - General Question and Answers and Discussion (pre-SharePoint 2010))
    Friday, July 16, 2010 8:48 AM


All replies

  • Hello Edward,

    have you confirmed that these fields for user are populated in user's profile inside SSP?

    You can verify this by going to your SSP - > User profiles and properties

    Search the user and from hovered dropdown, select Edit user profile


    If it is not populated in there, then delete the user profile and allow user profile import job to run. Verify once the user profile is imported. Then delete the user completely from site collection, and add again.

    P.S. If its a new setup, then these steps are quiet easy; otherwise there maybe possibality that user has multiple set of permissions on different docs/lists/libraries/subsites where its a quiet tedious.

    Hope this helps,

    Regards, Rohan
    Friday, July 16, 2010 11:27 AM
  • Hi Rohan,


    In can find those field from View Profile Properties page, is it okay? 

    Besides, after user create "My Sites". Those user can see their full profile from "My Profile > Detail" and it is match with AD information.



    Monday, July 19, 2010 8:09 AM
  • Hello Edward,

    thats great. The profile seems to be sync'ed correctly with AD.

    Now the problem in front of us is only the cached profile in that particular site collection.

    So if possible, please remove the user completely from site collection, and then add again.

    Make sure you remove the user account from People and group-> all people -> click on user account and click on "Delete user from Site collection". Once its deleted, re-add him with at-least "Read only" permission or above.

    Then check the user profile again. :)

    p.s.  "Delete user from Site collection" will remove user completely from site collection, so all permissions for him will be deleted including permissions on site/subsite/lists/libraries. So you need to add him back everywhere as before if this is a production environment.


    Regards, Rohan
    Monday, July 19, 2010 8:38 AM
  • Hi Rohan,

    Thanks for your reply.

    Following you procedure, re-add user with site member. And checked again, the profile is still missing "Office" field value. (from "[sitename] > People and Groups > [sitename] member"). 


    Any step i was missed? please kindly help.


    p.s. same as mentioned before, if user was created "My Sites", "My Sites" > "Detail" can see this value. but "[sitename] > People and Groups > [sitename] member" still can't see "office" field value. So i wonder is it different profile? Thanks.


    Best regards,


    Monday, July 19, 2010 9:41 AM
  • Hello Edward,

    Have you tried adding the same user account on some other site collection on which he never had access?

    Please try this and check if the user profile is populating all the fields for that particular site collection.


    Regards, Rohan
    Monday, July 19, 2010 10:16 AM
  • Hi Rohan,


    Just tried added the newer user on other site collection or user who never adding on site collection, the results are same.


    Both can't display "Office" field from [sitename] > People and Groups > [sitename] member


    Any idea on it??????? Thanks.

    Best regards,


    Tuesday, July 20, 2010 12:48 AM
  • Hi,

    so you mean you added the same user AD\Bob in the another site collection from the same (problematic) web application and got the same results? or is it another way (i.e you added him to another site from another web application on which he never had before)?

    Soppy for the questons again and my poor understanding..:(

    Regards, Rohan
    Wednesday, July 21, 2010 1:16 PM
  • Hi~~


    first apologies for my terrible english....

    yup. what i mean is added the same user AD\Bob in the another site collection from the same web application and got the same results. And also tried add another user (who never added into site collection before) and got the same results too.


    Best regards,


    Thursday, July 22, 2010 1:27 AM
  • Hello Edward,

    can you please try to run following stsadm command

    stsadm -o sync -listolddatabases 1

    If you see any results then these site collections are not synchronizing.  You can correct the problem by running this command:

    stsadm -o sync -deleteolddatabases 1

    Contrary to what it says, it doesn't delete anything.  It simply resets a field in the database that forces it to resynchronize at the next run.  I believe it runs every two hours by default, but that is configurable.

    Here is a resource for the stsadm -o sync command


    I just found it while reading some other forum and thought of maybe helpful for your situation.


    Regards, Rohan
    Thursday, July 22, 2010 12:41 PM
  • following link also worth give a look for such issue:



    Regards, Rohan
    Thursday, July 22, 2010 12:46 PM
  • Thanks Rohan. Follow the guide and fix the issue.



    Friday, July 23, 2010 12:57 AM
  • Hello Edward,

    Glad to know that issue has been reasolved; Sorry, giving you some more trouble :) I would like to know did you really found the exact reason caused the issue? or which of the step from guide worked well to reslove the the problem?

    Thanks for your response in advance..!!

    All the very best.

    Regards, Rohan
    Friday, July 23, 2010 10:31 AM
  • Hi Rohan,

    Sorry for late reply. Just taken a long weekend after fixed this problem:P

    Here's my step of procedure:

    1) run below command to remove old data:
    stsadm -o sync -deleteolddatabases 1

    2) After that, make sure there has member into Member group before sync. (Observed that the member list can't sync if there is no people into member group).

    3) Run import user profile from "user profiles and properties" (at shared shares administration page).

    4) Wait for next profile synchronization.

    Hope everyone can fix it by using this above SOP

    Best regards,


    Tuesday, July 27, 2010 5:45 AM