none
Visual C++ 2015 Redistributable Setup Failed 0x80070666 (x64 & x86) RRS feed

  • Question

  • I've been trying for the past 3 hours to get these two to install. (x64 & x86) I haven't gotten it to work, it's starting to get annoying. It's trying to tell me that I already have it install, I've followed the directions and have deleted both of them. After deleting them, it still gives me the error.

    One or more issues caused the setup to fail. Please fix the issues and then retry setup.

    For more information see the log file.

     0x80070666 - Another version of this product is already installed. Installation of this version cannot continue.

    To configure or remove the existing version of this product, use Add/Remove programs on the control panel. 



    Log File x64

    [12C8:2310][2017-08-09T14:44:44]i001: Burn v3.7.3813.0, Windows v10.0 (Build 15063: Service Pack 0), path: C:\Users\Fluff\Downloads\vc_redist.x64 (3).exe, cmdline: ''
    [12C8:2310][2017-08-09T14:44:44]i000: Setting string variable 'WixBundleLog' to value 'C:\Users\Fluff\AppData\Local\Temp\dd_vcredist_amd64_20170809144444.log'
    [12C8:2310][2017-08-09T14:44:44]i000: Setting string variable 'WixBundleOriginalSource' to value 'C:\Users\Fluff\Downloads\vc_redist.x64 (3).exe'
    [12C8:2310][2017-08-09T14:44:44]i000: Setting string variable 'WixBundleOriginalSourceFolder' to value 'C:\Users\Fluff\Downloads\'
    [12C8:2310][2017-08-09T14:44:44]i000: Setting string variable 'WixBundleName' to value 'Microsoft Visual C++ 2015 Redistributable (x64) - 14.0.24215'
    [12C8:2310][2017-08-09T14:44:44]i100: Detect begin, 10 packages
    [12C8:2310][2017-08-09T14:44:44]i000: Setting version variable 'windows_uCRT_DetectKey' to value '10.0.15063.447'
    [12C8:2310][2017-08-09T14:44:44]i000: Setting numeric variable 'windows_uCRT_DetectKeyExists' to value 1
    [12C8:2310][2017-08-09T14:44:44]i102: Detected related bundle: {f1e7e313-06df-4c56-96a9-99fdfd149c51}, type: Upgrade, scope: PerMachine, version: 14.10.25008.0, operation: Downgrade
    [12C8:2310][2017-08-09T14:44:44]i108: Detected compatible package: vcRuntimeMinimum_x64, provider: Microsoft.VS.VC_RuntimeMinimumVSU_amd64,v14, installed: {8D50D8C6-1E3D-3BAB-B2B7-A5399EA1EBD1}, version: 14.10.25008, chained: {50A2BC33-C9CD-3BF1-A8FF-53C10A0B183C}
    [12C8:2310][2017-08-09T14:44:44]i103: Detected related package: {8D50D8C6-1E3D-3BAB-B2B7-A5399EA1EBD1}, scope: PerMachine, version: 14.10.25008.0, language: 0 operation: Downgrade
    [12C8:2310][2017-08-09T14:44:44]i108: Detected compatible package: vcRuntimeAdditional_x64, provider: Microsoft.VS.VC_RuntimeAdditionalVSU_amd64,v14, installed: {C668F044-4825-330D-8F9F-3CBFC9F2AB89}, version: 14.10.25008, chained: {EF1EC6A9-17DE-3DA9-B040-686A1E8A8B04}
    [12C8:2310][2017-08-09T14:44:44]i103: Detected related package: {C668F044-4825-330D-8F9F-3CBFC9F2AB89}, scope: PerMachine, version: 14.10.25008.0, language: 0 operation: Downgrade
    [12C8:2310][2017-08-09T14:44:44]i052: Condition '(VersionNT = v6.3 AND NOT VersionNT64) AND (windows_uCRT_DetectKeyExists AND windows_uCRT_DetectKey >= v10.0.10240.0)' evaluates to false.
    [12C8:2310][2017-08-09T14:44:44]i052: Condition '(VersionNT = v6.3 AND VersionNT64) AND (windows_uCRT_DetectKeyExists AND windows_uCRT_DetectKey >= v10.0.10240.0)' evaluates to false.
    [12C8:2310][2017-08-09T14:44:44]i052: Condition '(VersionNT = v6.2 AND NOT VersionNT64) AND (windows_uCRT_DetectKeyExists AND windows_uCRT_DetectKey >= v10.0.10240.0)' evaluates to false.
    [12C8:2310][2017-08-09T14:44:44]i052: Condition '(VersionNT = v6.2 AND VersionNT64) AND (windows_uCRT_DetectKeyExists AND windows_uCRT_DetectKey >= v10.0.10240.0)' evaluates to false.
    [12C8:2310][2017-08-09T14:44:44]i052: Condition '(VersionNT = v6.1 AND NOT VersionNT64) AND (windows_uCRT_DetectKeyExists AND windows_uCRT_DetectKey >= v10.0.10240.0)' evaluates to false.
    [12C8:2310][2017-08-09T14:44:44]i052: Condition '(VersionNT = v6.1 AND VersionNT64) AND (windows_uCRT_DetectKeyExists AND windows_uCRT_DetectKey >= v10.0.10240.0)' evaluates to false.
    [12C8:2310][2017-08-09T14:44:44]i052: Condition '(VersionNT = v6.0 AND NOT VersionNT64) AND (windows_uCRT_DetectKeyExists AND windows_uCRT_DetectKey >= v10.0.10240.0)' evaluates to false.
    [12C8:2310][2017-08-09T14:44:44]i052: Condition '(VersionNT = v6.0 AND VersionNT64) AND (windows_uCRT_DetectKeyExists AND windows_uCRT_DetectKey >= v10.0.10240.0)' evaluates to false.
    [12C8:2310][2017-08-09T14:44:44]i101: Detected package: vcRuntimeMinimum_x64, state: Obsolete, cached: None
    [12C8:2310][2017-08-09T14:44:44]i101: Detected package: vcRuntimeAdditional_x64, state: Obsolete, cached: None
    [12C8:2310][2017-08-09T14:44:44]i101: Detected package: Windows81_x86, state: Absent, cached: None
    [12C8:2310][2017-08-09T14:44:44]i101: Detected package: Windows81_x64, state: Absent, cached: None
    [12C8:2310][2017-08-09T14:44:44]i101: Detected package: Windows8_x86, state: Absent, cached: None
    [12C8:2310][2017-08-09T14:44:44]i101: Detected package: Windows8_x64, state: Absent, cached: None
    [12C8:2310][2017-08-09T14:44:44]i101: Detected package: Windows7_MSU_x86, state: Absent, cached: None
    [12C8:2310][2017-08-09T14:44:44]i101: Detected package: Windows7_MSU_x64, state: Absent, cached: None
    [12C8:2310][2017-08-09T14:44:44]i101: Detected package: WindowsVista_MSU_x86, state: Absent, cached: None
    [12C8:2310][2017-08-09T14:44:44]i101: Detected package: WindowsVista_MSU_x64, state: Absent, cached: None
    [12C8:2310][2017-08-09T14:44:44]i052: Condition 'VersionNT64 >= v6.0 OR (VersionNT64 = v5.2 AND ServicePackLevel >= 1)' evaluates to true.
    [12C8:2310][2017-08-09T14:44:44]i199: Detect complete, result: 0x0
    [12C8:127C][2017-08-09T14:44:46]e000: Error 0x80070666: Cannot install a product when a newer version is installed.


    Log File x86

    [2E9C:15D8][2017-08-09T14:57:41]i001: Burn v3.7.3813.0, Windows v10.0 (Build 15063: Service Pack 0), path: C:\Program Files (x86)\Steam\steamapps\common\PUBG\_CommonRedist\vcredist\2015\vc_redist.x86.exe, cmdline: ''
    [2E9C:15D8][2017-08-09T14:57:41]i000: Setting string variable 'WixBundleLog' to value 'C:\Users\Fluff\AppData\Local\Temp\dd_vcredist_x86_20170809145741.log'
    [2E9C:15D8][2017-08-09T14:57:41]i000: Setting string variable 'WixBundleOriginalSource' to value 'C:\Program Files (x86)\Steam\steamapps\common\PUBG\_CommonRedist\vcredist\2015\vc_redist.x86.exe'
    [2E9C:15D8][2017-08-09T14:57:41]i000: Setting string variable 'WixBundleOriginalSourceFolder' to value 'C:\Program Files (x86)\Steam\steamapps\common\PUBG\_CommonRedist\vcredist\2015\'
    [2E9C:15D8][2017-08-09T14:57:41]i000: Setting string variable 'WixBundleName' to value 'Microsoft Visual C++ 2015 Redistributable (x86) - 14.0.24215'
    [2E9C:15D8][2017-08-09T14:57:41]i100: Detect begin, 10 packages
    [2E9C:15D8][2017-08-09T14:57:41]i000: Setting version variable 'windows_uCRT_DetectKey' to value '10.0.15063.447'
    [2E9C:15D8][2017-08-09T14:57:41]i000: Setting numeric variable 'windows_uCRT_DetectKeyExists' to value 1
    [2E9C:15D8][2017-08-09T14:57:41]i102: Detected related bundle: {c239cea1-d49e-4e16-8e87-8c055765f7ec}, type: Upgrade, scope: PerMachine, version: 14.10.25008.0, operation: Downgrade
    [2E9C:15D8][2017-08-09T14:57:41]i108: Detected compatible package: vcRuntimeMinimum_x86, provider: Microsoft.VS.VC_RuntimeMinimumVSU_x86,v14, installed: {C6CDA568-CD91-3CA0-9EDE-DAD98A13D6E1}, version: 14.10.25008, chained: {BBF2AC74-720C-3CB3-8291-5E34039232FA}
    [2E9C:15D8][2017-08-09T14:57:41]i103: Detected related package: {C6CDA568-CD91-3CA0-9EDE-DAD98A13D6E1}, scope: PerMachine, version: 14.10.25008.0, language: 0 operation: Downgrade
    [2E9C:15D8][2017-08-09T14:57:41]i108: Detected compatible package: vcRuntimeAdditional_x86, provider: Microsoft.VS.VC_RuntimeAdditionalVSU_x86,v14, installed: {E6222D59-608C-3018-B86B-69BD241ACDE5}, version: 14.10.25008, chained: {69BCE4AC-9572-3271-A2FB-9423BDA36A43}
    [2E9C:15D8][2017-08-09T14:57:41]i103: Detected related package: {E6222D59-608C-3018-B86B-69BD241ACDE5}, scope: PerMachine, version: 14.10.25008.0, language: 0 operation: Downgrade
    [2E9C:15D8][2017-08-09T14:57:41]i052: Condition '(VersionNT = v6.3 AND NOT VersionNT64) AND (windows_uCRT_DetectKeyExists AND windows_uCRT_DetectKey >= v10.0.10240.0)' evaluates to false.
    [2E9C:15D8][2017-08-09T14:57:41]i052: Condition '(VersionNT = v6.3 AND VersionNT64) AND (windows_uCRT_DetectKeyExists AND windows_uCRT_DetectKey >= v10.0.10240.0)' evaluates to false.
    [2E9C:15D8][2017-08-09T14:57:41]i052: Condition '(VersionNT = v6.2 AND NOT VersionNT64) AND (windows_uCRT_DetectKeyExists AND windows_uCRT_DetectKey >= v10.0.10240.0)' evaluates to false.
    [2E9C:15D8][2017-08-09T14:57:41]i052: Condition '(VersionNT = v6.2 AND VersionNT64) AND (windows_uCRT_DetectKeyExists AND windows_uCRT_DetectKey >= v10.0.10240.0)' evaluates to false.
    [2E9C:15D8][2017-08-09T14:57:41]i052: Condition '(VersionNT = v6.1 AND NOT VersionNT64) AND (windows_uCRT_DetectKeyExists AND windows_uCRT_DetectKey >= v10.0.10240.0)' evaluates to false.
    [2E9C:15D8][2017-08-09T14:57:41]i052: Condition '(VersionNT = v6.1 AND VersionNT64) AND (windows_uCRT_DetectKeyExists AND windows_uCRT_DetectKey >= v10.0.10240.0)' evaluates to false.
    [2E9C:15D8][2017-08-09T14:57:41]i052: Condition '(VersionNT = v6.0 AND NOT VersionNT64) AND (windows_uCRT_DetectKeyExists AND windows_uCRT_DetectKey >= v10.0.10240.0)' evaluates to false.
    [2E9C:15D8][2017-08-09T14:57:41]i052: Condition '(VersionNT = v6.0 AND VersionNT64) AND (windows_uCRT_DetectKeyExists AND windows_uCRT_DetectKey >= v10.0.10240.0)' evaluates to false.
    [2E9C:15D8][2017-08-09T14:57:41]i101: Detected package: vcRuntimeMinimum_x86, state: Obsolete, cached: None
    [2E9C:15D8][2017-08-09T14:57:41]i101: Detected package: vcRuntimeAdditional_x86, state: Obsolete, cached: None
    [2E9C:15D8][2017-08-09T14:57:41]i101: Detected package: Windows81_x86, state: Absent, cached: None
    [2E9C:15D8][2017-08-09T14:57:41]i101: Detected package: Windows81_x64, state: Absent, cached: None
    [2E9C:15D8][2017-08-09T14:57:41]i101: Detected package: Windows8_x86, state: Absent, cached: None
    [2E9C:15D8][2017-08-09T14:57:41]i101: Detected package: Windows8_x64, state: Absent, cached: None
    [2E9C:15D8][2017-08-09T14:57:41]i101: Detected package: Windows7_MSU_x86, state: Absent, cached: None
    [2E9C:15D8][2017-08-09T14:57:41]i101: Detected package: Windows7_MSU_x64, state: Absent, cached: None
    [2E9C:15D8][2017-08-09T14:57:41]i101: Detected package: WindowsVista_MSU_x86, state: Absent, cached: None
    [2E9C:15D8][2017-08-09T14:57:41]i101: Detected package: WindowsVista_MSU_x64, state: Absent, cached: None
    [2E9C:15D8][2017-08-09T14:57:41]i052: Condition 'VersionNT >= v6.0 OR (VersionNT = v5.1 AND ServicePackLevel >= 2) OR (VersionNT = v5.2 AND ServicePackLevel >= 1)' evaluates to true.
    [2E9C:15D8][2017-08-09T14:57:41]i199: Detect complete, result: 0x0
    [2E9C:31F8][2017-08-09T14:57:43]e000: Error 0x80070666: Cannot install a product when a newer version is installed.


    Can someone please help me?
    Wednesday, August 9, 2017 7:59 PM

All replies

  • Hi ChrisLlama,

    Thank you for posting in MSDN forum.

    >>Error 0x80070666: Cannot install a product when a newer version is installed.

    This error shows that the previous Visual C++ Redist remaining that prevents the 2015 version setup.

    Please try steps as below:

    1. Go to Control Panel--Programs and Features, uninstall all the Visual C++ Redistribute items.

    2. Run Fix it tool to fix problems that block programs from being installed or removed.

    3. Check you windows update and install latest patches.

    4. Reboot your machine.

    5. Re-download from Visual C++ Redistributable for Visual Studio 2015 and 2015 Redistributable Update 3 RC

    Best Regards,


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Thursday, August 10, 2017 6:59 AM
    Moderator
  • I ran into this issue as well and the program did not appear in the Add/Remove Programs list.  To get around it I downloaded the latest Visual C++ 2015 Redistributable package and ran the following from the command line:

    vc_redist.x64.exe /uninstall

    A popup will show with the option to repair the installation.  The repair succeeded and I was able to continue on past the point I was blocked by this.

    • Proposed as answer by RME_A Tuesday, November 28, 2017 9:22 AM
    Tuesday, October 17, 2017 2:15 AM
  • The ONLY solution that worked with me when installing [ Setup Failed ] ERROR appears to ( Microsoft Visual c++ Redistributable 2015) is to search for windows update in WINDOWS UPDATE from START MENU.... Secrch for Service Pack 1 Update (SP1)... download, install, restart.... IT WORKS !!


    Tuesday, October 24, 2017 9:03 PM
  • That didn't work for me. I tried repairing and even uninstalling and reinstalling the C++ redistributable package. I'm still getting it.

    Hatessunlight

    Thursday, January 4, 2018 5:12 PM
  • The above didn't work for me. Still unresolved after two days.

    Hatessunlight

    Thursday, January 4, 2018 5:13 PM
  • This worked for me also. 

    remember kids, first change your directory to the relevant folder. I.e.

    >cd C:\Users\<user>\Downloads

    cd - change directory
    C:\Users\<user>\Downloads - the directory


    now your terminal is working in the right directory, then you punch in 

    vc_redist.x64.exe /uninstall

    or 

    vc_redist.x86.exe /uninstall

    depending on what you downloaded. 


    • Edited by Grimblewald Tuesday, January 9, 2018 10:16 PM
    • Proposed as answer by Darshan1920 Wednesday, August 8, 2018 6:39 AM
    Tuesday, January 9, 2018 10:15 PM
  • This was the solution that worked for me, amazing! Thanks!
    Tuesday, February 6, 2018 10:54 AM
  • Thank you! This is what finally worked for me.
    Wednesday, March 14, 2018 4:57 AM
  • i know its a bit late but just wanted to share my solution

    i was having the same problem as you guys. I tried all of the solutions in this thread nothing worked then i downloaded and installed windows sp 1(different packages depending upon your OS and architecture 64 or 32) install it, restart pc, uninstall all vc++ runtimes, restart pc, install vc++ 2015 and it will work.

    if somebody is having the api ms crt issues this solution will fix those issues too. good luck!

    link: https://support.microsoft.com/en-us/help/15090/windows-7-install-service-pack-1-sp1

    Monday, March 19, 2018 7:08 AM
  • I'm surprised that nobody mentioned that the Visual Studio 2017 redistributable blocks the Visual Studio 2015 redistributable installation because the Visual Studio 2017 runtime is backwards compatible.

    If you are in a situation where the VS 2017 redistributable is installed, but the application that you are installing doesn't detect this and is refusing to install, then you should look for the Visual Studio 2017 redistributables and uninstall those, Let the installer complete, then finally reinstall the Visual Studio 2017 redistributable. This will update the runtime to the latest version.

    I know this situation was more confusing because this is the first time that two versions of Visual Studio redistributed files with the same name, and of course the help available for this was lacking if you didn't know how things worked.


    This is a signature. Any samples given are not meant to have error checking or show best practices. They are meant to just illustrate a point. I may also give inefficient code or introduce some problems to discourage copy/paste coding. This is because the major point of my posts is to aid in the learning process.

    • Proposed as answer by OwenHu99 Tuesday, April 3, 2018 3:24 PM
    Monday, March 19, 2018 4:58 PM
  • Thank you for posting this, I was stuck and your solution finally fixed my install for me. Your post was the first ever on MSDN to actually work.

    If I had a dollar for every copy paste reply voted as 'answer' here, I'd be ... very rich.

    Wednesday, April 11, 2018 2:21 AM
  • Could you explain it to me in more details as I cant get it to work?
    Monday, April 16, 2018 5:50 PM
  • You, Sir, are a genius that saved me a lot of time and frustration- this worked perfectly for me (and I would not have worked out that this was blocking the 2015 install).

    Sunday, May 13, 2018 10:15 AM
  • ^^^^^This one is the winner!  I am guessing that, since the 2015 and 2017 carry similar version numbers (fully patched I was 14.0.23918 for 2015 and 14.12.25810 for 2017), the installer was seeing the 2017 as a "newer" version.  Once I uninstalled the 2017 runtimes, I can reinstall 2015.
    Thursday, May 17, 2018 8:44 PM
  • tyvm worked like a charm 
    Sunday, May 20, 2018 7:31 AM
  • i have windows 8.1 Will this work for me?
    Wednesday, May 23, 2018 9:03 AM
  • Maybe  you  should confirm you don't have installed  higher vc version such as vc 2017,if you have,you must remove the higher vc version and then install vc 14,and it worked for my situation.
    Wednesday, June 6, 2018 8:32 AM
  • Thank you Grimblewald, that worked for me!

    Wednesday, June 13, 2018 3:22 PM
  • thanks it really works
    Friday, July 27, 2018 4:30 PM
  • you are genius sir.. thanks

    uninstall VS 2017 >> install VS 2015 (success) >> reinstall VS 2017

    Thursday, August 2, 2018 9:27 AM
  • I'm surprised that nobody mentioned that the Visual Studio 2017 redistributable blocks the Visual Studio 2015 redistributable installation because the Visual Studio 2017 runtime is backwards compatible.

    If you are in a situation where the VS 2017 redistributable is installed, but the application that you are installing doesn't detect this and is refusing to install, then you should look for the Visual Studio 2017 redistributables and uninstall those, Let the installer complete, then finally reinstall the Visual Studio 2017 redistributable. This will update the runtime to the latest version.

    I know this situation was more confusing because this is the first time that two versions of Visual Studio redistributed files with the same name, and of course the help available for this was lacking if you didn't know how things worked.


    This is a signature. Any samples given are not meant to have error checking or show best practices. They are meant to just illustrate a point. I may also give inefficient code or introduce some problems to discourage copy/paste coding. This is because the major point of my posts is to aid in the learning process.


    Thank you!!!
    Thursday, August 2, 2018 11:15 AM
  • its working !!!!!!!!1

    Thanks

    Wednesday, August 8, 2018 6:39 AM
  • Thank You! The 2017 redistribution was the problem for me.
    Sunday, August 12, 2018 12:45 AM
  • The same thing happens with Direct X  and VS2010 that should be installer after Direct X. In my case, I had installed the Vs2017 first, I removed it and managed to install the VS2015
    Wednesday, August 22, 2018 4:43 AM
  • This was the block! Thanks for pointing it out. 
    Wednesday, September 26, 2018 6:40 AM
  • I'm surprised that nobody mentioned that the Visual Studio 2017 redistributable blocks the Visual Studio 2015 redistributable installation because the Visual Studio 2017 runtime is backwards compatible.

    If you are in a situation where the VS 2017 redistributable is installed, but the application that you are installing doesn't detect this and is refusing to install, then you should look for the Visual Studio 2017 redistributables and uninstall those, Let the installer complete, then finally reinstall the Visual Studio 2017 redistributable. This will update the runtime to the latest version.

    I know this situation was more confusing because this is the first time that two versions of Visual Studio redistributed files with the same name, and of course the help available for this was lacking if you didn't know how things worked.


    This is a signature. Any samples given are not meant to have error checking or show best practices. They are meant to just illustrate a point. I may also give inefficient code or introduce some problems to discourage copy/paste coding. This is because the major point of my posts is to aid in the learning process.

    Thank You!!!!!!
    Thursday, September 27, 2018 7:56 PM
  • you are great boss.Thank you for your advice.Now it's works.
    Wednesday, October 3, 2018 12:30 PM
  • thank you, this was my issue. 
    Tuesday, October 16, 2018 8:19 PM
  • thanks very  much
    Wednesday, October 31, 2018 12:11 PM
  • This works for me, heaps of thanks!
    Friday, December 7, 2018 10:57 PM
  • Thank you !!! for revealing this trick. I was already thinking: I not supposed to uninstall my C++ 2017 huh?
    Sunday, December 16, 2018 6:00 PM
  • I am trying to install a pc game...shadow of tomb raider but it shows error there as api-ms-win-crt-runtime-l1-1-0.dll is missing. Also net framework C++ 2015 not getting installed...shows setup fail error. Rest all the c++ files installed successfully  except 2015. I have Hp g6 2005 ax notebook, window 7 64 bit. Help me bypass this error. c++ 2015 is needed to be installed to run this game. Get me solution ....Replay asap.
    Monday, December 31, 2018 9:25 PM
  • I am trying to install a pc game...shadow of tomb raider but it shows error there as api-ms-win-crt-runtime-l1-1-0.dll is missing. Also net framework C++ 2015 not getting installed...shows setup fail error. Rest all the c++ files installed successfully  except 2015. I have Hp g6 2005 ax notebook, window 7 64 bit. Help me bypass this error. c++ 2015 is needed to be installed to run this game. Get me solution ....Replay asap.
    Monday, December 31, 2018 9:26 PM
  • I am trying to install a pc game...shadow of tomb raider but it shows error there as api-ms-win-crt-runtime-l1-1-0.dll is missing. Also net framework C++ 2015 not getting installed...shows setup fail error. Rest all the c++ files installed successfully  except 2015. I have Hp g6 2005 ax notebook, window 7 64 bit. Help me bypass this error. c++ 2015 is needed to be installed to run this game. Get me solution ....Replay asap.
    Monday, December 31, 2018 9:26 PM
  • This worked. Removed both 2017 re-distributables. Tried the program installer (which was trying to install the 2015 versions) and succeeded! 

    Thank you!

    Sunday, February 3, 2019 12:07 PM
  • So to answer to your issue is c++ 2017. c++ 2017 is the replacement to c++ 2015. So the err 0x80070666 is responding to Microsoft Visual c++ 2017 rather then 2015.

    go here https://www.youtube.com/watch?v=GMhZNZMz1Ug


    • Edited by Trist3232 Saturday, March 2, 2019 4:33 PM
    Saturday, March 2, 2019 4:32 PM
  • Thanks  a Heap I was going crazy trying to fix this. Had to brush up on my DOS a bit but it WORKED!
    Sunday, March 3, 2019 12:49 PM
  • You're amazing!!! Worked at last!! Thanks

    Neill

    Thursday, March 14, 2019 12:56 PM
  • So to answer to your issue is c++ 2017. c++ 2017 is the replacement to c++ 2015. So the err 0x80070666 is responding to Microsoft Visual c++ 2017 rather then 2015.

    go here https://www.youtube.com/watch?v=GMhZNZMz1Ug



    Trust Microsoft to confuse everyone. :)
    Sunday, April 14, 2019 6:44 AM
  • Well, you can say this, but they learnt from their mistake with Visual Studio 2019.

    So it is easier now, you just need to tell people to get the latest version of the Visual C++ 2015 - 2019 redistributable.


    This is a signature. Any samples given are not meant to have error checking or show best practices. They are meant to just illustrate a point. I may also give inefficient code or introduce some problems to discourage copy/paste coding. This is because the major point of my posts is to aid in the learning process.

    Sunday, April 14, 2019 1:30 PM
  • Well, you can say this, but they learnt from their mistake with Visual Studio 2019.

    So it is easier now, you just need to tell people to get the latest version of the Visual C++ 2015 - 2019 redistributable.


    This is a signature. Any samples given are not meant to have error checking or show best practices. They are meant to just illustrate a point. I may also give inefficient code or introduce some problems to discourage copy/paste coding. This is because the major point of my posts is to aid in the learning process.


    Where did you get that from?
    Sunday, April 14, 2019 9:53 PM
  • It's here under Other Tools and Frameworks.

    It's only listed as "Microsoft Visual C++ Redistributable for Visual Studio 2019", but it is actually "Microsoft Visual C++ 2015-2019 Redistributable".

    Monday, April 15, 2019 12:22 AM
  • hi there...
    1. iam using Wind 7 64 bit. should i choose only 64 bit or both of them?
    2. I tried to open Motogp 2018 and it showed "The following component(s) are required! to run this program:
     DirectX Runtime", if i install this Will it solved that problem?
    thx
    Sunday, May 26, 2019 4:26 PM
  • hi there...
    1. iam using Wind 7 64 bit. should i choose only 64 bit or both of them?
    2. I tried to open Motogp 2018 and it showed "The following component(s) are required! to run this program:
     DirectX Runtime", if i install this Will it solved that problem?
    thx

    Have you tried installing DirectX End-User Runtime yet?
    Friday, June 7, 2019 5:52 AM
  • Finally found the solution,indeed I can not install 2015 because 2017 already installed,thank you.
    Thursday, July 4, 2019 3:36 AM
  • Fix it tool did not work(it couldbt instal or uninstal it) i still cant instal visual c++ 2015 and nobody seems to have an answer. if u have anything else to say that could help me please do.

    Tuesday, July 16, 2019 8:02 AM
  • Fix it tool did not work(it couldbt instal or uninstal it) i still cant instal visual c++ 2015 and nobody seems to have an answer. if u have anything else to say that could help me please do.

    Hi hobgoblin.

    Visual C++ 2017 is a replacement for Visual C++ 2015. So, installing Visual C++ 2017 should fix any Visual C++ 2015 problems you have.

    If for some reason you absolutely need to have Visual C++ 2015 installed (which I doubt), you will first have to uninstall Visual C++ 2017 and leave it uninstalled as installing Visual C++ 2017 afterwards will overwrite Visual C++ 2015.

    I posted a link in my previous post.

    There are also some excellent all-in-one repacks around, but I would do what I just said above.


    • Edited by dypsis Thursday, July 18, 2019 8:05 AM
    Thursday, July 18, 2019 8:04 AM
  • Thank you!!! This was the fix for me!
    Thursday, July 18, 2019 9:44 PM
  • Uninstall 2017 to install 2015, THANK YOU!!!!
    Wednesday, September 11, 2019 2:06 AM
  • I was having the same issue and having 2017 installed i was wondering why 2015 wouldnt install. In the end all i had to do was repair 2017.
    Friday, October 4, 2019 8:23 PM
  • thankyou dude you'r my lifesafer
    Sunday, October 6, 2019 6:51 AM