none
Distributed Cache Host Down RRS feed

  • Question

  • when i start the cache host  on the server with the below command

    Start-CacheHost -Computername "name" -CachePort 22233

    it immediately displays


    HostName : CachePort Service Name            Service Status Version Info
    -------------------- ------------            -------------- ------------
    name:22233           AppFabricCachingService DOWN           3 [3,3][1,3]


    when i checked the logs i see


     AppFabricCachingService.Crash 
      Param System.UriFormatException: Invalid URI: The hostname could not be parsed. at System.Uri.CreateThis


    I am able to ping the hostname.

    Can somebody point what is missing?
    Friday, July 4, 2014 6:20 AM

Answers

  • Okay, let's start over. From ABC1, run the following cmdlets:

    Remove-SPDistributedCacheServiceInstance
    Add-SPDistributedCacheServiceInstance

    This is SharePoint's way of starting the DC, but it must be done on the server you intend to run the DC on.

    Install that AppFabric CU5 *first* as there are significant stability and bug fixes. Also make that change in the config file per the CU3 hotfix notes.


    Trevor Seward

    Follow or contact me at...
      

    This post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    • Proposed as answer by Jason Warren Friday, July 4, 2014 5:03 PM
    • Marked as answer by thomsonjacob Monday, July 7, 2014 5:49 AM
    Friday, July 4, 2014 4:21 PM
    Moderator

All replies

  • Is the "name" longer than 15 characters or does it contain a dot character?

    Trevor Seward

    Follow or contact me at...
      

    This post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    Friday, July 4, 2014 6:36 AM
    Moderator
  • The name has 4 characters ,

    ABC1

    Friday, July 4, 2014 6:59 AM
  • Try installing AppFabric CU5:

    http://support.microsoft.com/kb/2932678

    Also, enable backgroundGC = true per the article (this is for AppFabric CU3, but applies to CU3 onwards):

    http://support.microsoft.com/kb/2787717

    What is the status of AppFabric Caching Service in services.msc on this host?


    Trevor Seward

    Follow or contact me at...
      

    This post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    Friday, July 4, 2014 7:02 AM
    Moderator
  • The Status of AppFabric Caching Service in services.msc on this host is Not Started 
    Friday, July 4, 2014 7:14 AM
  • Sorry, is there a reason you're not using the standard SharePoint way of doing this?

    http://technet.microsoft.com/en-us/library/jj219613%28v=office.15%29.aspx#startstopcache


    Trevor Seward

    Follow or contact me at...
      

    This post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    Friday, July 4, 2014 7:16 AM
    Moderator
  • Hi,

    Similiar issue reported here

    http://social.msdn.microsoft.com/Forums/vstudio/en-US/15386b05-6498-4c56-a3e5-916face21f07/appfabric-caching-service-crashed-with-exception-systemuriformatexception-invalid-uri-the?forum=velocity

    please check this.


    Please remember to click 'Mark as Answer' on the answer if it helps you

    Friday, July 4, 2014 7:23 AM
  • What i see is that In Central Administration , it says the Distributed Cache is running.

    But when i go to the services.msc i see the AppFabric Caching Service is not started. Can you let me know what is the standard SharePoint way?

    Thanks in Advance

    Friday, July 4, 2014 9:49 AM
  • I tried running the command


    cmdlet Get-AFCacheHostConfiguration at command pipeline position 1
    Supply values for the following parameters:
    ComputerName: ABC1
    CachePort: 22233


    HostName        : ABC1
    ClusterPort     : 22234
    CachePort       : 22233
    ArbitrationPort : 22235
    ReplicationPort : 22236
    Size            : 819 MB
    ServiceName     : AppFabricCachingService
    HighWatermark   : 99%
    LowWatermark    : 90%
    IsLeadHost      : True

    Its running , But when i run

    Start-CacheHost -Computername "abc1" -CachePort 22233

    it immediately displays


    HostName : CachePort Service Name            Service Status Version Info
    -------------------- ------------            -------------- ------------
    abc1:22233           AppFabricCachingService DOWN           3 [3,3][1,3]

    Friday, July 4, 2014 9:53 AM
  • Okay, let's start over. From ABC1, run the following cmdlets:

    Remove-SPDistributedCacheServiceInstance
    Add-SPDistributedCacheServiceInstance

    This is SharePoint's way of starting the DC, but it must be done on the server you intend to run the DC on.

    Install that AppFabric CU5 *first* as there are significant stability and bug fixes. Also make that change in the config file per the CU3 hotfix notes.


    Trevor Seward

    Follow or contact me at...
      

    This post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    • Proposed as answer by Jason Warren Friday, July 4, 2014 5:03 PM
    • Marked as answer by thomsonjacob Monday, July 7, 2014 5:49 AM
    Friday, July 4, 2014 4:21 PM
    Moderator
  • CU 5 did the trick

    Thanks

    Monday, July 7, 2014 5:49 AM