none
Not able to edit the emailed document to SharePoint library RRS feed

  • Question

  • Did anyone try to edit the Word Documents that are populated from the outlook emails into the SharePoint library using Incoming Email setttings?

    This library doesn't have any required cols but still it is giving this error message all the time:

    The File cannot be saved because some properties are missing or invalid.

    Use the document Information panel to provide the correct property values. errors for required properties are marked with red asterisk and errors for invalid properties are marked with a red dashed border.

    When I go to the information panel, I just see a red asterisk beside the location- populated with the path of the file location.

    Does anyone faced this issue before?

    Advanced thanks for the help.

    Tuesday, February 7, 2012 6:41 PM

Answers

  • Hi,

    It seems a default behavior in SharePoint 2010 for an email enabled list.

    You can try the workaround below:

    1. Go to the doc library where you have enabled incomingemail> go to Library Settings

    2. Go to the Content Types section (you have to enable manage Content types from Advanced Settings if not done already)

    3. Add a new content type fromthe list of existing content types > good to try with Basic Page. Make that as the Default (select it as #1).

    4. Once you are done with the changes, go to our Outlook client and send an emailto the same list with an attached Word or Excel file and try Saving it after Edit.



    Xue-mei Chang

    TechNet Community Support

    Friday, February 10, 2012 2:16 AM
    Moderator

All replies

  • Thank you for the links Shripav. But none of the links satisfy my requirements. They are not uploaded directly into SharePoint library nor they have content types being used in that library.

    It is a normal document library, where the documents are populated from email attachments.

    Anyone has any idea?

    Wednesday, February 8, 2012 7:50 PM
  • I figured out the problem is due to the Document Properties and personal Information Found.

    I tried to Inspect the Document and the Inspection results are as follows:

    "Custom XML Data": custom XML data was found. and

    "Document Properties and personal Information". The following document information was found:

    *Document Properties

    *Document Server properties

    *Content type Information.

    After clicking Remove all for Document Properties and personal information, I am able to save the document without any errors.

    But I need to do this everytime I try to edit any document (populated from email).

    Is there any way that I can just by default delete those document properties? instead of inspecting the doc and deleting it.

    Wednesday, February 8, 2012 10:01 PM
  • Hi,

    It seems a default behavior in SharePoint 2010 for an email enabled list.

    You can try the workaround below:

    1. Go to the doc library where you have enabled incomingemail> go to Library Settings

    2. Go to the Content Types section (you have to enable manage Content types from Advanced Settings if not done already)

    3. Add a new content type fromthe list of existing content types > good to try with Basic Page. Make that as the Default (select it as #1).

    4. Once you are done with the changes, go to our Outlook client and send an emailto the same list with an attached Word or Excel file and try Saving it after Edit.



    Xue-mei Chang

    TechNet Community Support

    Friday, February 10, 2012 2:16 AM
    Moderator
  • THANK YOU so much it works!


    Tinac


    • Edited by sigWebmaster Monday, February 25, 2013 6:41 PM we solved the issue - I was searching in the wrong screen
    Monday, February 25, 2013 6:19 PM
  • Best workaround ever!  Thank you!
    Friday, February 7, 2014 12:55 AM