none
Workflow 2013 - error on stating WF with a content type RRS feed

  • Question

  • Hello there,

    I have this error on my Workflow 2013 created through SharePoint Designer 2013, that is drivin' me crazy!

    This is the cenario:

    The "Shared Documents" document library, with a content type manager enabled. There are 2 different content types: the "Document" (standard one) and a custom ct called "Custom Doc".

    There is a workflow that i've create only for tests, and it only have a "log action" that write a custom message on a history list.

    All right. Now the problem.

    If I UPLOAD a document, even it is a docx, xlsx, the workflow works just fine. BUT, if a CREATE a new document, from new button of document library, with one of the 2 content type (standard document or "custom doc") the workflow starts and then its is been cancelled or suspended with error HTTP 500. (information is in the exclamation mark just after workflow internal status)

    Anyone knows what is this?

    Thanks in advance.


    Friday, August 2, 2013 7:44 PM

Answers

  • Thanks Victoria,


    Unfortunatelly I only get this working when i disable the option about "automatically update stage name on sharepoint list (or something like this) in the sharepoint designer, in workflow configurations.

    You may try this too:

    1. Create 2 or more custom sharepoint site columns;
    2. Create a custom site content types;
    3. Add this custom columns u've created on step 1 to the custom content type.
    4. Add the custom content type to the document library
    5. open content type's template and add some document library column as property field in the document and save the template.
    6. Add the workflow.

    This is my real cenario.

    All your suggestions i've tried and still not working.

    Thanks again!! ;)


    Monday, August 12, 2013 4:38 PM

All replies

  • Hi,
    According to your post, the workflow doesn’t work when you create a new document using new button in the ribbon.
    I have tested the scenario per your post, the workflow works fine.

    The 500 Internal Server Error is a very general HTTP status code that means something has gone wrong on the web site's server but the server could not be more specific on what the exact problem is.
    I recommend to try the following steps to see if the error still occurs:
    1. Reload the web page.
    2.  Clear your browser's cache.
    3. Delete your browser's cookies.
     
    More information are provided in the below link:
    http://pcsupport.about.com/od/findbyerrormessage/a/500servererror.htm
     
    Best regards.
    Thanks

    Wednesday, August 7, 2013 10:14 AM
    Moderator
  • Thanks Victoria,


    Unfortunatelly I only get this working when i disable the option about "automatically update stage name on sharepoint list (or something like this) in the sharepoint designer, in workflow configurations.

    You may try this too:

    1. Create 2 or more custom sharepoint site columns;
    2. Create a custom site content types;
    3. Add this custom columns u've created on step 1 to the custom content type.
    4. Add the custom content type to the document library
    5. open content type's template and add some document library column as property field in the document and save the template.
    6. Add the workflow.

    This is my real cenario.

    All your suggestions i've tried and still not working.

    Thanks again!! ;)


    Monday, August 12, 2013 4:38 PM