none
Sharepoint Designer - Change login credentials question RRS feed

  • Question

  •  

    Hi Folks,

     

     I was tempted to put the word BUG in the title on this one as I believe the following issue is one.

     

     When I run Sharepoint Designer it automatically connects to MOSS using my windows credentials which are configured as a normal user (just view access).     I then get a 'you do not have permission' error and it pops up a login dialog for me to provide the correct credentials.

     

    However, it doesnt always do this (it wont if any explorer windows are open) and there is no-way as far as I can see in SharePoint Designer to change user credentials once its made up its mind who I should connect as  (the bug or missing feature).

     

    I have found a work-a-round where if I close down SharePoint Designer and all browser windows, then fire up explorer, connect to MOSS and 'login as a different user' to the desired account,  THEN fire up sharepoint designer, it will correctly connect using the account I am currently logged in with on the browser.

     

    I figure that this is one of those 'great features' that the Microsoft Evangilists harp on about, but it unfortunately causes me much grief.   I am wondering if there is a configuration setting I can apply to perhaps explorer that will force SharePoint Designer to always prompt for user credentials every time an attempt is made to open a site.

     

     

    Tuesday, April 8, 2008 10:37 PM

Answers

  • if the user authentication is disabled the only way that workd on my end is to temporary add the site under the Security --> restricted sites list. and then reopen Designer and i was prompted to enter new credentials...

    Tuesday, August 4, 2009 2:44 AM
    • right click on the SharePoint designer .exe and select "Run As..." as put in the credentials you want; or
    • you could Remote Desktop to your own machine and log in as another user.
    Wednesday, April 9, 2008 10:44 AM
  • I found that removing the site from the Intranet or Trusted Sites list in Internet Explorer solves(or breaks) the auto-logon problem, as per this post.

    http://michael.wilcox.net/2008/04/11/logging-into-sharepoint-designer/


    If you want to auto-logon with one user, but also have the option to change users, you could leave the default site URL in the Intranet or Trusted Sites in Internet Explorer and create an Alternative Access URL that would only be for development or changing users.

    Cheers,
    Lars
    Thursday, October 30, 2008 3:03 PM

All replies

  • I haven't tried it, but I would think if you did a Right Click (on the SPD shortcut) -> Run As and ran the SPD as the desired account, it would then use those credentials when designing.
    Wednesday, April 9, 2008 1:18 AM
    • right click on the SharePoint designer .exe and select "Run As..." as put in the credentials you want; or
    • you could Remote Desktop to your own machine and log in as another user.
    Wednesday, April 9, 2008 10:44 AM
  • The "Run As..." method doesn't work if you need to log in as a local user on the server. I also tried the suggestion of logging in first in IE and then opening up SP Designer. That didn't seem to work.

     

    The only solution I can think of is remote desktopping into the server, which is less than ideal...

    Thursday, April 24, 2008 9:50 PM
  • Nevermind, the solution is obvious. Just "Run As..." a user that has no access to the Sharepoint server. Then SP Designer will prompt for a login.

    • Proposed as answer by Ankit G Tuesday, June 5, 2012 5:57 PM
    • Unproposed as answer by Ankit G Tuesday, June 5, 2012 5:57 PM
    Thursday, April 24, 2008 9:56 PM
  •  

    interesting... i wonder.. has it allways been like that? In the internet explorer.. under security.. under local intranets.. do you have the site set in there? it will allways try to login you in with the same credintials if you loged in succesfully once.e.. if you have any sites in there..

     

    also just for good measure.. how's your internet connection. SPD has done some weird stuff when the connection isn't so good

     

    last have you tried blowing away your dns, cookies, dll's and everything under the sun to see if IE has the death grip on some credintials.. even my SPD logs me str8 into some sites.. but most of the time i just close it an open the site i want.

    Sunday, April 27, 2008 5:54 AM
  •  

    I have found a similar problem with Front Page (2003). If one opens up front page to a site in a different domain, and then opens up another site in the current domain, FP will prompt for log-in credentials.  But it seems to remember the last set used which causes issues if one has to log-in as a different user (depending on the site permissions).

     

     

    Friday, May 2, 2008 12:08 AM
  • Are there any other work-arounds? My SPD (and even IE) is defaulting to someone else's account. When I login as a different user in the website and then edit a page via SPD it is saying that I cannot save the page because it is checked out by me. This is due to the fact that SPD is still editing under that someone else's account.

     

    Any ideas?

    Tuesday, May 27, 2008 1:06 PM
  • Run as worked for me, thanks to those who enlightened me to that option.
    Wednesday, August 27, 2008 3:29 AM
  • The run as would be a nice solution for XP, win 2k3, ... but what do you do with Vista?
    Here I have only the option to run as an administrator.

    So do you suggest, I should create a shortcut with runas /:user ... that links somehow to the SPD path + exe, which I will have to search first ...

    If this is your answer, this is really not a nice solution, this shouldn't be the suggested way to use SPD...

    Regards,
    e-a-s-y
    Tuesday, September 2, 2008 10:47 PM
  • I found that removing the site from the Intranet or Trusted Sites list in Internet Explorer solves(or breaks) the auto-logon problem, as per this post.

    http://michael.wilcox.net/2008/04/11/logging-into-sharepoint-designer/


    If you want to auto-logon with one user, but also have the option to change users, you could leave the default site URL in the Intranet or Trusted Sites in Internet Explorer and create an Alternative Access URL that would only be for development or changing users.

    Cheers,
    Lars
    Thursday, October 30, 2008 3:03 PM
  • I have solved some issues related to this by using the 'stored username and password' feature on server 2003.  I believe Windows XP also has a similar facility.   I have not tested to see if this can be used to resolve this particular issue tho.

    Tuesday, November 25, 2008 11:00 PM
  • I am in the same boat. I used a colleagues login to verify the end user experience via "Sign in as a different user" a few weeks ago, for only a few minutes before returning to my own account via the same method. I have cleared my system cache, and rebooted my machine a few times. Unfortunately it looks like there is some deeper memory in the system as All site collections in the affected farm now default me to the other user, although I only performed this action within a single collection.

    I also am running Vista and do not have the "Run as..." option. I attempted "Run as Administrator" however even as myself as the admin I am still receiving the other users access level in SharePoint Designer.



    I do have a work around and this one should work for any version of Windows.

    I am using Vista with IE 7, so the locations may be a bit different depending on your configuration.

    1. So, start by opening Internet Explorer (If you use another browser, sorry I only support one at a time).
    2. Open the Tools menu and go to Internet Options
    3. Select the Security Tab
    4. Select the Intranet Zone (Or your affected zone if your sharepoint site is not in your Intranet)
    5. Click the button for Custom Level
    6. Find "User Authentication" in the list
    7. Set this option to "Prompt for Username and Password"

    Both IE and SharePoint designer are now prompting me for credentials in any window opened for either application. A little painful I know, but it will have to do for the moment, since this allows me the access I need to get my work done today.

    Any way to permanently log out of the other users account would be most helpful if anyone has further ideas.



    EDIT: This is in addition to larslynch's post below. In my case I did not have the site listed among my trusted sites.

    Wednesday, May 6, 2009 9:39 PM
  • if the user authentication is disabled the only way that workd on my end is to temporary add the site under the Security --> restricted sites list. and then reopen Designer and i was prompted to enter new credentials...

    Tuesday, August 4, 2009 2:44 AM
  • So the real issue is as follows when you have different browsers open:

    If I log into my site with one account in IE and another account in FF and close both browsers, IE will open with the other person or whoever was logged in last. This will also effect SPD...

    The only work around I have found is to go to "Pages" on the left when first opened and try to open a page you have recently edited. This will prompt you for credentials.

    Im of course still open to a simplier method of just "logging in" to SPD but that seems like an invisible feature/bug...

    Monday, March 7, 2011 2:17 PM
  • Is so ssimple like this :

    In left side , down there is a button with an icon of a person.

    click it and say it to login as another user.

     

    Gabriel Giraldo

    www.gjgsoftware.com

    Monday, October 31, 2011 8:25 PM
  • 

    rdharani@corelogic.com

    Wednesday, October 31, 2012 10:01 AM
  • Refer to link http://support.microsoft.com/kb/2738178

    C:\Program Files\Microsoft Office\Office14

    Press and hold the Shift key, right-click Spedesign.exe, and then click Run as different user


    Shailendra Shelar

    Thursday, December 27, 2012 10:51 AM
  • it couldn't be so obvious.

    just at the front of my nose!

    thanks a lot!!!!

    Thursday, January 17, 2013 1:37 AM
  • Hi you can  change log in as another user on SPD interface or you can RUN SPD as another user from CMD

    1.   Open windows command prompt by hitting "cmd" in Run

    2.   Enter the below command,

    For 64bit,

    runas /profile /user:<domain\username> "c:\program files\microsoft office\office14\spdesign.exe"

    For 32 bit,

    runas /profile /user:<domain\username> "C:\Program Files (x86)\Microsoft Office\Office14\spdesign.exe"

     

    3.   Enter the password of the user when prompted

    4.   SharePoint Designer will get opened with Different User

     
    Tuesday, November 26, 2013 2:16 AM
  • Ran into the same problem, noticed the stored sites were showing in net use within command prompt, try the command "net use * /delete" from a command prompt window to delete all active connections (this will delete any mapped drives as well), or use net use in cmd to get a list of the connected sites and then use "net use \\mysite.com /delete" replacing the //mysite.com with whichever site you want to delete. Worked for me!

    Sunday, March 22, 2015 9:47 PM
  • Definitely either a bug or just another horrible design.....when's Msft going to stop "igniting" about new features and enhancements and fix the products they already have? Or at least make them work in the way users would expect.
    Friday, May 8, 2015 3:36 AM