none
attachment disappears when evaluating the required field in sharepoint list

    Question

  • hi all,

    i have a sharepoint list with soem required fields .

    when i do the attachement and say ok without entering the required fields in the page . the page refreshes and prompts me to enter the required fields.

    but the attachemnt disappears. i need to re attach the files aggain.. wats the fix for this ?


    jayaraja
    Sunday, September 05, 2010 9:12 PM

All replies

  • There isn't a fix.  You just have to provide the required fields for the attachment not to go away.  The attachment is not committed until the item is submitted, and the item is not submitted until all required fields are filled.
    SharePoint Architect || Microsoft MVP || My Blog
    Planet Technologies || SharePoint Task Force
    Monday, September 06, 2010 11:44 PM
  • where do i set the reqd field for attachments not to go away ?
    jayaraja
    Wednesday, September 08, 2010 6:39 PM
  • where do i set the reqd field for attachments not to go away ?
    jayaraja

    I don't know of such a setting.  I was referring to making sure that all required fields are filled out before doing the attachment or just making sure all required fields are done before submitting.
    SharePoint Architect || Microsoft MVP || My Blog
    Planet Technologies || SharePoint Task Force
    Wednesday, September 08, 2010 6:47 PM
  • then it must be a bug in sharepoint right..

    i attach and then say ok

    page post backs and says some fields are required

    and then the attachment disappears

    then attach it again .. dosent make sense


    jayaraja
    Thursday, September 09, 2010 12:45 PM
  • Hello Jayaraja,

    This is current design for both SharePoint 2007 and SharePoint 2010. I will update if I can find the reason why we doesn't retain attachment after fields validation.

    Regards,
    Jing Wang
    Microsoft Online Community Support

    Sunday, November 14, 2010 8:34 PM
  • great.. thank you...

    as of the customer ... he has to enter only the fields he is missing... say if he as did 100 attachments from different folder and but mistake if he has missed out the reqd field then everything goes away and he has to attach those again.. its again a big work for himm...


    jayaraja
    Thursday, December 02, 2010 4:04 PM
  • I reported the issue and the investigation is in process.

    Regards,
    Jing Wang
    Microsoft Online Community Support

    Monday, January 17, 2011 4:56 PM
  • Jim Wang,

     

    Any solution for the attachment disappear problem...............is there any chance this will be fixed in next hot fix?


    Nimesh
    Friday, April 15, 2011 9:40 PM
  • Hello Jim Wang,

    Any update on when this fix is going to be available is highly appreciated.

    At the moment this makes users go crazy when they have to re-attach things whenever they miss a required field or when a custom event receiver error is raised.

    In my case it is quite serious since, it is mandatory to attach a document to the workflow form and there are lot of other validations performed using event receivers as well . Each time when user receives an error and go back to form to correct the problem the attachments are gone!!.

    I have also noticed another issue with “Person or Group” type fields.

    When you are creating a new list Item, the value entered will get disappear when an event receiver error message fires and user navigates back to the form. All other filed values entered remains except the value entered in “Person or Group” field.

    Please let me know if you need more information or help to re-create this issue.

    Best Regards,
    Niroshana.

    Wednesday, September 07, 2011 1:50 AM
  • I reported the issue and the investigation is in process.

    Regards,
    Jing Wang
    Microsoft Online Community Support

    Hello Jim Wang,

    Any update on when this fix is going to be available is highly appreciated.

    At the moment this makes users go crazy when they have to re-attach things whenever they miss a required field or when a custom event receiver error is raised.

    In my case it is quite serious since, it is mandatory to attach a document to the workflow form and there are lot of other validations performed using event receivers as well . Each time when user receives an error and go back to form to correct the problem the attachments are gone!!.

    I have also noticed another issue with “Person or Group” type fields.

    When you are creating a new list Item, the value entered will get disappear when an event receiver error message fires and user navigates back to the form. All other filed values entered remains except the value entered in “Person or Group” field.

    Please let me know if you need more information or help to re-create this issue.

    Best Regards,
    Niroshana.

    Wednesday, September 14, 2011 6:04 AM
  • Hi Jing Wang

    I haven't seen any updates for a few months.  Are there any updates on when this could be fixed?  Or is the investigation still in progress?

    thanks!

    Thursday, October 27, 2011 8:41 PM
  • Please.....somebody respond on this issue. This is a major issue in our environment. We deal with legal issues. Sensitive data lost without no warning or anything? Come on...! One bug after another has been killing us lately with SharePoint.
    Saturday, November 05, 2011 7:52 PM
  • Same here. We are in urgent need of a fix for this behaviour!

    We're using SharePoint Server 2010 Enterprise.

    Tuesday, November 29, 2011 8:38 AM
  • I apologize for the delayed reply.

    The issue is targeted to next version of SharePoint currently.

    You may open a support ticket to request a change in current version. Otherwise, Javascript may be used to retain the value.

    http://support.microsoft.com/default.aspx?id=fh;en-us;offerprophone

     

    Regards,

    Jing Wang | Microsoft Online Community Support

    • Proposed as answer by substian Tuesday, November 19, 2013 8:26 PM
    • Unproposed as answer by substian Tuesday, November 19, 2013 8:26 PM
    Tuesday, November 29, 2011 4:08 PM
  • Any JavaScript suggestions Jing? We have used some PreSaveAction functions, and this can be successful for fairly small forms, but for large forms (lots of fields) this gets way complicated and hard to maintain.
    Wednesday, November 30, 2011 8:51 AM
  • Hi Jim ,

    How can we resove the file attachment disappear issue .

    Tuesday, November 19, 2013 11:11 PM