locked
Error when farm backup is restored in sharePoint 2013 RRS feed

  • Question

  • Hi,

    I'm trying to restore the backup of a farm into a different server. I'm using central administration for restoring the backup. 

    Can we directly use central administration to restore or do weed need to backup and restore the database seperatly? like content db, sharepoint _config.

    I tried to do it directly using the CA, but it failed. I'm new to Administrator. 

    Can anyone provide me with the detailed steps for restoring a farm in a different server? Any help is appreciated.

    Thanks in Advance,

    Regards

    Keerthi


    Monday, February 24, 2014 9:38 AM

All replies

  • What happened when you tried to restore the farm, did it give you any error messages?

    This guide shows the process for restoring a farm: http://technet.microsoft.com/en-us/library/ee428314.aspx

    There is a chance, based on other technet questions, that you might be trying to do something that can't be achieved with the farm backup. Can you provide more detail about your overall situation and goals?


    Monday, February 24, 2014 9:42 AM
  • Hi,

    When I tried to restore the farm, it gave the below error:

    Object User Profile Service Application failed in event OnRestore. For more information, see the spbackup.log or sprestore.log file located in the backup directory.

    From Logs:

    [2/19/2014 2:37:24 AM] Verbose: [StateService_ee7c35061ae5439cb4456be9a0e8b2a3] SQL Server Command: 

    IF EXISTS ( SELECT * FROM master..sysdatabases WHERE has_dbaccess(name)=1 AND name=@db_name )
    BEGIN
        SELECT 1 as ErrorCode
    END
    ELSE
    BEGIN RESTORE DATABASE [StateService_ee7c35061ae5439cb4456be9a0e8b2a3] FROM DISK=@db_location WITH STATS=5, FILE=1, MOVE @db_OldName TO @db_NewFile, MOVE @db_OldLogName TO @db_NewLogFile, NOREWIND, NOUNLOAD, RECOVERY
    END

    @db_location=C:\Farm Backup\spbr0000\0000010A.bak, @db_OldName=StateService_ee7c35061ae5439cb4456be9a0e8b2a3, @db_NewFile=C:\Program Files\Microsoft SQL Server\MSSQL11.MSSQLSERVER\MSSQL\DATA\StateService_ee7c35061ae5439cb4456be9a0e8b2a3.mdf, @db_OldLogName=StateService_ee7c35061ae5439cb4456be9a0e8b2a3_log, @db_NewLogFile=C:\Program Files\Microsoft SQL Server\MSSQL11.MSSQLSERVER\MSSQL\DATA\StateService_ee7c35061ae5439cb4456be9a0e8b2a3_log.ldf, @db_name=StateService_ee7c35061ae5439cb4456be9a0e8b2a3
    [2/19/2014 2:37:24 AM] Verbose: [StateService_ee7c35061ae5439cb4456be9a0e8b2a3] SQL command timeout is set to 1.00 hours.
    [2/19/2014 2:37:24 AM] Verbose: [ExperimentswithSP] Trying to connect to Web application http://experiments.intranet.com:1986/.
    [2/19/2014 2:37:24 AM] Verbose: [ExperimentswithSP] Trying to connect to Web application http://experiments.intranet.com:1986/.
    [2/19/2014 2:37:24 AM] Progress: [Microsoft SharePoint Foundation Web Application] 80 percent complete.
    [2/19/2014 2:37:24 AM] Verbose: Starting object: Experiments_1986.
    [2/19/2014 2:37:25 AM] FatalError: Object StateService_ee7c35061ae5439cb4456be9a0e8b2a3 failed in event OnRestore. For more information, see the spbackup.log or sprestore.log file located in the backup directory.
    SPException: The specified component exists. You must specify a name that does not exist.

    My situation and goal:

    I have a sp 2013 server(s1) deployed as farm solution (both sharepoint and SQL exist in the same server). I have set of sites in this server. s1 has 3 custom solutions (event receivers) deployed at farm level.

    Now, I want to backup and restore the farm of s1 to a different server (s2). I just want the whole farm to replicated in the s2 server.

    Thanks


    Monday, February 24, 2014 9:56 AM
  • So you have installed and configured a second SharePoint farm on s2 and are trying to restore a backup of s1 onto it.

    Are you following a guide, if so which one and at what stage are you at?

    That log file implies that something in the State Service already exists and so is hitting an error when it tries to re-create it.

    Monday, February 24, 2014 10:29 AM
  • Hi Alex,

    Yes, I have installed and configured a second SharePoint farm on s2 to restore the backup. As such I'm not following any guide, I've referred the technet sites. It would be great if you can refer some guide where I can find the steps in detail.

    The steps that I followed are:

    1) Take backup of the farm through CA.

    2) Configure the SP server (s2)

    3) Copy the backup file into s2 local folder.

    4) Restore the backup through CA.

    Do we need to check or configure anything in between these steps? and Is it good to use CA for Backup/restore?

    Thanks,

    Keerthi

    Monday, February 24, 2014 11:55 AM