locked
MSSCCPRJ.SCC file RRS feed

  • Question

  • I am not sure if this is the right place to post my problem. Sorry, I do not work with VS.

    A user stated that she wanted to select her name from a drop down list but her name is gone. Her name was there before.

    We are running VS 2003 on Windows 2003 Server. When I try to open up a project, I receive the message below.

    The solution appears to be under source control, but its binding information cannot be found. It is possible that the MSSCCPRJ.SCC file or another item that holds the source control settings for the solution, has been deleted. Because it is not possible to recover this missing information automatically, the projects whose bindings are missing will be treated as not under source control.

    I tried to access the Source Control from within VS like other people have stated. I go to File - Source Control, the options are greyed out. Is there any other way to remove the message without causing any problems. Should I run the repair from the CD?

    Thanks for any advice.

    Tuesday, March 20, 2007 2:56 PM

Answers

  • Mike,

    Repair is not going to help.

    Your solution contains some settings that tells scci package that your project is controlled. When scci tries to get the bindings from mssccprj.scc file, this file is probably not found and the solution/project end up uncontrolled - this is why you don't see any scc related option in File/SourceControl.

    One solution might be: if you do have File/SourceControl/AddSolutionToSourceControl enabled you can use that to add the project to scc (which will recreate the msccprj.scc). After that, if you don't need source control on the solution you can use File/SourceControl/ChangeSourceControl dialog to Unbind the project from scc.

    If you don't have File/SourceControl/AddSolutionToSourceControl enabled, make sure you have a provider selected as active (as Barry said, in Tools/Options). If you really don't have any source control provider installed on your machine (and can't install it), you will need to manually edit the solution and project files and remove the scc binding info:

    - in the solution file (.sln), there is a "SourceCodeControl" section
    - in the project files (.vcproj, .vbproj, .csproj, etc). The section depends on the project type, but generally there are 4 strings saved there (SccProjectName, SccAuxPath, SccLocalPath and SccProvider)

    Alin

    Monday, March 26, 2007 6:28 PM
    Moderator

All replies

  • Hi Mike,

    I have a few questions to ask you so that we can better help you with this issue that you are encountering:

    1. "A user stated that she wanted to select her name from a drop down list but her name is gone. Her name was there before. "... Where is this drop down list that she is trying to select her name? Is the drop down in a dialog and if so, what is the dialog's title caption?

    2. What Source Control provider are you guys using (ie. Visual SourceSafe, VS Team Foundation, Clearcase, etc.)? You can check for the provider you are using in Visual Studio by bringing up the Options dialog and select the Source Control node in the tree; The plugin combo box should show the provider that you are using.

    3. Do you have a Source Control (provider) application installed on your local machine?

    4. Seems like the project that you are trying to open used by be Source Code controlled. Did you recently delete any of the files that the alert message is claiming to be missing?

    5. "I go to File - Source Control, the options are greyed out."... Make sure you have a Source Control provider selected in the Tools>Options->Source Control. Also, if you create a brand new project and then look at the menu items under File>Source Control menu, do you see the menu items still greyed out?

    Thanks,

    Barry

    Wednesday, March 21, 2007 1:48 AM
    Moderator
  • Mike,

    Repair is not going to help.

    Your solution contains some settings that tells scci package that your project is controlled. When scci tries to get the bindings from mssccprj.scc file, this file is probably not found and the solution/project end up uncontrolled - this is why you don't see any scc related option in File/SourceControl.

    One solution might be: if you do have File/SourceControl/AddSolutionToSourceControl enabled you can use that to add the project to scc (which will recreate the msccprj.scc). After that, if you don't need source control on the solution you can use File/SourceControl/ChangeSourceControl dialog to Unbind the project from scc.

    If you don't have File/SourceControl/AddSolutionToSourceControl enabled, make sure you have a provider selected as active (as Barry said, in Tools/Options). If you really don't have any source control provider installed on your machine (and can't install it), you will need to manually edit the solution and project files and remove the scc binding info:

    - in the solution file (.sln), there is a "SourceCodeControl" section
    - in the project files (.vcproj, .vbproj, .csproj, etc). The section depends on the project type, but generally there are 4 strings saved there (SccProjectName, SccAuxPath, SccLocalPath and SccProvider)

    Alin

    Monday, March 26, 2007 6:28 PM
    Moderator