none
"The SPListItem being updated was not retrieved with all taxonomy fields." Exception while updating a taxaonomy field

    Question

  • Hi All,

    I'm getting this exception "The SPListItem being updated was not retrieved with all taxonomy fields." when i try to programatically update a taxonomy field of a list item. Can any1 pls tell me why this exception occurs ???

    Wednesday, January 05, 2011 10:38 AM

Answers

  • Do you try to set fields values programmatically or it happens when you do it in SP UI.

    If programatically then maybe this blog post can help you

    http://www.sharepoint4developers.net/en-nz/post/setting-taxonomy-field-values.aspx


    Lightning Tools Check out our SharePoint tools and web parts
    • Marked as answer by Wayne Fan Tuesday, January 11, 2011 7:53 AM
    Thursday, January 06, 2011 9:50 AM
  • Recently hit this myself, as well.  Turns out it's a central admin setting that throttles the lookup return count, and Taxonomy fields are just lookups under the hood.

    Go into Central Administration, Manage Web Applications, select your web application, and then in the ribbon choose the dropdown under General Settings select Resource Throttling.  Find the setting for "List View Lookup Threshold" and raise it from the default 8 (can go up to 1000, but 20 is likely fine depending how many lookup fields you're pulling back in your SPListItem).

    • Marked as answer by Wayne Fan Tuesday, January 11, 2011 7:53 AM
    Friday, January 07, 2011 6:12 PM

All replies

  • Do you try to set fields values programmatically or it happens when you do it in SP UI.

    If programatically then maybe this blog post can help you

    http://www.sharepoint4developers.net/en-nz/post/setting-taxonomy-field-values.aspx


    Lightning Tools Check out our SharePoint tools and web parts
    • Marked as answer by Wayne Fan Tuesday, January 11, 2011 7:53 AM
    Thursday, January 06, 2011 9:50 AM
  • Recently hit this myself, as well.  Turns out it's a central admin setting that throttles the lookup return count, and Taxonomy fields are just lookups under the hood.

    Go into Central Administration, Manage Web Applications, select your web application, and then in the ribbon choose the dropdown under General Settings select Resource Throttling.  Find the setting for "List View Lookup Threshold" and raise it from the default 8 (can go up to 1000, but 20 is likely fine depending how many lookup fields you're pulling back in your SPListItem).

    • Marked as answer by Wayne Fan Tuesday, January 11, 2011 7:53 AM
    Friday, January 07, 2011 6:12 PM
  • I tried to update one of a taxonomy value in a list but ended up with the same error "The SPListItem being updated was not retrieved with all taxonomy fields"

    When I removed my viewfields of the SPQuery everything went fine. I believe the reason is Taxonomy column in a list includes subcolumns with note value. (not sure though)

     


    Thanks
    Sunday, December 11, 2011 9:43 PM
  • I am getting this in office 365 too. There is no Resource Throlttling in admin center
    Tuesday, April 23, 2013 8:15 PM
  • Taxonomy fields have a hidden note field that is responsible for storing the actual data. In my case this error was occurring when this  hidden field was missing from the list. 
    Thursday, May 30, 2013 6:14 PM
  • I came across this in Office 365 too.

    For us it was a Links list created in the user interface, no code, but it did have the exterprise keywords field switched on for the list.

    By removing and re-adding the enterprise keywords field on this list I have cleared the error.

    Hmm. The joy of Office 365 glitches!


    Ruth, UK

    • Proposed as answer by Lalita Mittal Thursday, April 14, 2016 6:48 AM
    Friday, January 30, 2015 12:16 PM
  • hi

    I have same problem but the problem occurs only If I change the display language of sharepoint 2013 English to Turkish. ın English every thing just fine. 

    What could be problem ? Any idea. I could not find any result from MS forum site neither google.


    S. Aziz KAZDAL

    Wednesday, August 19, 2015 2:13 PM