none
error: Task could not find "lc.exe" using the SdkToolsPath "C:\Program Files (x86)\Microsoft SDKs\Windows\v10.0A\bin\NETFX 4.7.2 Tools\" RRS feed

  • Question

  • My Visual Studio 2019 have an error 

    Error Task could not find "lc.exe" using the SdkToolsPath

    "C:\Program Files (x86)\Microsoft SDKs\Windows\v10.0A\bin\NETFX 4.7.2 Tools\"

    or the registry key "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft SDKs\NETFXSDK\4.7.2\WinSDK-NetFx40Tools-x86".

    Make sure the SdkToolsPath is set and the tool exists in the correct processor specific location under the SdkToolsPath

    and that the Microsoft Windows SDK is installed Tenants


    in my computer I see only the Folder 

    C:\Program Files (x86)\Microsoft SDKs\Windows\v10.0A\bin\NETFX 4.8 Tools

    I tried installing SDK 4.7.2 and this is the message I got:

    "NET Framework 4.7.2 or a later update is already installed on this computer."

    How can I solve this problem?

    Sunday, September 1, 2019 6:38 PM

Answers

  • OK I Uninstalled with "windows installer Cleanup" the extra "old .net framewok"  and it fixed the problem
    • Marked as answer by MosheS Singer Sunday, September 1, 2019 8:10 PM
    Sunday, September 1, 2019 8:10 PM

All replies

  • Hello,

    Since this is not a specific VB.NET issue your post is being moved to the Visual Studio General question forum. You might look at the following post which indicates (and this may or may not be the case about 32 and 64 compiling).

    https://stackoverflow.com/questions/26103582/task-could-not-find-lc-exe-using-sdktoolspath


    Please remember to mark the replies as answers if they help and unmarked them if they provide no help, this will help others who are looking for solutions to the same or similar problem. Contact via my Twitter (Karen Payne) or Facebook (Karen Payne) via my MSDN profile but will not answer coding question on either.

    NuGet BaseConnectionLibrary for database connections.

    StackOverFlow
    profile for Karen Payne on Stack Exchange

    Sunday, September 1, 2019 6:59 PM
  • OK I Uninstalled with "windows installer Cleanup" the extra "old .net framewok"  and it fixed the problem
    • Marked as answer by MosheS Singer Sunday, September 1, 2019 8:10 PM
    Sunday, September 1, 2019 8:10 PM
  • Hi MosheS,

    We are glad to hear that your issue has been solved by yourself. So if you have any other issues about this aspect, please feel free to let us know. We are willing to help you further.

    Thanks for your understanding.

    Best Regards,

    Perry


    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com

    Monday, September 2, 2019 3:03 AM
  • Thats a scam to install "windows installer Cleanup" whats the solution?!
    Saturday, October 19, 2019 9:46 AM