none
Connection manager :changes are not saved after edit ,the package still retains the old server name RRS feed

  • Question

  • I copied a prod pkg to my local machine and opened it in BIDS .The package had a oledb connection to sql server .I wanted to chnage it and point it to my local machine sql server.But whenever I make changes in the connection manager the settings are not saved .

    bids 2008r2

    What might be the issue?


    Mudassar

    Friday, January 25, 2013 6:53 PM

Answers

  • I am betting that the connection is using a configuration.  What version are you using.  If it is SSIS 2008R2 to 2005 then right click in the control flow and choose configuration manager.  There is probably an entry to map the onnection string.  If you disable it and reset the connection string you should be able to run it locally.  If it is SSIS 2012 check to see if the connection is mapped to a parameter.

    Also check the Expression property of the connection manager and see if there is an expression setting for one of the connection proerpties

    Hopet his helps


    David Dye My Blog


    • Edited by David DyeModerator Friday, January 25, 2013 7:01 PM add expression
    • Marked as answer by MLTC Friday, January 25, 2013 7:25 PM
    Friday, January 25, 2013 6:59 PM
    Moderator
  • Prod server: SQL server 2008

    Local Machine :SQL server 2008r2

    No package configurations set .

    Connection manager has a expression configured.I am now going to delete the expression


    Mudassar

    • Marked as answer by MLTC Friday, January 25, 2013 7:25 PM
    Friday, January 25, 2013 7:13 PM

All replies

  • Make sure you 1st create a SSIS project - then add the package to it and only perform any desired modifications. You will not be able also to execute it w/o being in a project.

    Arthur My Blog

    Friday, January 25, 2013 6:57 PM
    Moderator
  • I am betting that the connection is using a configuration.  What version are you using.  If it is SSIS 2008R2 to 2005 then right click in the control flow and choose configuration manager.  There is probably an entry to map the onnection string.  If you disable it and reset the connection string you should be able to run it locally.  If it is SSIS 2012 check to see if the connection is mapped to a parameter.

    Also check the Expression property of the connection manager and see if there is an expression setting for one of the connection proerpties

    Hopet his helps


    David Dye My Blog


    • Edited by David DyeModerator Friday, January 25, 2013 7:01 PM add expression
    • Marked as answer by MLTC Friday, January 25, 2013 7:25 PM
    Friday, January 25, 2013 6:59 PM
    Moderator
  • I have pasted my prod package in a project even then I am not able to make any chnages to it and save it.

    Mudassar

    Friday, January 25, 2013 7:01 PM
  • Prod server: SQL server 2008

    Local Machine :SQL server 2008r2

    No package configurations set .

    Connection manager has a expression configured.I am now going to delete the expression


    Mudassar

    • Marked as answer by MLTC Friday, January 25, 2013 7:25 PM
    Friday, January 25, 2013 7:13 PM
  • Just delete it and put back a replica with the new source.

    Arthur My Blog

    Friday, January 25, 2013 7:15 PM
    Moderator
  • To this day, I am still always having to open the dtsx file in notepad and physically change my connection strings or even drive letters.  The IDE does not work at saving any information.

    keith

    Thursday, August 9, 2018 12:49 PM