locked
не запускается эмулятор RRS feed

  • Вопрос

  • Здравствуйте!

    Не запускается эмулятор. При запуске эмулятора из студии каждый раз валятся разные ошибки от "Неизвестное устройство", "Ошибка службы RPC" до "Connection failed because of invalid command line arguments". При запуске XdeLauncher.exe "Windows Phone 7" "Windows Phone Emulator" эмулятор моргает пару раз и исчезает. Переставлял WP developer tools много раз - не помогло. Последний раз еще снес и студию, и поставил VS2010 Express for Windows Phone, которая в пакете WPDT - эмулятор начал запускаться, но отображает "windows phone 7 emulator is doing a complete os boot". Короче я в растерянности, накопал кучу обсуждений на тему ошибок запуска эмулятора, но никаких конкретных рецептов по излечению не нашел.

    Система, ноутбук - Windows 7 x64/P6100/4gb RAM/geforce 310M

    Спасибо!

    22 сентября 2011 г. 8:08

Ответы

  • По железу конфигурация хорошая.
    Какая версия WP Developer Tools? (их уже много версий - 7.0, 7.1 Beta, 7.1 RC)
    Если эмулятор начинает запускаться и уже есть надпись "windows phone 7 emulator is doing a complete os boot" - это хороший признак. Если после этого эмулятор отваливается и пытается перезапуститься - обычно дело или в количестве памяти или в видеокарте. Хотя по конфигурации памяти более чем достаточно - лучше лишних приложений не запускать, хотя бы во время запуска эмулятора. Ещё важный момент тот, что эмулятор использует DirectX10, поэтому желательно проверить драйвера на обновление (http://www.nvidia.ru/Download/index.aspx?lang=ru)
    • Помечено в качестве ответа hujg 22 сентября 2011 г. 18:24
    22 сентября 2011 г. 9:25

Все ответы

  • По железу конфигурация хорошая.
    Какая версия WP Developer Tools? (их уже много версий - 7.0, 7.1 Beta, 7.1 RC)
    Если эмулятор начинает запускаться и уже есть надпись "windows phone 7 emulator is doing a complete os boot" - это хороший признак. Если после этого эмулятор отваливается и пытается перезапуститься - обычно дело или в количестве памяти или в видеокарте. Хотя по конфигурации памяти более чем достаточно - лучше лишних приложений не запускать, хотя бы во время запуска эмулятора. Ещё важный момент тот, что эмулятор использует DirectX10, поэтому желательно проверить драйвера на обновление (http://www.nvidia.ru/Download/index.aspx?lang=ru)
    • Помечено в качестве ответа hujg 22 сентября 2011 г. 18:24
    22 сентября 2011 г. 9:25
  • Спасибо! Обновил драйвера, удалил с жесткого диска все папки связанные с WPDT и опять переставил все с нуля (в который раз!). На этот раз эмулятор заработал!
    22 сентября 2011 г. 18:27