none
C#, комментарии в на русском языке RRS feed

  • Вопрос

  • Всем привет!

    Проблема -

    Перенес свои программы на другой компьютер, 
    русско-языкие комментарии стали нечитабельными.
    Однако новые, те, которые ввожу заново, читаются нормально.

    Куда залезть, чтобы восстановиться?

    12 февраля 2013 г. 12:43

Ответы

  • Добрый день,

    Часто просто изменить на UTF-8 не достаточно.

    Советую проверить региональные настройки в "Панеле Управления - Язык и региональные стандарты - Дополнительно - Язык програм не поддерживающих Юникод", измените на - Русский. Затем надо будет перезагрузить и проверить.

    Надеюсь поможет.


    13 февраля 2013 г. 14:19
    Модератор

Все ответы

  • Посмотрите в какой кодировке были сохранены файлы на старом компьютере (File- Advanced save option), для нормально работы с русским лучше сохранять в UTF-8 (65001)
    12 февраля 2013 г. 12:55
  • "File- Advanced save option" -
    Не нашел, где это?
    В Сервис - Параметры - Текстовый редактор - Общие 
    Отмечена галочка "Автоматически определять кодировку UTF-8 без сигнатуры"
    Больше про UTF-8 нигде не нашел.
    Эта галочка отмечена на обоих компах.

    12 февраля 2013 г. 13:23
  • К сожалению у меня унглийская студия, поэтому как по русски будет сказать не смогу,но находится это в меню Файл, под пунктом сохранить
    12 февраля 2013 г. 13:28
  • Advanced save option - Это дополнительные опции сохранения.
    В меню Файл у меня их нет.
    Но где-то должны быть.
    12 февраля 2013 г. 13:52
  • Попробуйте прям такое кривое решение. Копировать весть текст файла (включая код) и вставлять в блокнот. Если там текст читается, то потом копировать из блокнота и обратно в студию. Доводилось как то так лечить подобные проблемы

    Женат на WPF. Тайно встречаюсь с WinRT. Не сложилось с C#!

    12 февраля 2013 г. 15:17
    Отвечающий
  • Оригинальное решение...
    Но тоже не работает.
    Русские тексты в блокноте не работают,
    те, которые переписаны с компа на комп,
    а те которые записаны на новом компе, те работают,
    а в Word-е и Exсel-е работают и переписанные и родные.
    Была там какая-то беда...
    Какие-то фонты надо где-то прописать.
    Я в этом давно хотел разобраться, но так руки и не дошли.
    • Изменено QazRdx 12 февраля 2013 г. 17:07
    12 февраля 2013 г. 17:04
  • Добрый день,

    Часто просто изменить на UTF-8 не достаточно.

    Советую проверить региональные настройки в "Панеле Управления - Язык и региональные стандарты - Дополнительно - Язык програм не поддерживающих Юникод", измените на - Русский. Затем надо будет перезагрузить и проверить.

    Надеюсь поможет.


    13 февраля 2013 г. 14:19
    Модератор