none
Поддержка NET Framework 3.5 и 4.0 RRS feed

  • Вопрос

  • Всем привет.

    Возможно ли в приложении на C# реализовать поддержку NET Framework 3.5 и 4.0 (и если можно остальных более ранних версий) ?

    19 апреля 2011 г. 17:31

Ответы

  • Нет поддержки сверху вниз, есть только поддержка снизу вверх.
    Но если Вы в своей программе не используете новейших возможностей, 
    то можно передать программу в текстовом виде,
    а там заново создать проект и вписать в него текст программы 
    • Помечено в качестве ответа Abolmasov Dmitry 20 апреля 2011 г. 12:23
    19 апреля 2011 г. 18:02

Все ответы

  • Как только Вам понадобилось открыть проект ранней версии, фреймворк последней установленной у Вас версии тут же переформачивает этот проект под последнюю версию.
    Ни одного проекта, несовместимого с последней версией, у меня не было. 

    19 апреля 2011 г. 17:38
  • Как только Вам понадобилось открыть проект ранней версии, фреймворк последней установленной у Вас версии тут же переформачивает этот проект под последнюю версию.
    Ни одного проекта, несовместимого с последней версией, у меня не было. 


    У меня стоит 4 и софт соответственно под 4. Но если допустим человеку програмку скинуть, то у него она работать не будет на 3.5 (по дефолту в win7). Именно поэтому я и спросил, возможна ли такая реализация в одном софте, чтобы у тех кто на 3.5 он работал.
    19 апреля 2011 г. 17:57
  • Нет поддержки сверху вниз, есть только поддержка снизу вверх.
    Но если Вы в своей программе не используете новейших возможностей, 
    то можно передать программу в текстовом виде,
    а там заново создать проект и вписать в него текст программы 
    • Помечено в качестве ответа Abolmasov Dmitry 20 апреля 2011 г. 12:23
    19 апреля 2011 г. 18:02
  • То есть если софт не использует новых возможностей которые реализуются в версии 4, то можно как-то сделать его на 3.5 . Но как? Компилировать с установленым 3.5 ?
    20 апреля 2011 г. 1:24
  • Не проект 4 компилировать в 3.5, а создать новый проект в 3.5 и перенести в него все тексты из проекта 4, а потом компилировать.
    20 апреля 2011 г. 2:44
  • Не проект 4 компилировать в 3.5, а создать новый проект в 3.5 и перенести в него все тексты из проекта 4, а потом компилировать. Как создать новый проект в 3.5 ? Это в настройках где-то указывается ?
    20 апреля 2011 г. 3:58
  • Если есть 3.5 у кого-то, как Вы говорите, то создать проект 3.5 там, на той машине, и туда перенести тексты Ваших программ.
    А еще лучше, пусть Ваш друг обновится до 4 и обменивайтесь как хотите - и туда, и обратно. 
    20 апреля 2011 г. 4:11
  • Все ясно. Спасибо
    20 апреля 2011 г. 5:05