none
Ошибка при нажатии пункта меню updatereference в Visual Studion. RRS feed

  • Вопрос

  • Текст ошибки:"Превышена квота максимального числа символов в таблице имен(16384)"

    Привожу конфиги клиента и сервера:

    Конфиг сервера:

    <system.serviceModel>
        <bindings>
          <customBinding>
            <binding name="TestMexBinding" openTimeout="00:00:30" sendTimeout="00:00:30" receiveTimeout="00:00:30" closeTimeout="00:00:30">
            
              <tcpTransport maxPendingConnections="1000" portSharingEnabled="true" listenBacklog="1000">
                <connectionPoolSettings groupName="default" maxOutboundConnectionsPerEndpoint="1000" />
                
              </tcpTransport>
            </binding>
          </customBinding>
          <netTcpBinding>
            <binding name="binding" maxConnections="1000"  listenBacklog="1000"  portSharingEnabled="true" openTimeout="00:00:30" sendTimeout="00:00:30" receiveTimeout="00:00:30" closeTimeout="00:00:30" hostNameComparisonMode="StrongWildcard" maxBufferSize="2147483647" maxBufferPoolSize="2147483647" maxReceivedMessageSize="2147483647">
              <readerQuotas maxDepth="2147483647" maxStringContentLength="2147483647" maxArrayLength="2147483647" maxBytesPerRead="2147483647" maxNameTableCharCount="2147483647" />
              <reliableSession ordered="true" inactivityTimeout="00:00:30"
                           enabled="false" />
              <security mode="None">
              </security>
            </binding>
          </netTcpBinding>
        </bindings>
        <!-- This section is optional with the new configuration model
               introduced in .NET Framework 4. -->
        <services>
          <service behaviorConfiguration="CalculatorServiceBehavior" name="WebServiceCadTech.TechPlan">
            <endpoint address="" binding="netTcpBinding" bindingConfiguration="binding" behaviorConfiguration="" name="NetTcpBindingEndpoint" contract="WebServiceCadTech.ITechPlan">
            </endpoint>
            <endpoint address="mex" binding="customBinding" bindingConfiguration="TestMexBinding" contract="IMetadataExchange" />
            <host>
              <baseAddresses>
                <add baseAddress="net.tcp://develop-3:2021/TechPlan" />
              </baseAddresses>
            </host>
          </service>
        </services>
        <behaviors>
          <serviceBehaviors>
            <behavior name="CalculatorServiceBehavior">
              <serviceMetadata httpGetEnabled="false" />
              <dataContractSerializer maxItemsInObjectGraph="2147483647" />
              <serviceDebug includeExceptionDetailInFaults="true" />
              <serviceThrottling maxConcurrentCalls="1000" maxConcurrentSessions="1000" maxConcurrentInstances="1000" />
            </behavior>
          </serviceBehaviors>
        </behaviors>
      </system.serviceModel>
      

    Конфиг клиента:

     <system.serviceModel>
            <bindings>
                <netTcpBinding>
                    <binding name="NetTcpBindingEndpoint1" closeTimeout="00:30:00"
                        openTimeout="00:30:00" receiveTimeout="00:30:00" sendTimeout="00:30:00"
                        transactionProtocol="OleTransactions" hostNameComparisonMode="StrongWildcard"
                        listenBacklog="1000" maxBufferPoolSize="2147483647" maxConnections="1000"
                        maxReceivedMessageSize="2147483647">
                        <readerQuotas maxDepth="32" maxStringContentLength="2147483647"
                            maxArrayLength="2147483647" maxBytesPerRead="2147483647" maxNameTableCharCount="2147483647" />
                        <reliableSession ordered="true" inactivityTimeout="00:30:00"
                            enabled="false" />
                        <security mode="None" />
                    </binding>
                </netTcpBinding>
            </bindings>
            <client>
                <endpoint address="net.tcp://develop-3:2021/TechPlan" behaviorConfiguration="MaxBehavior"
                    binding="netTcpBinding" bindingConfiguration="NetTcpBindingEndpoint1"
                    contract="TechPlan.ITechPlan" name="NetTcpBindingEndpoint1" />
            </client>
          <behaviors>
            <endpointBehaviors>
              <behavior name="MaxBehavior">
                <clientCredentials>
                <serviceCertificate>
                  <authentication certificateValidationMode="None" />
                </serviceCertificate>
                  </clientCredentials>
                <dataContractSerializer maxItemsInObjectGraph="2147483647"/>
              </behavior>
            </endpointBehaviors>
          </behaviors>
        </system.serviceModel>

    Поискал в google ответ вроде бы надо править SvcUtil.exe.config, поправил следующим образом(конфиг лежит по пути C:\Program Files\Microsoft SDKs\Windows\v7.0A\bin):

    <?xml version="1.0" encoding="utf-8"?>
    <configuration>
        <system.serviceModel>
            <bindings>
               <customBinding>
            <binding name="TestMexBinding" openTimeout="00:00:30" sendTimeout="00:00:30" receiveTimeout="00:00:30" closeTimeout="00:00:30">
              <tcpTransport maxPendingConnections="1000" portSharingEnabled="true" listenBacklog="1000">
                <connectionPoolSettings groupName="default" maxOutboundConnectionsPerEndpoint="1000" />
               
              </tcpTransport>
            </binding>
          </customBinding>
          <netTcpBinding>
            <binding name="binding" maxConnections="1000"  listenBacklog="1000"  portSharingEnabled="true" openTimeout="00:00:30" sendTimeout="00:00:30" receiveTimeout="00:00:30" closeTimeout="00:00:30" hostNameComparisonMode="StrongWildcard" maxBufferSize="2147483647" maxBufferPoolSize="2147483647" maxReceivedMessageSize="2147483647">
              <readerQuotas maxDepth="2147483647" maxStringContentLength="2147483647" maxArrayLength="2147483647" maxBytesPerRead="2147483647" maxNameTableCharCount="2147483647" />
              <reliableSession ordered="true" inactivityTimeout="00:00:30"
                           enabled="false" />
              <security mode="None">
              </security>
            </binding>
          </netTcpBinding>
            </bindings>
            <client>
                <endpoint binding="netTcpBinding" bindingConfiguration="binding"
                    contract="IMetadataExchange"
                    name="tcp" />
            </client>
        </system.serviceModel>
    </configuration>
    но все равно та же ошибка



Ответы

Все ответы