none
Ошибка при установке Team Foundation Server 2012 RRS feed

  • Вопрос

  • Добрый день!

    Я пытаюсь установить TFS 2012 на Windows Server 2012 Datacenter и получаю ошибку на шаге "Configuring Services":

    [Error @08:27:34.212] TF255175: The application setting could not be set for the web.config file with a key or a value. Key: applicationId. Value: 1d1c6438-7a90-4a10-b29f-fac2c108cf18.
    [Error @08:27:34.222] 
    Exception Message: This configuration section cannot be used at this path. This happens when the site administrator has locked access to this section using <location allowOverride="false"> from an inherited configuration file. (type ConfigurationErrorsException)
    Exception Stack Trace: at System.Configuration.MgmtConfigurationRecord.GetConfigDefinitionUpdates(Boolean requireUpdates, ConfigurationSaveMode saveMode, Boolean forceSaveAll, ConfigDefinitionUpdates& definitionUpdates, ArrayList& configSourceUpdates)
    at System.Configuration.MgmtConfigurationRecord.SaveAs(String filename, ConfigurationSaveMode saveMode, Boolean forceUpdateAll)
    at Microsoft.TeamFoundation.Admin.ConfigureSetConfigInstanceId.Run(ActivityContext context)

    Где надо поменять location allowOverride на true?

    Спасибо.

    26 июля 2013 г. 13:20

Ответы

Все ответы

  • Не приходилось сталкиваться. Но судя по ошибко возможно секция находится в файле Machine.config.

    Сделаем содержимое сообщества лучше, вместе!

    28 июля 2013 г. 5:09
    Модератор
  • Спасибо за Ваш ответ!

    Но в файле по адресу C:\Windows\Microsoft.NET\Framework64\v4.0.30319\Config\machine.config нет секции location.. Вы думаете, ее нужно добавить?

    28 июля 2013 г. 19:18
  • Здравствуйте,

    Да, надо будет добавить.


    Если вам помог чей-либо ответ, пожалуйста, не забывайте жать на кнопку "Предложить как ответ" или "Проголосовать за полезное сообщение"

    29 июля 2013 г. 10:24
    Модератор
  • Вот здесь http://support.microsoft.com/kb/815174/ru посмотрел пример:

    <location path="Default Web Site/MyApp" allowOverride="true"> <system.web> <authorization> <allow users="?" /> </authorization> </system.web> </location>

    Только не понятно, что указывать в параметре path?

    Ведь я не знаю, как TFS собирается назвать виртуальную

    директорию.

    Спасибо, очень надеюсь на Вашу помощь.


    • Изменено YatajgaEditor 29 июля 2013 г. 18:57 фрм.
    29 июля 2013 г. 13:11
  • Ну если пояснее, то чтото вроде SiteName/UrlPath, но думаю что в machine.config'е можно и на подобие этого писать http://localhost/myapp


    Если вам помог чей-либо ответ, пожалуйста, не забывайте жать на кнопку "Предложить как ответ" или "Проголосовать за полезное сообщение"

    29 июля 2013 г. 13:25
    Модератор
  • Добавил такой блок:

       <location path="Team Foundation Server/tfs" allowOverride="true">
            <system.web>
                <authorization>
                    <allow users="?" />
                </authorization>
            </system.web>
        </location>

    Надолго задумывается и потом просто установщик отваливается.

    На всякий случай попробовал вот так:

    <location path="http://localhost:8080/tfs" allowOverride="true">
            <system.web>
                <authorization>
                    <allow users="?" />
                </authorization>
            </system.web>
        </location>

    Точно такой же эффект.

    29 июля 2013 г. 14:07
  • Приведу более полный лог. Возможно, здесь есть какая-то дополнительная полезная информация:

    [Info   @12:17:19.920] +-+-+-+-+-| Running Configuring Services: Configuring Services |+-+-+-+-+-
    [Info   @12:17:19.921] 
    [Info   @12:17:19.921] +-+-+-+-+-| Configuring Services |+-+-+-+-+-
    [Info   @12:17:19.921] Starting Node: CONTAINER
    [Info   @12:17:19.921] NodePath : Container/Progress
    [Info   @12:17:19.921] Node returned: Ignore
    [Info   @12:17:19.921] Completed Configuring Services: Ignore
    [Info   @12:17:19.921] -----------------------------------------------------
    [Info   @12:17:19.921] 
    [Info   @12:17:19.921] +-+-+-+-+-| Running EmailAlerts: EmailAlerts |+-+-+-+-+-
    [Info   @12:17:19.921] 
    [Info   @12:17:19.921] +-+-+-+-+-| EmailAlerts |+-+-+-+-+-
    [Info   @12:17:19.921] Starting Node: CONDITION
    [Info   @12:17:19.921] NodePath : Container/Progress/Conditional
    [Info   @12:17:19.921] Node returned: Ignore
    [Info   @12:17:19.921] Completed EmailAlerts: Ignore
    [Info   @12:17:19.921] -----------------------------------------------------
    [Info   @12:17:19.921] 
    [Info   @12:17:19.921] +-+-+-+-+-| Running EmailAlerts: Configure email alert settings |+-+-+-+-+-
    [Info   @12:17:19.922] 
    [Info   @12:17:19.922] +-+-+-+-+-| Configure email alert settings |+-+-+-+-+-
    [Info   @12:17:19.922] Starting Node: CALERTS
    [Info   @12:17:19.922] NodePath : Container/Progress/Conditional/CALERTS
    [Info   @12:17:19.944] Node returned: Success
    [Info   @12:17:19.944] Completed EmailAlerts: Success
    [Info   @12:17:19.944] -----------------------------------------------------
    [Info   @12:17:19.944] 
    [Info   @12:17:19.944] +-+-+-+-+-| Running RegistryEntries: RegistryEntries |+-+-+-+-+-
    [Info   @12:17:19.944] 
    [Info   @12:17:19.944] +-+-+-+-+-| RegistryEntries |+-+-+-+-+-
    [Info   @12:17:19.944] Starting Node: CONDITION
    [Info   @12:17:19.944] NodePath : Container/Progress/Conditional
    [Info   @12:17:19.944] Node returned: Ignore
    [Info   @12:17:19.944] Completed RegistryEntries: Ignore
    [Info   @12:17:19.944] -----------------------------------------------------
    [Info   @12:17:19.944] 
    [Info   @12:17:19.944] +-+-+-+-+-| Running DisableUserAgents: Register disabled user agents |+-+-+-+-+-
    [Info   @12:17:19.945] 
    [Info   @12:17:19.945] +-+-+-+-+-| Register disabled user agents |+-+-+-+-+-
    [Info   @12:17:19.945] Starting Node: CXUSERAGENTS
    [Info   @12:17:19.945] NodePath : Container/Progress/Conditional/CXUSERAGENTS
    [Info   @12:17:19.964] Node returned: Success
    [Info   @12:17:19.964] Completed DisableUserAgents: Success
    [Info   @12:17:19.964] -----------------------------------------------------
    [Info   @12:17:19.964] 
    [Info   @12:17:19.964] +-+-+-+-+-| Running RegisterInstalledLanguages: Register Installed Languages |+-+-+-+-+-
    [Info   @12:17:19.965] 
    [Info   @12:17:19.965] +-+-+-+-+-| Register Installed Languages |+-+-+-+-+-
    [Info   @12:17:19.965] Starting Node: CREGINSLANG
    [Info   @12:17:19.965] NodePath : Container/Progress/Conditional/CREGINSLANG
    [Info   @12:17:19.985] Node returned: Success
    [Info   @12:17:19.985] Completed RegisterInstalledLanguages: Success
    [Info   @12:17:19.985] -----------------------------------------------------
    [Info   @12:17:19.985] 
    [Info   @12:17:19.985] +-+-+-+-+-| Running DefaultLabSettings: Configure default lab settings |+-+-+-+-+-
    [Info   @12:17:19.986] 
    [Info   @12:17:19.986] +-+-+-+-+-| Configure default lab settings |+-+-+-+-+-
    [Info   @12:17:19.986] Starting Node: CLABSETTINGS
    [Info   @12:17:19.986] NodePath : Container/Progress/Conditional/CLABSETTINGS
    [Info   @12:17:20.018] Node returned: Success
    [Info   @12:17:20.018] Completed DefaultLabSettings: Success
    [Info   @12:17:20.018] -----------------------------------------------------
    [Info   @12:17:20.018] 
    [Info   @12:17:20.018] +-+-+-+-+-| Running SetConfigInstanceId: Update web.config file with instance id |+-+-+-+-+-
    [Info   @12:17:20.018] 
    [Info   @12:17:20.018] +-+-+-+-+-| Update web.config file with instance id |+-+-+-+-+-
    [Info   @12:17:20.018] Starting Node: CUPDINSTID
    [Info   @12:17:20.018] NodePath : Container/Progress/CUPDINSTID
    [Info   @12:17:20.022] connectionString: Data Source=WIN-LREC6QGJ5ID\SqlExpress;Initial Catalog=Tfs_Configuration;Integrated Security=True
    [Info   @12:17:20.023] instanceId: da6b39c7-dff0-4b9a-bfd9-37d78e2591fe
    [Info   @12:17:20.024] websiteVdir:/tfs
    [Info   @12:17:20.024] m_atWebsiteName:Team Foundation Server
    [Info   @12:17:20.039] ensured removed
    [Info   @12:17:20.040] adding key:applicationId value:da6b39c7-dff0-4b9a-bfd9-37d78e2591fe
    [Error  @12:17:20.040] TF255175: The application setting could not be set for the web.config file with a key or a value. Key: applicationId. Value: da6b39c7-dff0-4b9a-bfd9-37d78e2591fe.
    [Error  @12:17:20.040] 
    Exception Message: This configuration section cannot be used at this path.  This happens when the site administrator has locked access to this section using <location allowOverride="false"> from an inherited configuration file. (type ConfigurationErrorsException)
    Exception Stack Trace:    at System.Configuration.MgmtConfigurationRecord.GetConfigDefinitionUpdates(Boolean requireUpdates, ConfigurationSaveMode saveMode, Boolean forceSaveAll, ConfigDefinitionUpdates& definitionUpdates, ArrayList& configSourceUpdates)
       at System.Configuration.MgmtConfigurationRecord.SaveAs(String filename, ConfigurationSaveMode saveMode, Boolean forceUpdateAll)
       at Microsoft.TeamFoundation.Admin.ConfigureSetConfigInstanceId.Run(ActivityContext context)
    29 июля 2013 г. 14:08
  • А под каким уровнем доверия работает сервер?


    Если вам помог чей-либо ответ, пожалуйста, не забывайте жать на кнопку "Предложить как ответ" или "Проголосовать за полезное сообщение"

    29 июля 2013 г. 14:22
    Модератор
  • Могли бы Вы уточнить где это можно посмотреть, чтобы быть уверенным, что мы об одном говорим? В папках TFS есть файл C:\Program Files\Microsoft Team Foundation Server 11.0\Application Tier\Web Services\web.config.template. Там есть секция

    <!-- need to force the level as full trust since we may be installing
                 to a web site that runs at a lower trust level (like WSS) -->
        <trust level="Full" originUrl="" />

    Я пробовал там выставлять trust level="Medium". Получал такую же ошибку.

    Также сейчас попробовал в IIS на уровне сервера в разделе .NET Trust Levels выставить Minimal. Ничего не изменилось.
    29 июля 2013 г. 15:51
  • Решил проблему!
    В IIS на уровне сервера открыл Feautere Delegated и для всех элементов включил Read/Write. Установка прошла успешно. Вдальнейшем верну настройки обратно.
    Всем большое спасибо!
    • Помечено в качестве ответа YatajgaEditor 29 июля 2013 г. 18:57
    29 июля 2013 г. 18:36
  • Просто уровни доверия тоже про IIS думал, странно что на full не работало.

    Спасибо, что поделились решением.


    Если вам помог чей-либо ответ, пожалуйста, не забывайте жать на кнопку "Предложить как ответ" или "Проголосовать за полезное сообщение"

    30 июля 2013 г. 5:50
    Модератор