none
Можно ли в ASP.NET 5 добавить классическую .NET dll (v.4.6.1) RRS feed

  • Вопрос

  • Всем привет! Подскажите пожалуйста, можно ли в проект aps.net 5 1.0.0-rc1-update1 (fullCLR) добавить обычную C# dll v.4.6.1. У меня не добавляет. Если изменить версию на 4.5.1 то добавляет, но перестает собирать пакеты.
    12 января 2016 г. 14:07

Ответы

  • Спасибо за ответ! К сожалению ни один из вариантов не работает. Более того, если изменить dnx с 451 на 561 все виснет. Тикет есть на github
    • Помечено в качестве ответа umputun 14 января 2016 г. 7:15
    14 января 2016 г. 7:15

Все ответы

  • Здравствуйте,

    Поробуйте следовать шагам из этой темы http://stackoverflow.com/questions/31804623/issue-adding-reference-to-class-libary-project-in-asp-net-5-vnext :

    1. Create a new web app project

    2. Remove the "dnxcore50" framework from project.json

    3. Add a new project for a normal class library

    4. Manually move the class library project into the /src folder (otherwise I get error "The dependency MyClassLibrary1 >= 1.0.0-* could not be resolved.")

    5. Add a reference to this class library

    Если не работает, посмотрите:


    Если Вам помог чей-либо ответ, пожалуйста, не забывайте жать на кнопку "Предложить как ответ" или "Проголосовать за полезное сообщение" Мнения, высказанные здесь, являются отражение моих личных взглядов, а не позиции корпорации Microsoft. Вся информация предоставляется "как есть" без каких-либо гарантий.

    • Предложено в качестве ответа YatajgaEditor 14 января 2016 г. 6:18
    13 января 2016 г. 11:39
    Модератор
  • Спасибо за ответ! К сожалению ни один из вариантов не работает. Более того, если изменить dnx с 451 на 561 все виснет. Тикет есть на github
    • Помечено в качестве ответа umputun 14 января 2016 г. 7:15
    14 января 2016 г. 7:15