none
Веб-развертывание RRS feed

  • Вопрос

  • Здравствуйте!

    Подскажите пожалуйста как мне сконфигурировать IIS на windows 8.1, таким образом, что бы стало возможным опубликовать сайт на этой машине удаленно, используя стандартный механизм Web Deploy Visual Studio 2013.

    При попытке публикации удаленно, получаю вот что: 

    Ошибка 1 Не удалось выполнить задачу Web Deploy. (Не удалось подключиться к удаленному компьютеру ("MyIP"). На удаленном компьютере проверьте, установлено ли веб-развертывание и запущен ли требуемый процесс ("Служба управления сетью").  Дополнительные сведения: http://go.microsoft.com/fwlink/?LinkId=221672#ERROR_DESTINATION_NOT_REACHABLE.)

    При попытке публикации локально, но используя IP компьютера, получаю то же самое.

    При публикации на localhost все отлично работает.

    - Пол дня чтения буржуйских форумов, мануалов, пошаговых руководств ничего не дало.

    - Брандмауэр выключен.

    - "Служба управления сетью" отсутствует

    - "Служба веб-публикаций" запущенна

    - Никаких настроек типа разрешить удаленную публикацию в IISе не обнаружено.

    Вот, что установлено:

    Помогите пожалуйста, кто знает решение.

Ответы

  • Хорошо, понятно. Попробуйте сохранить обе конфигурации в файле, если они не сохранены и посмотрите в текстовом редакторе, пути к службе публикации, возможно у них неверно генерируются адреса. Там должно быть нечто подобное: MSDeployServiceURL="https://address:port/MsDeploy.axd;. Возможно проблема именно в этом. Также посмотрите это руководство диагностики проблем в IIS.

    Сделаем содержимое сообщества лучше, вместе!

    Модератор

Все ответы

  • Очень трудно дать совет в подобной ситуации. Вам, наверное стоит ещё раз повнимательней пройтись по шагам, возможно, что то было упущено. Посмотрите эту статью, если не смотрели. Возможно проблема в разрешении доступа к серверу.

    Сделаем содержимое сообщества лучше, вместе!

    Модератор
  • Здравствуйте, спасибо за ваше участие в решении проблемы.

    К сожалению, я уже выполнял все инструкции из этой статьи. Не помогло.

    Возможно, я не совсем понятно описал в топике одну ситуацию, и думаю, что именно она, в этом вопросе показательная и ключевая, и содержит в себе "половину ответа". Вот смотрите, это компьютер на котором установлен IIS и VS2013:

    Вот так работает:

    А вот так, уже нет:


    • Изменено JusteG 21 мая 2014 г. 2:59
  • Хорошо, понятно. Попробуйте сохранить обе конфигурации в файле, если они не сохранены и посмотрите в текстовом редакторе, пути к службе публикации, возможно у них неверно генерируются адреса. Там должно быть нечто подобное: MSDeployServiceURL="https://address:port/MsDeploy.axd;. Возможно проблема именно в этом. Также посмотрите это руководство диагностики проблем в IIS.

    Сделаем содержимое сообщества лучше, вместе!

    Модератор