none
Проблемы в VS 2010 c компонетном WebBrowser(Internet Explorer 9 RC) RRS feed

  • Вопрос

  • После установки в систему Internet Explorer 9 RC  в компоненте WebBrowser проявилась проблема с процедурами

    WebBrowser.DocumentText и WebBrowser.ActiveXInstance.document.designmode = "On"

    При инициализации компонента designmode = "On" Работает

    Но стоит в компонент передать текст с помощью DocumentText перестает редактироваться )

     

    Также при активизации WebBrowser.ActiveXInstance.document.designmode = "Off" все удаляется

    Компонент добавляется в Пользовательском элементе управления

     Public Sub New()
    
      InitializeComponent()
    
      Try
    
       WebBrowser.DocumentText = ""
    
       WebBrowser.ActiveXInstance.document.designmode = "On"
    
      Catch
    
      End Try
    
     End Sub

    После инициализации в него передается содержимое с помощью

    WebBrowser.DocumentText

     

    27 февраля 2011 г. 12:18

Ответы

  • Здравствуйте, действительно такая проблема существует в верии RC. Возможно она будет исправлена в Release версии браузера. Интересно то, что проблема наблюдается при задание текса через DocumentText, если же создавать временную html страницу и загружать ее через метод Navigate, то все работает так, как надо. Попробуйте это обходное решение.

    Таже можете посмотреть обсуждение проблемы на stackoverflow - Internet Explorer 9 RC stops my WinForms WebBrowser control to work in editing mode. И также на контрол - Zeta HTML Edit Control, который использует мини-веб сервер, для задания текста в веб-браузере.

     


    Для связи [mail]
    • Помечено в качестве ответа Abolmasov Dmitry 12 марта 2011 г. 11:13
    2 марта 2011 г. 9:56