none
Для конструктора XAML требуется... RRS feed

  • Вопрос

  • Начал изучать c# и Visual Studio 2015, вылезает такое сообщение, когда нажимаешь на MainPage.xaml

    Для конструктора XAML требуется Центр Обновления Windows

    Важность: Информационное

    Описание: Версия целевой платформы windows 10 для проекта "название проекта" является более новой, чем текущая версия Windows 10. Обновите Windows 10, чтобы включить конструктор XAML и получить возможность использовать новые функции Windows.

    Стоит Windows 10, сборка 10240

    Центр обновления пишет, что версия ОС последняя

    microsoft.com



    • Изменено SPECTRUM151 20 января 2016 г. 14:09
    20 января 2016 г. 12:09

Ответы

Все ответы

  • Актуальная сборка Winddows 10, 10586.

    Так, что ваш центр обновления что то путает. Соответственно проблема в Windows, а не в VS


    VB.Net - WPF, UWP

    20 января 2016 г. 17:17
  • У меня такая же проблема. Если проблема в Windows, то как ее исправить?

    • Изменено AVIctor 5 февраля 2016 г. 12:07
    5 февраля 2016 г. 12:06
  • У меня такая же проблема. Если проблема в Windows, то как ее исправить?

    Обновить Windows, а так же проверить в вашем проект файл "ИмяПроекта.csproj" следующие строки:

        <TargetPlatformIdentifier>UAP</TargetPlatformIdentifier>
        <TargetPlatformVersion>10.0.10240.0</TargetPlatformVersion>
        <TargetPlatformMinVersion>10.0.10049.0</TargetPlatformMinVersion>

    И убедится, что значение TargetPlatformVersion корректно и не превышает сборку вашей ОС и установленного SDK.

    • Предложено в качестве ответа AVIctor 7 февраля 2016 г. 9:25
    5 февраля 2016 г. 12:26
  • Действительно превышает сборку ОС. Всегда, когда создаешь новый проект.

    Спасибо за помощь.

    7 февраля 2016 г. 9:30