none
VS 2010 with XNA 4.0 can't find AudioEngine class / VS 2010 с XNA 4.0 не может найти класс AudioEngine RRS feed

  • Вопрос

  • English:

    At the moment I am studying programming video games with XNA 4.0 on the book with the title "Learning XNA 4.0". The first problem that I encountered, and I can not solve it: development studio can not find the class AudioEngine, and the class WaveBank and others, when declaring objects in a class Game1:

    AudioEngine audioEngine;

    WaveBank waveBank;

    Error:

    Error 1 Can not find the name of a type or namespace "AudioEngine" (missing a using directive or an assembly reference?) C: \ Developer \ AnimatedSprites \ AnimatedSprites \ Game1.cs September 24 AnimatedSprites



    Although I use the line:

    using Microsoft.Xna.Framework;
    using Microsoft.Xna.Framework.Audio;

    and do everything by the book.

    In what could be the problem?

    Russian:

    В настоящий момент я изучаю программирование видео игр с XNA 4.0 по книжке с названием "Learning XNA 4.0". Первая проблема, с которой я столкнулся, и никак не могу решить ее: студия разработки никак не может найти класс AudioEngine, а также класс WaveBank и другие, при объявлении объектов в классе Game1:

    AudioEngine audioEngine;

    WaveBank waveBank;

    Выдается ошибка:

    Ошибка 1 Не удалось найти имя типа или пространства имен "AudioEngine" (пропущена директива using или ссылка на сборку?) C:\Developer\AnimatedSprites\AnimatedSprites\Game1.cs 24 9 AnimatedSprites

    Хотя я использую строчки:

    using Microsoft.Xna.Framework;
    using Microsoft.Xna.Framework.Audio;

    и делаю все по инструкции.

    В чем может быть проблема?

    29 ноября 2012 г. 21:11

Ответы

Все ответы