none
Partial Rendering не работает на iis 6 под 2003 RRS feed

  • Общие обсуждения

  • Попал в интересную ситуацию:
    есть простейший сWebApplication на ASP.NET, там просто поле, кнопка и Label, который в Updatepanel обновляется асинхронно с partialRendering из поля.

    Это все суперски работает на встроенном web-сервере VisualStudio 2010. Но вот возникла проблема с выносом его на win2003 на iis6, x64.
    Что получилось: есть DefaultWebSite, если кладу туда, то все работает отлично с PartialRendering
    если кладу его во вложенную VirtualDir в DefaultWebSite, то тоже все работает

    Кладу в свой web TestWeb, который у меня вместо DefaultWebSite, также все работает.
    Но стоит положить в какой-либо вложенный в TestWeb VirtualDir, то partialRendering перестает работать и работает полный rendering.

    Какими настройками это исправляется?
    Пробовал уже все: и aspnet_regiis -r и aspnet_regiis -с

    Собственно задача вот откуда появилась: есть веб, который работал, его слегка переписали и разместили в другом вебе. И тут начались проблемы. Вот начал тестировать.

    Может ли быть проблема в том, что у меня три уровня вложенности виртуальных директорий:
    WebSite/VirtDir1/VirtDir2/Default.aspx

    а если класть в WebSite/VirtDir1/Default.aspx, то работает.!

    18 ноября 2010 г. 6:40

Все ответы

  • Уважаемый пользователь!


    В вашей теме отсутствует активность в течение последних 5 дней. При отсутствии каких-либо действий в течение 2 последующих дней, тема будет переведена в разряд обсуждений. Вы можете возобновить дискуссию, просто оставив сообщение в данной теме


    Для связи [mail]
    22 ноября 2010 г. 22:03
    Модератор