none
ASP.NET установка Theme для всего сайта RRS feed

  • Вопрос

  • Доброго дня, подскажите, пожалуйста, в чем ошибка. Когда устанавливаю тему в web.config , находящийся в корне 

    <system.web>
            <pages theme="FirstTheme" />
    </system.web>

    появляется следующая ошибка:

    <fieldset>

    500.19 - Server error: Data for this file is configured improperly.

    The requested page cannot be accessed because of a configuration error.

    </fieldset>

    а когда тоже самое устанавливаю в web.config, находящиеся во вложенных папках - все нормально работает.

    Заранее благодарю.

    • Перемещено YatajgaEditor 20 октября 2013 г. 11:26
    19 октября 2013 г. 22:14

Ответы

  • А там ничего больше не прописываете, может символы какие случайные или дублирование данных. Возможно поэтому файл оказывается невалидным.

    Сделаем содержимое сообщества лучше, вместе!

    • Помечено в качестве ответа monteloro 20 октября 2013 г. 19:11
    20 октября 2013 г. 11:37
    Модератор

Все ответы

  • А там ничего больше не прописываете, может символы какие случайные или дублирование данных. Возможно поэтому файл оказывается невалидным.

    Сделаем содержимое сообщества лучше, вместе!

    • Помечено в качестве ответа monteloro 20 октября 2013 г. 19:11
    20 октября 2013 г. 11:37
    Модератор
  • Пробовал в ручную писать не помогает, пробовал из буфера вставлять в корневой web.config вставляю - выдаёт ошибку, в директории в web.config вставляю - все работает. Вставляю пустой блок в корневой web.config

        <system.web>
        </system.web> работает, как только вставляю в него же

       <pages theme="FirstTheme" /> или <pages theme="" />

    вылетает ошибка. Может у меня что-то с правами?

    20 октября 2013 г. 11:55
  • Странно как то. А если что то другое добавляете в корневой web.config, не относящееся к темам, опять ошибку выдаёт или нет?

    Сделаем содержимое сообщества лучше, вместе!

    20 октября 2013 г. 17:05
    Модератор
  • Уважаемый Yatajga, спасибо большое за помощь, сейчас внимательно пересмотрел весь web.config нашел дублирование раздела, при вставке AjaxControlToolkit  автоматически проставил <pages> я и не заметил. Сейчас вставил в него <pages theme="FirstTheme"> все заработало.

    20 октября 2013 г. 17:46