locked
WP7 эмулятор + XP Mode RRS feed

  • Вопрос

  • Добрый день!

    Возникла следующая проблема:

    Имеется Windows 7 x64 с установленным XP Mode и эмулятор Windows Phone 7. Так вот этот эмулятор не хочет запускаться пишет: "Запущен другой диспетчер виртуальных машин. Закройте ... тра-та-та".

    Собственно вопроса 2:

    1. Можно ли как-то заставить работать эмулятор вместе с другими виртуальными машинами?

    2. Если нет, то как выключить Virtual PC, чтобы эмулятор его не видел? (просто выключить виртуальные машины - не помогает).

    Спасибо!

    2 декабря 2011 г. 9:35

Ответы

  • Ну ошибка, которую говорит эмулятор именно об этом :)

    Да и если убить руками процесс vpc.exe, то эмулятор запускается (сам этот процесс, почему-то, при закрытии приложения, запущенного на virtual pc, не прибивается).

    А у вас если работает какое-то приложение на виртуалке - запускает эмулятор?

     

    Собственно после того, как я начал убивать его руками второй вопрос отпал, а вот на первый хотелось бы получить ответ.

    • Предложено в качестве ответа Abolmasov Dmitry 21 декабря 2011 г. 13:54
    • Помечено в качестве ответа MegaUxx 25 декабря 2011 г. 6:47
    2 декабря 2011 г. 12:54
  • Если запустить виртуалку, то эмулятор не работает у меня. Попробуйте просмотреть вот эту ветку.
    • Предложено в качестве ответа Abolmasov Dmitry 21 декабря 2011 г. 13:54
    • Помечено в качестве ответа MegaUxx 25 декабря 2011 г. 6:47
    2 декабря 2011 г. 13:30

Все ответы

  • Есть XP Mode и WP7 эмулятор запускается без проблем. Возможно ошибка на самом деле в другом.
    2 декабря 2011 г. 12:18
  • Ну ошибка, которую говорит эмулятор именно об этом :)

    Да и если убить руками процесс vpc.exe, то эмулятор запускается (сам этот процесс, почему-то, при закрытии приложения, запущенного на virtual pc, не прибивается).

    А у вас если работает какое-то приложение на виртуалке - запускает эмулятор?

     

    Собственно после того, как я начал убивать его руками второй вопрос отпал, а вот на первый хотелось бы получить ответ.

    • Предложено в качестве ответа Abolmasov Dmitry 21 декабря 2011 г. 13:54
    • Помечено в качестве ответа MegaUxx 25 декабря 2011 г. 6:47
    2 декабря 2011 г. 12:54
  • Если запустить виртуалку, то эмулятор не работает у меня. Попробуйте просмотреть вот эту ветку.
    • Предложено в качестве ответа Abolmasov Dmitry 21 декабря 2011 г. 13:54
    • Помечено в качестве ответа MegaUxx 25 декабря 2011 г. 6:47
    2 декабря 2011 г. 13:30
  • Не работает даже если везде (эмулятор, биос, Virtual PC) выключить железячную виртуализацию :(

    Может, конечно, что-то еще можно подкрутить, но с отключенной работает все ооочень медленно и это не вариант, а ускорение в железе в любом случае не возможно судя по фразе:

    The Emulator must have exclusive ownership of the hardware virtualization resource.

    Есть правда такая штука как Virtual Server (не представляю как там все работает) ... интересно, можно с помощью него как-то это все запустить и заставить работать ...

    3 декабря 2011 г. 16:32
  • The Emulator must have exclusive ownership of the hardware virtualization resource.

    Эта фраза как раз и говорит о том, что эмулятор не будет работать вместе с какой-либо запущенной виртуальной машиной. Также эмулятор не будет работать в виртуальной машине.

    Скорей всего работа эмулятора бок о бок с другими виртуальными машинами просто напросто невозможна. А если и возможна, то убытков в производительности вы понесете больше.


    Для связи [mail]
    21 декабря 2011 г. 13:53
  • Ну это тоже, что я написал, только другими словами ;)

    На самом деле вопрос снят, понятно, что нельзя заставить работать ... оставалась надежда на Virtual Server (он же умеет несколько виртуальных машин запускать), но это видимо очень сложно разрулить.

    25 декабря 2011 г. 6:47