none
Не запускается студия Microsoft Visual Studio 2013. Ошибка при запуске. (нет интерфейса???) RRS feed

  • Вопрос

  • Текст ошибки:

    ---------------------------
    Microsoft Visual Studio
    ---------------------------
    InvalidCastException:  Невозможно привести COM-объект типа "System.__ComObject" к интерфейсному типу "Microsoft.VisualStudio.Shell.Interop.IVsProfileDataManager". Операция завершилась со сбоем, поскольку вызов QueryInterface COM-компонента для интерфейса с IID "{466EFAF6-F832-4079-83CD-4BBB02719C1D}" возвратил следующую ошибку: Интерфейс не поддерживается (Исключение из HRESULT: 0x80004002 (E_NOINTERFACE)).
    
       в System.StubHelpers.StubHelpers.GetCOMIPFromRCW(Object objSrc, IntPtr pCPCMD, IntPtr& ppTarget, Boolean& pfNeedsRelease)
    
       в Microsoft.VisualStudio.Shell.Interop.IVsProfileDataManager.GetSettingsFiles(UInt32 fileLocations, IVsProfileSettingsFileCollection& ppCollection)
    
       в Microsoft.VisualStudio.Services.SignIn.ProfileSelectionPageDataSource.BuildProfilesCollection(IVsProfileDataManager profileDataManager, String defaultProfile)
    
       в Microsoft.VisualStudio.Services.SignIn.ProfileSelectionPageDataSource.<>c__DisplayClass1.<InitializeAsync>b__0()
    
       в System.Threading.Tasks.Task.InnerInvoke()
    
       в System.Threading.Tasks.Task.Execute()
    
    --- Конец трассировка стека из предыдущего расположения, где возникло исключение ---
    
       в System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)
    
       в System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
    
       в Microsoft.VisualStudio.Services.SignIn.PrepareForProfileSelectionPageDataSource.<InitProfileSelectionDataSourceAsync>d__0.MoveNext()
    
    
    ---------------------------
    ОК   
    ---------------------------
    

    Подскажите как можно исправить?  (недавно появились проблемы с реестром(вирус удалял что-то), после исправления появилась эта ошибка)

Ответы

  • Все , проблему решил.

    1. Восстановил права на доступ к реестру

    - не помогло

    2. Запускал студию со сбросом всех настроек

    - не помогло

    3. Переустановил студию

    - не помогло

    4. Удалил студию, установил студию, запустил со сбросом всех настроек

    - СРАБОТАЛО!!!  :)

    • Помечено в качестве ответа Karaulov 2 мая 2014 г. 15:22