none
Как сообщить технической поддержке об ошибке в загрузке Microsoft Visual C++ 2005? RRS feed

  • Вопрос

  • Обнаружил "ошибку" в загружаемом файле, но так и не смог донести ее до службы поддержки (не по телефону, не по эл. почте), т.е. может у кого побольше опыта, более грамотно озвучат ее (я простой пользователь и не программист) и направят куда надо? Суть ошибки:

    У Microsoft есть пакет Visual C++ 2005 (понимаю что он устарел, но все же...). Последняя версия 6.0.2900.2180 от 22 марта 2006:

        Microsoft Visual C++ 2005 (x86) https://www.microsoft.com/en-us/download/details.aspx?id=3387
        Microsoft Visual C++ 2005 (x64) https://www.microsoft.com/en-us/download/details.aspx?id=21254

    После него выходит обновления SP1 с версией 6.0.3790 от 19 февраля 2007:

        Microsoft Visual C++ 2005 SP1 (x86) https://www.microsoft.com/en-us/download/details.aspx?id=5638
        Microsoft Visual C++ 2005 SP1 (x64) https://www.microsoft.com/en-us/download/details.aspx?id=18471

    Потом Microsoft обнаруживает ошибки в системе безопасности ATL (20 июля 2009) и MFC (18 мая 2011) выпускает соответствующие обновления:

        Microsoft Visual C++ 2005 ATL https://www.microsoft.com/en-us/download/details.aspx?id=14431
        Microsoft Visual C++ 2005 MFC https://www.microsoft.com/en-us/download/details.aspx?id=26347

    В этих двух ссылках выше и кроется ошибка. Как видно в описании на сайте, обновления ATL и MFC якобы применены к SP1, т.е. версии 6.0.3790, однако если мы скачаем эти файлы и посмотрим их свойства, то увидим что их версии 6.0.2900.2180, т.е. обновления использованы на устаревшей версии Visual C++ 2005 (без SP1). Причем обращаю внимания, что обновления ATL и MFC, по отношению к Visual C++ 2008 и 2010, применены правильно, т.е. именно к SP1.

    В общем если кто может, сообщите об этой ошибке в Microsoft, я так понимаю желательно сразу в англоязычную поддержку, т.е. чтоб без "наших" посредников. Пусть либо загружаемые файлы поменяют, либо описание, убрав упоминание о SP1.

    P.S. И еще пару вопросов от/для меня лично:

        1. Я правильно понимаю, что если я установил скажем пакет Microsoft Visual C++ 2010 SP1 MFC (версия 10.0.40219.325) https://www.microsoft.com/ru-RU/download/details.aspx?id=26999 то основной пакет Visual C++ 2010 (версия 10.0.30319.1) https://www.microsoft.com/ru-RU/download/details.aspx?id=26999 и пакет обновления Visual C++ 2010 SP 1 (версия 10.0.40219.1) https://www.microsoft.com/ru-RU/download/details.aspx?id=26999 мне устанавливать (перед этим), не нужно, т.к. они уже входят в версию 10.0.40219.325?
        2. Я правильно понимаю, что пакеты Visual C++ разных годов не взаимозаменяемы, т.е. если приложение разработано с помощью Visual C++ 2008, то для работы с ним нужен исключительно он и тот же Visual C++ 2010 уже не подойдет?

    28 января 2016 г. 10:26