none
Проблема с переходом Microsoft ReportViewer 9.0»10.0 RRS feed

  • Вопрос

  • Добрый день!

    После перехода моего проекта Windows Forms возникла следующая проблема:

    В программе ранее использовались объекты Microsoft ReportViewer 9.0, после перехода на VS2010, я в Prefernces проекта изменил версию Microsoft ReportViewer 9.0 на Microsoft ReportViewer 10.0. У меня всё работает отлично, но вот на других компьютерах не работает - выдаёт ошибку в которой сказано что невозможно загрузить файл или сборку Microsoft ReportViewer 9.0, не удаётся найти указанный файл.

    Установка .Net Framework 3.5 SP1, и даже 4.0 RC - не помогла.

    • Перемещено Siddharth Chavan 2 октября 2010 г. 1:03 MSDN Forums Consolidation (От:Visual Studio - отзывы и пожелания)
    8 апреля 2010 г. 10:44

Ответы

  • Возможно Вы неправильно поняли мою проблему(либо я в последнем случае в качестве версии указал 9.0 вместо 10.0, хоть это и не суть важно), но ваше решение соответственно не помогает.

    Смог решить проблему, только следующим способом:

    В настройках билда нашёл скрытые компоненты, среди которых были 4 компонента Microsoft.ReportDesigner и установил для них значения: Publish Status - Include, Download Group - Required. После чего, в папке вмете с *.exe файлом при билде появились, те самые 4 *.dll файла Microsoft.ReportDesigner. Протестил работу проги на другом компе - всё норм. Правда вот весят эти *.dll порядка 10МБ, сравнительно с моей прогой 1,2 МБ... Но главное нашлось решение:)

    Несмотря на это спасибо за ответ, Megano.

    • Помечено в качестве ответа _CRBA_ 13 апреля 2010 г. 18:52
    13 апреля 2010 г. 18:52

Все ответы

  • Удалить с проекта References на Microsoft.ReportDesigner.dll и добавить по новой, после чего сделать ребилд. Как это сделать я писал вам тут .
    8 апреля 2010 г. 13:26
  • Возможно Вы неправильно поняли мою проблему(либо я в последнем случае в качестве версии указал 9.0 вместо 10.0, хоть это и не суть важно), но ваше решение соответственно не помогает.

    Смог решить проблему, только следующим способом:

    В настройках билда нашёл скрытые компоненты, среди которых были 4 компонента Microsoft.ReportDesigner и установил для них значения: Publish Status - Include, Download Group - Required. После чего, в папке вмете с *.exe файлом при билде появились, те самые 4 *.dll файла Microsoft.ReportDesigner. Протестил работу проги на другом компе - всё норм. Правда вот весят эти *.dll порядка 10МБ, сравнительно с моей прогой 1,2 МБ... Но главное нашлось решение:)

    Несмотря на это спасибо за ответ, Megano.

    • Помечено в качестве ответа _CRBA_ 13 апреля 2010 г. 18:52
    13 апреля 2010 г. 18:52