none
Microsoft Visual C++ 2015 x64 RRS feed

  • Вопрос

  • Пытался установить Microsoft Visual C++ 2015 х64 но выдает такое сообщение, мол уже установлено! но в установка его невидно(остальные Microsoft Visual C++ видны для удаления) пытался через программы удалить его, ничего не получается. Поставил все имеющиеся обновления виндовс и повторил еще раз, нету результата. Прошу помогите. ошибка 0х80070666 

    [1D8C:1C3C][2019-03-02T14:41:35]i001: Burn v3.7.3813.0, Windows v6.3 (Build 9600: Service Pack 0), path: C:\Users\Владимир\Downloads\vc_redist.x64 (3).exe, cmdline: ''
    [1D8C:1C3C][2019-03-02T14:41:35]i000: Setting string variable 'WixBundleLog' to value 'C:\Users\18EE~1\AppData\Local\Temp\dd_vcredist_amd64_20190302144135.log'
    [1D8C:1C3C][2019-03-02T14:41:35]i000: Setting string variable 'WixBundleOriginalSource' to value 'C:\Users\Владимир\Downloads\vc_redist.x64 (3).exe'
    [1D8C:1C3C][2019-03-02T14:41:35]i000: Setting string variable 'WixBundleOriginalSourceFolder' to value 'C:\Users\Владимир\Downloads\'
    [1D8C:1C3C][2019-03-02T14:41:35]i000: Setting string variable 'WixBundleName' to value 'Microsoft Visual C++ 2015 Redistributable (x64) - 14.0.24123'
    [1D8C:1C3C][2019-03-02T14:41:35]i100: Detect begin, 10 packages
    [1D8C:1C3C][2019-03-02T14:41:35]i000: File search: windows_uCRT_DetectKey, did not find path: C:\Windows\system32\ucrtbase.dll
    [1D8C:1C3C][2019-03-02T14:41:35]i000: File search: windows_uCRT_DetectKeyExists, did not find path: C:\Windows\system32\ucrtbase.dll
    [1D8C:1C3C][2019-03-02T14:41:35]i000: Setting numeric variable 'windows_uCRT_DetectKeyExists' to value 0
    [1D8C:1C3C][2019-03-02T14:41:35]i102: Detected related bundle: {d6f233bd-3f8c-43f6-878b-07bd0568d595}, type: Upgrade, scope: PerMachine, version: 14.10.25017.0, operation: Downgrade
    [1D8C:1C3C][2019-03-02T14:41:35]i108: Detected compatible package: vcRuntimeMinimum_x64, provider: Microsoft.VS.VC_RuntimeMinimumVSU_amd64,v14, installed: {8D4F7A6D-6B81-3DC8-9C21-6008E4866727}, version: 14.10.25017, chained: {FDBE9DB4-7A91-3A28-B27E-705EF7CFAE57}
    [1D8C:1C3C][2019-03-02T14:41:35]i103: Detected related package: {8D4F7A6D-6B81-3DC8-9C21-6008E4866727}, scope: PerMachine, version: 14.10.25017.0, language: 0 operation: Downgrade
    [1D8C:1C3C][2019-03-02T14:41:35]i108: Detected compatible package: vcRuntimeAdditional_x64, provider: Microsoft.VS.VC_RuntimeAdditionalVSU_amd64,v14, installed: {E512788E-C50B-3858-A4B9-73AD5F3F9E93}, version: 14.10.25017, chained: {21134089-9B59-34C8-BE11-929D26AD5207}
    [1D8C:1C3C][2019-03-02T14:41:35]i103: Detected related package: {E512788E-C50B-3858-A4B9-73AD5F3F9E93}, scope: PerMachine, version: 14.10.25017.0, language: 0 operation: Downgrade
    [1D8C:1C3C][2019-03-02T14:41:35]i052: Condition '(VersionNT = v6.3 AND NOT VersionNT64) AND (windows_uCRT_DetectKeyExists AND windows_uCRT_DetectKey >= v10.0.10240.0)' evaluates to false.
    [1D8C:1C3C][2019-03-02T14:41:35]i052: Condition '(VersionNT = v6.3 AND VersionNT64) AND (windows_uCRT_DetectKeyExists AND windows_uCRT_DetectKey >= v10.0.10240.0)' evaluates to false.
    [1D8C:1C3C][2019-03-02T14:41:35]i052: Condition '(VersionNT = v6.2 AND NOT VersionNT64) AND (windows_uCRT_DetectKeyExists AND windows_uCRT_DetectKey >= v10.0.10240.0)' evaluates to false.
    [1D8C:1C3C][2019-03-02T14:41:35]i052: Condition '(VersionNT = v6.2 AND VersionNT64) AND (windows_uCRT_DetectKeyExists AND windows_uCRT_DetectKey >= v10.0.10240.0)' evaluates to false.
    [1D8C:1C3C][2019-03-02T14:41:35]i052: Condition '(VersionNT = v6.1 AND NOT VersionNT64) AND (windows_uCRT_DetectKeyExists AND windows_uCRT_DetectKey >= v10.0.10240.0)' evaluates to false.
    [1D8C:1C3C][2019-03-02T14:41:35]i052: Condition '(VersionNT = v6.1 AND VersionNT64) AND (windows_uCRT_DetectKeyExists AND windows_uCRT_DetectKey >= v10.0.10240.0)' evaluates to false.
    [1D8C:1C3C][2019-03-02T14:41:35]i052: Condition '(VersionNT = v6.0 AND NOT VersionNT64) AND (windows_uCRT_DetectKeyExists AND windows_uCRT_DetectKey >= v10.0.10240.0)' evaluates to false.
    [1D8C:1C3C][2019-03-02T14:41:35]i052: Condition '(VersionNT = v6.0 AND VersionNT64) AND (windows_uCRT_DetectKeyExists AND windows_uCRT_DetectKey >= v10.0.10240.0)' evaluates to false.
    [1D8C:1C3C][2019-03-02T14:41:35]i101: Detected package: vcRuntimeMinimum_x64, state: Obsolete, cached: None
    [1D8C:1C3C][2019-03-02T14:41:35]i101: Detected package: vcRuntimeAdditional_x64, state: Obsolete, cached: None
    [1D8C:1C3C][2019-03-02T14:41:35]i101: Detected package: Windows81_x86, state: Absent, cached: None
    [1D8C:1C3C][2019-03-02T14:41:35]i101: Detected package: Windows81_x64, state: Absent, cached: Complete
    [1D8C:1C3C][2019-03-02T14:41:35]i101: Detected package: Windows8_x86, state: Absent, cached: None
    [1D8C:1C3C][2019-03-02T14:41:35]i101: Detected package: Windows8_x64, state: Absent, cached: None
    [1D8C:1C3C][2019-03-02T14:41:35]i101: Detected package: Windows7_MSU_x86, state: Absent, cached: None
    [1D8C:1C3C][2019-03-02T14:41:35]i101: Detected package: Windows7_MSU_x64, state: Absent, cached: None
    [1D8C:1C3C][2019-03-02T14:41:35]i101: Detected package: WindowsVista_MSU_x86, state: Absent, cached: None
    [1D8C:1C3C][2019-03-02T14:41:35]i101: Detected package: WindowsVista_MSU_x64, state: Absent, cached: None
    [1D8C:1C3C][2019-03-02T14:41:35]i052: Condition 'VersionNT64 >= v6.0 OR (VersionNT64 = v5.2 AND ServicePackLevel >= 1)' evaluates to true.
    [1D8C:1C3C][2019-03-02T14:41:35]i199: Detect complete, result: 0x0
    [1D8C:05B0][2019-03-02T14:41:38]e000: Error 0x80070666: Cannot install a product when a newer version is installed.

     
    2 марта 2019 г. 11:44

Ответы

  • Здравствуйте.

    Судя по всему, у Вас уже установлен распространяемый пакет VC++ 2017. Поскольку мажорная версия и у 2015 и у 2017 одна (14.xx.xx.xx), установка "более старой" версии не производится. Таким образом, пакет VC+ 2015 Вам не нужен.

    Если же какая-либо программа требует исключительно версию 2015 , прежде удалите 2017-ю.


    Если сообщение помогло Вам, пожалуйста, не забудьте отметить его как ответ данной темы. Удачи в программировании!

    • Помечено в качестве ответа Mifis 4 марта 2019 г. 17:03
    4 марта 2019 г. 14:36

Все ответы

  • Здравствуйте.

    Судя по всему, у Вас уже установлен распространяемый пакет VC++ 2017. Поскольку мажорная версия и у 2015 и у 2017 одна (14.xx.xx.xx), установка "более старой" версии не производится. Таким образом, пакет VC+ 2015 Вам не нужен.

    Если же какая-либо программа требует исключительно версию 2015 , прежде удалите 2017-ю.


    Если сообщение помогло Вам, пожалуйста, не забудьте отметить его как ответ данной темы. Удачи в программировании!

    • Помечено в качестве ответа Mifis 4 марта 2019 г. 17:03
    4 марта 2019 г. 14:36
  • спасибо за совет! в инете ненашел такой информации! теперь буду знать!))
    4 марта 2019 г. 17:03