none
Microsoft Visual Studio Installer Project . Выбор версии NET Framework RRS feed

  • Вопрос

  • Всем доброго времени суток.

    C# Visual Studio 2017 Community.
    В свойствах проекта который будет упаковыватся выбираю: Приложение->Целевая платформа=.NET Framework 4
    С помощью Visual Studio Installer Project выполняю сборку файлов Setup.exe и Setup.msi.
    В свойствах Setup Deployment Projects, вкладка "Условия запуска"(Launch Conditions)
    выбираю для .NET Framework: Version=.NET Framework 4,
    Install URL: https://www.microsoft.com/ru-RU/download/details.aspx?id=17718


    Когда запускаю Setup.msi на Windows c предварительно установленным Framework ниже версии 4, то появляется окно с предложение установить NET Framework 4:

    Когда запускаю Setup.exe появляется окно с предложение установить NET Framework 4.6.1:


    Как сделать чтобы при запуске Setup.exe появлялось окно с предложением установить NET Framework 4 ???

    Где-то запомнилась версия 4.6.1...

    Примечание:

    Пробовал добавлять в Visual Studio другие пакеты для разработчиков для версии 4.6.2, 4.7.2 и 4.8 попрежнему при запуске
    Setup.exe появляется предложение установить NET Framework 4.6.1.

    При запуске setup.exe и setup.msi с предварительно выбранной целевой платформой и условиями запуска(выбираю URL и версию > 4.6.1) выше 4.6.1 результат одинаковый для обоих файлов.



    • Изменено Y_VS 15 сентября 2019 г. 13:56
    15 сентября 2019 г. 11:58