none
Использование разных тулсетов внутри одной IDE по одной лицензии RRS feed

  • Вопрос

  • Привет, у нас в компании встал такой вопрос:

    Имеем некоторое количество проектов, которые собираются на v110 (vs2012). Собираемся обновляться до v142, при этом что-то останется на старом тулсете. Вот в чем вопрос:

    Можно ли использовать в vs2019 одновременно v110 и v142, имея только 1 лицензию?

    13 июля 2020 г. 7:51

Ответы

  • Здравствуйте,

    Насколько мне известно в 2017/2019 версиях VS, более старые версии toolset можно установить как дополнительные компоненты, без необходимости устанавливать более старые VS.

    Можете посмотреть также этот блог: https://devblogs.microsoft.com/cppblog/stuck-on-an-older-toolset-version-move-to-visual-studio-2015-without-upgrading-your-toolset/

    Правда он про 2017, но думаю суть не изменилась.


    Если Вам помог чей-либо ответ, пожалуйста, не забывайте жать на кнопку "Предложить как ответ" или "Проголосовать за полезное сообщение" Мнения, высказанные здесь, являются отражение моих личных взглядов, а не позиции корпорации Microsoft. Вся информация предоставляется "как есть" без каких-либо гарантий.

    • Помечено в качестве ответа Glen Sand 13 июля 2020 г. 8:36
    13 июля 2020 г. 8:20
    Модератор

Все ответы

  • Здравствуйте,

    Насколько мне известно в 2017/2019 версиях VS, более старые версии toolset можно установить как дополнительные компоненты, без необходимости устанавливать более старые VS.

    Можете посмотреть также этот блог: https://devblogs.microsoft.com/cppblog/stuck-on-an-older-toolset-version-move-to-visual-studio-2015-without-upgrading-your-toolset/

    Правда он про 2017, но думаю суть не изменилась.


    Если Вам помог чей-либо ответ, пожалуйста, не забывайте жать на кнопку "Предложить как ответ" или "Проголосовать за полезное сообщение" Мнения, высказанные здесь, являются отражение моих личных взглядов, а не позиции корпорации Microsoft. Вся информация предоставляется "как есть" без каких-либо гарантий.

    • Помечено в качестве ответа Glen Sand 13 июля 2020 г. 8:36
    13 июля 2020 г. 8:20
    Модератор
  • Да, в vs installer можно поставить вплоть до v140, но более старых я не увидел. Это и насторожило.
    13 июля 2020 г. 8:34