none
Visual Studio 2010 и NF 2.0 RRS feed

  • Вопрос

  • Создаю новый проект на Visual C++(windows forms), хочу, чтоб приложение работало даже на старых версиях Windows (xp ...), для этого выбираю net framework 2. Проект создается нормально, но при отладке или компиляции "вываливается" такая ошибка: 

    "Не удается запустить отладчик. Параметр VSInstallDir отсутствует или пуст." 

    Так происходит, при любом net framework'e, кроме 4.0; 

    как уладить эту проблему? (проекту достаточно стандартных базовых классов, нет потребности в NF, выше 2.0)

    НЕВАЖНО, в каком режиме, и дебаг и релиз, все равно эта ошибка


    Проект без единого добавленного Мной символа. 

    У меня стоит Ultimate VS2010 на Windows 7 x64.

    20 июня 2012 г. 5:50

Ответы

  • А Visual Studio 2008 у вас стоит? Проекты Visual C++ для .Net Framework ниже 4ой версии в Visual Studio 2010 требуют наличия Visual Studio 2008.

    Собственно я получаю такую ошибку при попытке компиляции:

    Error 1 error MSB8009: .NET Framework 2.0/3.0/3.5 target the v90 platform toolset. Please make sure that Visual Studio 2008 is installed on the machine.

    Для связи [mail]

    • Помечено в качестве ответа Abolmasov Dmitry 28 июня 2012 г. 12:48
    20 июня 2012 г. 6:56