none
Не работают кнопки управления эмулятором RRS feed

  • Вопрос

  • Добрый день!

    Возникла проблема с эмулятором в VS2015, а именно не работают кнопки управления эмулятором (тачскрином), они не активны и отображаются серым цветом. При нажатии на иконки приложение (да вообче хоть на что на экране эмулятора) ничего не происходит. В итоге я не могу запустить ни одно приложение в эмуляторе. С чем это связано?



    19 июля 2016 г. 19:27

Ответы

  • Что нужно сделать 

    1. Откройте Hyper V Manager
    2. Удалите все Виртуальные Машины 
    3. Убедитесь что все файлы в C:\Users\*******\AppData\Local\Microsoft\XDE\10.0.10586.0\  удалены
    4. Удалите все Virtual Switches
    5. Перезагрузите компьютер
    6. Откройте VS и запустите эмулятор 




    21 июля 2016 г. 3:38

Все ответы

  • Добрый день,

    Если перезапуск не помогает вы можете востоновить эмулятор , откройте Панель управления в списке установленных програм найдите Microsoft Emulator нажмите правой кнопкой мыши и выберите Изменить.

    Вы также можете удалить образы виртуалных дисков которые находятя в 

    C:\Users\*******\AppData\Local\Microsoft\XDE\10.0.10586.0

    20 июля 2016 г. 11:52
  • Всё сделал. Результат тот же - кнопки не активны. Забыл раньше упомянуть, что при запуске эмулятора всплывают два окна.

    Сначала окно с такой надписью: "Attempting to modify switch settings.

    The emulator is changing the settings of the internal switch so that your emulator can function."

    Что в переводе примерно следующее:"Попытка изменить настройки коммутатора.

    Эмулятор изменит настройки внутреннего коммутатора, чтобы ваш эмулятор смог функционировать."

    А потом второе: "The emulator is unable to connect to the device operating system:
    The emulator is unable to determine the host IP address, which is used to communicate with the guest virtual machine.
    Some functionality might be disabled."

    Что в переводе примерно следующее:" Эмулятор не может подключиться к операционной системе устройства:
    Эмулятор не может определить IP-адрес хоста, который используется для связи с гостевой виртуальной машиной. Некоторые функции могут быть отключены."

    20 июля 2016 г. 20:01
  • Что нужно сделать 

    1. Откройте Hyper V Manager
    2. Удалите все Виртуальные Машины 
    3. Убедитесь что все файлы в C:\Users\*******\AppData\Local\Microsoft\XDE\10.0.10586.0\  удалены
    4. Удалите все Virtual Switches
    5. Перезагрузите компьютер
    6. Откройте VS и запустите эмулятор 




    21 июля 2016 г. 3:38
  • Большое Вам спасибо за совет! Помогло, всё работает теперь!!!
    21 июля 2016 г. 17:48