locked
Странная проблема. Приложение перестает работать после публикации в магазине RRS feed

  • Общие обсуждения

  • Приветствую. 

    Столкнулся со странной проблемой. Приложение прекрасно работает в эмуляторе и на устройстве (с VS), но после публикации в магазине перестает. Судя по ошибке проблемы с подключением (или скорее всгео сервер бросает WebException). Как такое происходит, не понимаю. Раньше уже замечал, что владельцы ресурса банили запросы с определенных User-Agent. Могут ли как нибудь отличаться веб запросы от неподписанной версии приложения и подписанной? Есть ли какие варианты отдебажить подписанное приложение? Поставить его через Deployment Tool я кстати не могу, тролько через магазин (выдает Error: End of Central directory could not be found"

    Спасибо. 

    UPD: Проблема решена. Оказалось, что запросы откланял сам сервер. Если в WebClient не указывать Referer то по-дефолту там будет GUID приложения, а GUID приложения в магазине и в VS рызный.
    23 декабря 2015 г. 9:33

Все ответы

  • Вы проверяли работоспособность приложения в режиме Debug или Release на своих устройствах? Столкнулась с тем, что мое приложение UWP отлично работает в режиме Debug и валится с кучей ошибок в режиме Release... Почему так происходит пока не разобралась, никто не помог даже советом...

    • Изменено Liliya Muray 23 декабря 2015 г. 10:06
    23 декабря 2015 г. 10:06
  • Во всех кофигурациях работает. Есть подозрение, что банят специально, по какому-то параметру HTTP реквеста
    23 декабря 2015 г. 10:19