none
SimpleMembership и Azure RRS feed

  • Вопрос

  • Здравствуйте! У меня есть сайт в котором используется SimpleMembersipProvider. Когда я разворачиваю сайт на локальном сервере VS всё работает. Однако если я загружаю на Azure, то появляются проблемы.

    1) Если я кликаю на регистрация один раз, то всё работает. Если потом не меняя данные в форме ещё раз, то тоже приходит реквест что пользователь создан (хотя по логике программы два пользователя не создаются, на лок. пк так и есть)

    2)Если я меняю данные, то мне надо нажать два раза что-бы запрос отправился. почему так?

    Ошибок в консоли не каких не вылазит. Если приходит ответ, пользователь создан, то и ответ сервера нормальный.

    Если пользователь не создан, то приходит ответ 500 с непонятной ошибкой

    Вот адрес сайта

    www.eatitnow.ru

    http://eattest.azurewebsites.net/

    Там посередине кнопка регистрация

    9 августа 2013 г. 12:02

Все ответы

  • Это сейчас реклама или реально нужна помощь?

    Сделаем содержимое сообщества лучше, вместе!

    18 августа 2013 г. 18:52
    Модератор
  • Да какая ж реклама, тут на форуме)

    Помощь бы получить хотелось)

    18 августа 2013 г. 18:56
  • там действительно не работает регистрация

    предлагаю вам использовать WebMatrix - среда разработки

    18 августа 2013 г. 20:45
  • Что значит использовать WebMatrix, это прикол такой?))

    Я и так подключаю пространство имен WebMatrix.WebData


    p.s. Прочитал про WebMatrix. Вы имеете ввиду что там можно выложенный на Azure сайт удалённо редактировать?
    19 августа 2013 г. 5:04
  • да. гораздо легче студии, и есть все что нужно. а еще мгновенный паблиш
    19 августа 2013 г. 7:27
  • Ну я как бы и со студией справляюсь, тем более в фирме везде VS стоит, не думаю что webmatrix мне её полноценно заменит)

    А вот удалённо сайты на Azure отлаживать это конечно хорошая возможность.

    Неужели в студии нет такой возможности. Подозреваю она просто где-то запрятана

    19 августа 2013 г. 7:35