none
Sharepoint 2013 не выполняется рабочий процесс

    Общие обсуждения

  • Добрый день.

    Сразу скажу с SharePoint 2013 не общался очень давно. Установлен он в базовой конфигурации только для совместной работы с документами по средствам OneDrive.

    Но вот пришло время и был достигнут лимит в 5000 элементов на библиотеку. Когда как в самом SharePoint можно увеличить лимит, то OneDrive настроек не имеет и отказывается работать с библиотекой в 5000+1 элементов. Придумали архивировать лишние документы. Решено сделать через рабочий процесс SharePoint по инструкции. Для начала SharePoint Designer не нашел рабочие процессы SharePoint Workflow 2013. Использовали эту инструкцию. Не завелось, помогла эта инструкция. Теперь Designer все видит, создает и публикует рабочие процессы.

    И вот тут я теряюсь. Рабочий процесс создан, но не отрабатывает. И где искать ошибку я не понимаю.

    Где можно посмотреть логи? Потому что в стандартных местах ошибок не вижу.

    Спасибо.


    Уши есть не только у стен.

    15 июня 2017 г. 8:48

Все ответы

  • При публикации рабочего процесса в библиотеку вы настроили "Параметры запуска Рабочих процессов"? Т.к. по умолчанию при публикации стоит только вручную. 



    15 июня 2017 г. 9:40
  • Конечно поставил, в инструкции это явно указано.

    Удалось добыть ошибку:

    Отсутствует реализация метода "StartWorkflowOnListItem" в типе "Microsoft.SharePoint.WorkflowServices.FabricWorkflowInstanceProvider" из сборки "Microsoft.SharePoint.WorkflowServices, Version=15.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c".
    Технические подробности

    Идентификатор взаимосвязи: 86defb9d-8f80-c076-857f-d10bc0a19f7d


    Уши есть не только у стен.

    15 июня 2017 г. 12:33
  • Конечно поставил, в инструкции это явно указано.

    Удалось добыть ошибку:

    Отсутствует реализация метода "StartWorkflowOnListItem" в типе "Microsoft.SharePoint.WorkflowServices.FabricWorkflowInstanceProvider" из сборки "Microsoft.SharePoint.WorkflowServices, Version=15.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c".
    Технические подробности

    Идентификатор взаимосвязи: 86defb9d-8f80-c076-857f-d10bc0a19f7d


    Уши есть не только у стен.

    Тогда рекомендую проверить случайно не из под системной учетной записи пытаетесь запустить рабочий процесс?
    15 июня 2017 г. 13:12
  • Тогда рекомендую проверить случайно не из под системной учетной записи пытаетесь запустить рабочий процесс?

    Подскажите где явно это проверить.

    Если смотреть приложения-службы то там запущено не от системной, а от специально созданной для этого записи. Даже создан новый отдельный пул приложений. Все службы запущены и службы-приложения тоже.


    Уши есть не только у стен.

    16 июня 2017 г. 9:21
  • в ЦА выберите приложение и там есть UserPolice ...погуглите...там можно посмотреть системная учетка или нет

    Так же вы говорите  запускается...тоесть в представлении списка столбец с рабочим процессом пуст? или там всетки что то написано


    19 июня 2017 г. 10:08
  • Учетка не системная, а специально созданная service_app.

    А вот в представлении списка столбец пуст


    Уши есть не только у стен.

    21 июня 2017 г. 8:38