none
SMux Provider: Physical connection is not usable

    Întrebare

  • Below the Server details:

    We have built an application in Symfony as backend and Angular JS as frontend. We are facing an issue in application on connecting to Azure SQL server. Here's the error:

    "An exception occurred while executing 'SELECT count(r0_.id) AS sclr_0 FROM reports r0_':\n\nSQLSTATE [08S02, -1]: [Microsoft][ODBC Driver 13 for SQL Server]SMux Provider: Physical connection is not usable [xFFFFFFFF]. \nSQLSTATE [08S02, -1]: [Microsoft][ODBC Driver 13 for SQL Server]Unable to open a logical session"



    Have anyone faced this issue? I searched but couldn't find any solution. Note that this error occurs only on certain queries and not on all queries. A lot of queries seem to work fine.

    Here are the version combinations we have tried:

    Combination 1:

    DriverName: libmsodbcsql-13.1.so.8.0

    DriverODBCVer: 03.52

    DriverVer: 13.01.0008

    ExtensionVer: 4.0.8.0 49

    PHP: v7.0.30-0ubuntu0.16.04.1

    Combination 2:

    DriverName: libmsodbcsql-13.1.so.9.0

    DriverODBCVer: 03.52

    DriverVer: 13.01.0009

    ExtensionVer: 4.3.0

    PHP: v7.0.30-0ubuntu0.16.04.1

    miercuri, 16 mai 2018 22:18

Toate mesajele

  • Hi Neerav,

    Have you taken a look at this forum post: SQLSTATE = 08S02, SMux Provider Physical connection is not usable

    It references a Microsoft Support solution that seems to address the solution: 

    I'm an SQL Server engineer from Microsoft. I will be happy to help you on this issue.

    I have noticed "did not have a network disconnect at the time the user reported this error (14:57)." However, the isssue "SMux Provider: Physical connection is not usable [xFFFFFFFF]." is usually caused by a network issue. And most of them are related to SNP (see, http://support.microsoft.com/kb/942861).

    The SNP features was introduced aimed at improving performance while the drivers used by SQL Server cannot work with these features very well. It is recommended to disable these features on both your server and client by executing below commands in CMD:

    • netsh interface tcp set global chimney=disabled
    • netsh interface tcp set global rss=disabled
    • netsh interface tcp set global NetDMA=disabled

    You need to restart your machine to make above settings take effect.

    Best regards,

    - - - -

    I hope this helps,

    Mike

    Note: If this addresses your issue please mark this as answered in an effort to assist others who are looking for the same information. 

    miercuri, 16 mai 2018 22:54
    Moderator