none
Cannot Add Elastic Tooling to Existing Shards - .dll Issue

    Întrebare

  • I am attempting to add elastic tooling to an existing shard set in an Azure elastic pool by following the below and using Windows Powershell ISE. 

    https://docs.microsoft.com/en-us/azure/sql-database/sql-database-elastic-convert-to-use-elastic-tools

    The first piece of powershell fails and asks me to check the Import-Module ShardElasticityModule. When running this it stages the "...ElasticScale.Client.dll" is not present in the "..\WindowsPowershell\Modules\ShardElasticityModule" folder. 

    The only way I could seem to get the dll to the module folder was downloading it manually from below, converted the nupkg to a zip file, retrieved the dll and added it to the powershell module folder. 

    https://www.nuget.org/packages/Microsoft.Azure.SqlDatabase.ElasticScale.Client/1.3.3

    Now I get the error cannot load file or assembly "...ElasticScale.Client.dll" or one of its dependencies. I've tried many combinations of the files being in the "..\WindowsPowershell\Modules\ShardElasticityModule" folder, and different downloads of the dll, but get the same error. 

    Could anyone please assist? 

    Thanks

    12 mai 2018 12:50

Toate mesajele