none
Habilitar Microsoft DAO 3.6 Object Library na janela de referências VBE RRS feed

  • Pergunta

  • Olá a todos,

    Preciso de ajuda para conseguir resolver o problema da referência Microsoft DAO 3.6 Object Library que não aparece na janela de referências do VBE.
    Ao abrir a janela de referências do VBE pelo meu notebook a biblioteca DAO não aparece. Não é aquele erro comum que é escrito "AUSENTE" na referência, não, ela simplesmente não aparece.
    Quando eu consulto na janela do VBE de qualquer outro computador a referência aparece normalmente.

    Para resolver o problema eu já:
    > Instalei o Office novamente
    > Atualizei a DLL dao360
    > Registrei novamente o arquivo DLL pelo cmd com êxito porém o problema não foi resolvido

    Abaixo exibo a janela de como aparece corretamente.

    Janela do VBProject com a referência DAO

    E abaixo como aparece a janela do VBE no meu notebook.

    Janela de bibliotecas VBE sem a referência DAO

    Já não sei mais o que posso fazer para resolver este problema.

    Alguém tem alguma ideia para me ajudar?

    Desde de já agradeço.

    Eduardo

    domingo, 5 de abril de 2015 20:40

Respostas

  • Obrigado mas eu já consegui resolver o problema.

    Copiei a DLL de um novo computador, deletei a que existia no meu notebook e inseri a nova DLL System32, na SysWOW64 e na pasta do DAO.

    Depois executei dois comandos pelo cmd, um para remover o registro da antiga DLL e o outro para inserir o registro da nova DLL, resolvendo o problema.

    Obrigado pelo ajuda.

    Eduardo


    terça-feira, 7 de abril de 2015 01:02

Todas as Respostas

  • Ola

    Amigo ja faz muito tempo que não utilizo o DAO 3.6 mas essas referencias creio que em versões de Windows mais novas não estão disponíveis, segue link abaixo que pode te ajudar.

    https://support.microsoft.com/en-us/kb/233002?wa=wsignin1.0

    Outro ponto você poderia usar o ADO pois com ele você poderia usar o MDAC.


    Junior

    domingo, 5 de abril de 2015 21:57
  • Realmente obrigado pela ajuda, mas ainda meu problema está sem solução.

    Eu utilizo ADO nas minhas aplicações VBA, porém vou continuar a buscar uma solução porque acho DAO muito útil.

    Mas obrigado novamente.

    Eduardo

    segunda-feira, 6 de abril de 2015 00:29
  • Ok, abaixo segue alguns links que achei na internet, podem te ajudar

    http://comunidade.itlab.com.br/eve/forums/a/tpc/f/273606921/m/2321006871
    http://support.microsoft.com/en-us/kb/233002


    Junior

    segunda-feira, 6 de abril de 2015 23:19
  • Obrigado mas eu já consegui resolver o problema.

    Copiei a DLL de um novo computador, deletei a que existia no meu notebook e inseri a nova DLL System32, na SysWOW64 e na pasta do DAO.

    Depois executei dois comandos pelo cmd, um para remover o registro da antiga DLL e o outro para inserir o registro da nova DLL, resolvendo o problema.

    Obrigado pelo ajuda.

    Eduardo


    terça-feira, 7 de abril de 2015 01:02