none
local roda diferente publish RRS feed

  • Pergunta

  • Pessoal,

    Tenho uma aplicação asp.net rodando em um servidor. Assim como todo mundo, faço minhas alterações na minha máquina, rodo utilizando IIS express que o visual studio emula e quando quero subir pro servidor, publico e jogo os arquivos lá.

    Acontece que tudo funciona perfeito, com exceto a um probleminha relacionado a uma parte específica do site. Pesquisei qual arquivo do publish poderia não estar indo pra achar a diferença entre o servidor e a minha máquina local. Até que tive a ideia de acessar o servidor e entrar localhost. Entrei localhost e percebi que o problema lá também não existe.

    OBS: Já limpei o cache do navegador.

    Simplesmente nunca vi isso, alguém tem alguma ideia do que pode ser?

    Obrigado!

    terça-feira, 24 de junho de 2014 20:27

Respostas

  • Resolviiiiiiiiii!!!

    Apesar de ser bem estranho, resolvi o problema fazendo isso:

    data.setDate(data.getDate());

    Mas que bom que resolveuuu! Obrigado quem tentou ajudar aeee

    quinta-feira, 26 de junho de 2014 14:21

Todas as Respostas

  • Amigo, boa noite.

    Qual é o problema que está ocorrendo ? Se tiver como postar a mensagem ou print, será de grande valia.

    Abraços !


    Diego Murakami View Diego Murakami's LinkedIn profile - MCP, MS, MCSD
    * Por favor "Marcar como Resposta" caso esta for útil para sua dúvida.

    terça-feira, 24 de junho de 2014 21:16
  • Olá,

      siga o que o Diego disse, 

      somente uma outra questão, se alterou no Visual Studio Funciona no servidor não ! Provavelmente seu arquivo não foi alterado no server, copie e cole manualmente e limpe o cache do navegador cookie tudo que deve resolver !

    quarta-feira, 25 de junho de 2014 01:57
  • O problema que está acontecendo é que tenho um plugin Jquery que é o fullcalendar e quando cadastro uma nova tarefa para o calendário, coloco uma data e quando vejo no banco ele cadastra com a data certa. Porém, no calendário ele aparece em um dia anterior da que cadastrei. Sempre em um dia anterior. 

    Porém, tenho certeza de que os arquivos estão certos já que quando entro no servidor e rodo a aplicação local, ele consegue rodar sem problema nenhum. 

    Nunca vi um problema parecido e não sei o que mais posso fazer para arrumar isso "/

    quarta-feira, 25 de junho de 2014 12:31
  • Pessoal, 

    Uma outra dica que acabei de perceber... Rodando pelo servidor, tanto acessando localhost quanto acessando a página em produção, o problema não acontece. Mas pra mim isso não faz o menor sentido. Enfim, está muito estranho. 

    quinta-feira, 26 de junho de 2014 12:07
  • Estou investigando se tem diferença executar o javascript no brasil ou nos EUA pra pegar a data, já que o servidor está nos EUA. Vi isso por causa desse tópico no StackOverflow(O problema dele é o mesmo que o meu, mas esse date.setHours não funciona pra mim ou não estou sabendo usar): http://stackoverflow.com/questions/15759566/why-my-fullcalendar-saved-events-goes-to-the-day-before

    Se alguém souber de algo que ajude, por favor me avise. Obrigado!

    quinta-feira, 26 de junho de 2014 13:20
  • Estou atualizando com o que vou encontrando pra caso alguém tenha um problema parecido com o meu. Dessa vez eu praticamente encontrei o problema. 

    Dá uma olhada no meu console do Chrome:

    Só ainda não entendi o motivo do chrome tirar um dia e estou tentando ver de qual maneira resolver isso, mas o problema com certeza está nisso.

    quinta-feira, 26 de junho de 2014 14:01
  • Resolviiiiiiiiii!!!

    Apesar de ser bem estranho, resolvi o problema fazendo isso:

    data.setDate(data.getDate());

    Mas que bom que resolveuuu! Obrigado quem tentou ajudar aeee

    quinta-feira, 26 de junho de 2014 14:21