none
Arrastar e soltar, Formula SE com mais de 7 condições RRS feed

  • Pergunta

  • Boa noite pessoal,

     

    gostaria de resolver um problema que está me incomodando a muito tempo, e é de extrema urgência.

    Tenho o seguinte caso, preciso criar uma função SE em uma célula, mas tenho mais de 7 condições. Procurando pela web aprendi que para inserir a função SE com mais de 7 condições temos que colocar o $ entre a célula desejada, por exemplo: Se eu quiser fazer uma formula assim, =SE(B8=A1;falso) tenho que fazer dessa maneira =SE(B$8=A1;falso), até ai tudo bem, o meu problema de mais de 7 condições foi resolvido. Mas tive um outro problema, vou repetir essa formula para as célular abaixo, tentei a maneira "Arrastar" do excel para copiar a formula, mas ele não arrasta do jeito certo, por exemplo: Preciso dessa mesma formula na célula abaixo, ela deveria ficar assim =SE(B$9=A2; falso), e na outra célula =SE(B10=A3; falso), e assim por diante.

     

    Mas quando coloco o $ na fórmula ele não arrasta a célula corretamente, ele simplesmente copia e cola.

    Estou desesperando tentando resolver esse problema e ainda não consegui, espero que vocês possam me ajudar, e espero também que tenham entendido o meu problema...rsrsrs

    sexta-feira, 20 de maio de 2011 22:49

Respostas

  • Olá Jeferson bom dia,

    Jeferson na verdade o $ não interfere na quantidade de condições SE que você vai utilizar, o $ tem a função de criar referência ABSOLUTA no Excel, veja este vídeo que fiz sobre referência relativa, absoluta e mista explicando o que é referência Relativa e Absoluta no Excel.

    http://carloscitrangulo.wordpress.com/2011/05/21/microsoft-excel-referencia-relativa-absoluta-e-mista/

    Vamos a sua solução:

    Criei esta tabela simples no excel:

     


    E

    H
    3 Amarelo

    Cor 1
    4 Vermelho

    Cor 2
    5 Azul

    Cor 3
    6 Roxo

    Cor 4
    7 Verde

    Cor 5
    8 Preto

    Cor 6
    9 Rosa

    Cor 7
    10 Cinza

    Cor 9
    11 Magenta

    Cor 8

     

    Repare que nesta tabela estamos trabalhando com as colunas E e H. Fiz uma fórmula com 8 condições IF, veja como contrui esta fórmula:

    =SE(E3="Amarelo";"Cor 1";SE(E3="Vermelho";"Cor 2";SE(E3="Azul";"Cor 3";SE(E3="Roxo";"Cor 4";SE(E3="Verde";"Cor 5";SE(E3="Preto","Cor 6";SE(E3="Rosa";"Cor 7";SE(E3="Magenta";"Cor 8","Cor 9"))))))))

    Esta fórmula foi aplicada na célula H3, e foi utilizado o recurso de auto-preenchimento (Arrastar e soltar) e o resultado foi este que você está vendo na tabela acima.

    Nesta forma sem o $ (Referência Relativa), o Excel compara todas as células seguintes: E4, E5, E6....

    Se eu tivesse feito na forma com o $ (Referência Absoluta), o Excel irá comparar somente a célula da referência Absoluta $E$3.

    Veja como ficaria o resultado:

     

    E H
    3 Amarelo Cor 1
    4 Vermelho Cor 1
    5 Azul Cor 1
    6 Roxo Cor 1
    7 Verde Cor 1
    8 Preto Cor 1
    9 Rosa Cor 1
    10 Cinza Cor 1
    11 Magenta Cor 1


    A fórmula utilizada foi a seguinte:

    =SE($E$3="Amarelo";"Cor 1";SE($E$3="Vermelho";"Cor 2";SE($E$3="Azul";"Cor 3";SE($E$3="Roxo";"Cor 4";SE($E$3="Verde";"Cor 5";SE($E$3="Preto";"Cor 6";SE($E$3="Rosa";"Cor 7";SE($E$3="Magenta";"Cor 8";"Cor 9"))))))))

    Para que você compreenda melhor refaça a tabela acima e teste com as duas fórmulas e veja se consegue entender a diferença.

    Veja o vídeo que fiz acho que esclarecerá bem a diferênça entre referência relativa e absoluta.

    Espero ter ajudado, se sim, por favor marcar como resposta.

    Abraços,


    Carlos Carvalho Citrangulo Junior
    Microsoft Certified Professional
    Microsoft Certified Desktop Support Technician
    MCTS Microsoft Windows Vista Configuration
    MCITP Enterprise Support Technician
    Profissional 5 Estrelas Microsoft
    http://carloscitrangulo.wordpress.com
    sábado, 21 de maio de 2011 17:07