locked
Preciso de uma formula no excel que me diga quanto foi utilizado e o nome da pessoa! RRS feed

  • Pergunta

  • tipo

    tenho várias pessoas que precisam usar um determinado equipamento ,e a pessoa somente pode usar 8 horas no dia ,existe uma formula que pegue a pessoa pelo nome entre várias ,e diga a quantidade de horas que utilizou?

    segunda-feira, 25 de abril de 2011 12:17

Todas as Respostas

  • tipo

    tenho várias pessoas que precisam usar um determinado equipamento ,e a pessoa somente pode usar 8 horas no dia ,existe uma formula que pegue a pessoa pelo nome entre várias ,e diga a quantidade de horas que utilizou?


    william weverton 01:15
    william weverton 02:20
    william william 03:20
    robson william 03:20
    weverton robson 03:20
    william william 03:20
    weverton william 03:20
    segunda-feira, 25 de abril de 2011 13:02
  • Bom dia, usando a fórmula PROCV da pra você fazer isso.

    Se não, teria como você melhorar um pouco mais a descrição da sua dúvida?

    Colocando, exemplo:

    Colunas      A                   B                        C

                  william            01:15

                  robson            03:20

     

    e assim por diante.

    Ou seja colocar a descrição de como esta a sua planilha para que a gente saiba exatamente como usar cada fórmula.

     

    Abraço e ótimo dia

     

    segunda-feira, 25 de abril de 2011 14:00
  • william

    weverton 01:15
    william weverton 02:20
    william william 03:20
    robson william 03:20
    weverton robson 03:20
    william william 03:20
    weverton william 03:20

     

    tendo estas informaçoes quero saber a quantidade de horas exata que robson william e weverton executaram individualmente.

    segunda-feira, 25 de abril de 2011 15:02
  • Boa tarde Gilberto.

    Na colunas A e B, suponhamos que estejam os nomes ( William, Weverton, Robson e etc.)

    Na coluna C, a quantidade em horas.

     

    Na coluna F na célula F1 coloque a seguinte fórmula  =SE(A1="";"";SE(CONT.SE($A$1:A1;A1)=1;LIN();""))

    Na coluna G na célula G1 coloque a seguinte fórmula =SE(ÉERROS(INDIRETO("a"&MENOR($F:$F;LIN())));"";INDIRETO("a"&MENOR($F:$F;LIN())))

    Na culuna H na célula H1 coloque a seguinte fórmula =SE(G1="";"";SOMASE(A:A;G1;C:C))

    Na coluna I na célula I1 coloque a seguinte fórmula =SE(G1="";"";SOMASE(B:B;G1;C:C)) + H1

     

    Depois se quiser pode ocultar as colunas F e H..

     

    Se ficou como você queria não esqueça de fechar o seu POST e marcar como respondido.

     

    Abraço

    • Sugerido como Resposta Allvinho segunda-feira, 25 de abril de 2011 15:28
    segunda-feira, 25 de abril de 2011 15:28
  • isso pode ser feito rapidamente com dois somase()

     

    =somase( a1:a6 ; "william" ; c1:c6)  + somase( b1:b6 ; "william" ; c1:c6)

     

    se quiser saber o de outro colega, é só colocar o nome no lugar do "william"


    João Eurico Consultor Manguetown - Brazil
    sexta-feira, 29 de abril de 2011 14:49