none
.Offset(rowcount, 1).Value="Formula SE" RRS feed

  • Pergunta

  • Boa tarde!

    Estou com dificuldades em fazer com que a célula receba a seguinte formula usando o VBA

     estou tentando fazer com que a célula receba a formula =SE(D2<>"";SE(O2<>"Baixado";HOJE()-D2;P2-D2);"-")

     .Offset(rowcount, 1).Value = Application.ActiveCell.FormulaR1C1 = _
            "=IF(RC[-13]<>"""",IF(RC[-2]<>""Baixado"",RC[-13]-TODAY(),RC[-13]-RC[-1]),""-"")"

            

        rowcount = Worksheets("impressas").Range("a1").CurrentRegion.Rows.Count
         With Worksheets("impressas").Range("a1")
        .Offset(rowcount, 0).Value = Me.DtBoxVenc.Value

        .Offset(rowcount, 16).Value = Application.ActiveCell.FormulaR1C1 = _
            "=IF(RC[-13]<>"""",IF(RC[-2]<>""Baixado"",RC[-13]-TODAY(),RC[-13]-RC[-1]),""-"")"

            Sheets("Aut.Coleta").Select
    End With

    sexta-feira, 20 de junho de 2014 17:37

Respostas

  • Ao inserir um código no fórum, utilize blocos de código. Para utilizar essa ferramenta, clique no botão cuja legenda é “Inserir bloco de código” na barra do editor de mensagens do fórum. Uma janela aparecerá onde você deverá colar seu código cru na caixa de texto à esquerda. Então, selecione a opção Vb.Net na caixa de combinação que você verá em cima à esquerda e depois clique no botão Inserir.

    ---

    Tente:

    .Offset(rowcount, 16).Value = "=IF(D2<>"""",IF(O2<>""Baixado"",TODAY()-D2,P2-D2),""-"")"


    Felipe Costa Gualberto - http://www.ambienteoffice.com.br

    sexta-feira, 20 de junho de 2014 22:02
    Moderador