none
Erro com Database Projects pós SP1 (VS2010) RRS feed

  • Pergunta

  • Bom dia pessoal.

    Estou com um problema que começou após a instalação do Visual Studio 2010 SP1. Trabalhava com Database Projects normalmente, mas após o update, quando possuo um Database Project na Solution e executo o build, simplesmente o Visual Studio lança uma NotSupportedException, como podem ver no seguinte link: http://img860.imageshack.us/i/visualstudioerror.jpg/

    Alguém passou por este problema? Seria um bug do Service Pack?

    Obrigado desde já


    [MCTS] Silverlight 4/ASP.Net 3.5/WPF 3.5/WinForms 2.0
    segunda-feira, 21 de março de 2011 11:40

Respostas

  • Olá Alliston, tudo tranquilo?

    Estou com o SP1 instalado aqui e não tive problemas com um projeto do tipo Database (SQL Server 2008) que eu tinha aqui... Fiz o teste de criar um novo projeto do tipo Database, adicionei uma tabela e consigo dar o build normalmente também...

    Você chegou a testar esse seu projeto em algum outro computador com o SP1 instalado? Você tem muitos componentes de terceiros instalados aí? Pode ser que algum deles esteja dando conflito com o SP1 e, estranhamente, esteja fazendo com que essa exception seja lançada em projetos do tipo Database...

    Também fiz uma boa busca na web e não encontrei nenhuma referência a esse tipo de erro pós-SP1... Pode ser algum erro localizado da sua máquina que não está se entendendo com o SP1... =(


    André Alves de Lima
    Microsoft MVP - Client App Dev
    Visite o meu site: http://www.andrealveslima.com.br
    Me siga no Twitter: @andrealveslima
    sexta-feira, 25 de março de 2011 13:12
    Moderador

Todas as Respostas

  • Alliston, se você criar um DataBase project do zero acontece o mesmo erro?

     


    Abraço

    Estevam

    **** Se a reposta foi útil, então não esqueça de marca-lá. ***
    quinta-feira, 24 de março de 2011 01:09
  • Olá Estevam, obrigado pela resposta.

    Infelizmente, o erro ainda acontece mesmo criando um projeto do zero.

    O problema realmente está no ato de executar um build do projeto tipo Database, tanto é que, quando possuo um projeto destes na minha solution e o ignoro (Unload Project), o restante do projeto executa normalmente.

    Abraços!


    [MCTS] Silverlight 4/ASP.Net 3.5/WPF 3.5/WinForms 2.0
    quinta-feira, 24 de março de 2011 11:44
  • Olá Estevam, obrigado pela resposta.

    Infelizmente, o erro ainda acontece mesmo criando um projeto do zero.

    O problema realmente está no ato de executar um build do projeto tipo Database, tanto é que, quando possuo um projeto destes na minha solution e o ignoro (Unload Project), o restante do projeto executa normalmente.

    Abraços!


    [MCTS] Silverlight 4/ASP.Net 3.5/WPF 3.5/WinForms 2.0
    faz click na opcao procurar solucao na internet....
    Just Be Humble Malange!
    quinta-feira, 24 de março de 2011 16:08
    Moderador
  • Olá Alliston, tudo tranquilo?

    Estou com o SP1 instalado aqui e não tive problemas com um projeto do tipo Database (SQL Server 2008) que eu tinha aqui... Fiz o teste de criar um novo projeto do tipo Database, adicionei uma tabela e consigo dar o build normalmente também...

    Você chegou a testar esse seu projeto em algum outro computador com o SP1 instalado? Você tem muitos componentes de terceiros instalados aí? Pode ser que algum deles esteja dando conflito com o SP1 e, estranhamente, esteja fazendo com que essa exception seja lançada em projetos do tipo Database...

    Também fiz uma boa busca na web e não encontrei nenhuma referência a esse tipo de erro pós-SP1... Pode ser algum erro localizado da sua máquina que não está se entendendo com o SP1... =(


    André Alves de Lima
    Microsoft MVP - Client App Dev
    Visite o meu site: http://www.andrealveslima.com.br
    Me siga no Twitter: @andrealveslima
    sexta-feira, 25 de março de 2011 13:12
    Moderador
  • Olá André,

    No momento, estou criando uma VM e instalando o VS2010 + SP1 pra fazer essa validação.

    Possuo sim algumas extensões, mas cheguei a desabilitá-las e tentar executar a build, mas ainda sem sucesso.

    Assim que terminar a instalação e os testes com o SP1, vou colocar os resultados aqui :)

    Muito obrigado!


    [MCTS] Silverlight 4/ASP.Net 3.5/WPF 3.5/WinForms 2.0
    sexta-feira, 25 de março de 2011 13:15
  • E aí Alliston, deu certo?
    André Alves de Lima
    Microsoft MVP - Client App Dev
    Visite o meu site: http://www.andrealveslima.com.br
    Me siga no Twitter: @andrealveslima
    quarta-feira, 20 de abril de 2011 19:14
    Moderador
  • Poxa, desculpem pessoal!

    André, instalei a VM e tudo mais, consegui criar os database projects e compilar sem problemas. Após isso, tentei reinstalar minhas extensões mais comuns e o erro não apareceu mais.

    Acredito que é tudo uma questão de ordem de instalação, pois no host, mesmo depois de desinstalá-las, o erro persistiu. Enfim, o jeito agora é continuar com a VM, ou formatar novamente o host.

    Obrigado André, e mais uma vez, desculpe a demora pra responder.


    [MCTS] Silverlight 4/ASP.Net 3.5/WPF 3.5/WinForms 2.0
    quarta-feira, 20 de abril de 2011 19:25
  • Alliston,

    É... Às vezes acontece esse tipo de conflito mesmo... =(


    André Alves de Lima
    Microsoft MVP - Client App Dev
    Visite o meu site: http://www.andrealveslima.com.br
    Me siga no Twitter: @andrealveslima
    quinta-feira, 21 de abril de 2011 13:01
    Moderador